mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/2] /fs/partition/check.c : fix return value warning (V2)
@ 2008-05-13 20:02 Abdel Benamrouche
  0 siblings, 0 replies; only message in thread
From: Abdel Benamrouche @ 2008-05-13 20:02 UTC (permalink / raw)
  To: akpm; +Cc: linux-kernel, trivial

On Tue, May 13, 2008 at 12:27 AM, Andrew Morton <akpm@linux-foundation.org> wrote:
> On Sat, 10 May 2008 13:40:53 +0200
>  Abdel Benamrouche <draconux@gmail.com> wrote:
>  
>  > fs/partitions/check.c:381: warning: ignoring return value of ___device_add___,
>  >  declared with attribute warn_unused_result
>  >
>  > Signed-off-by: Abdel Benamrouche <draconux@gmail.com>
>  > ---
>  > :100644 100644 6149e4b... 7a87fad... M        fs/partitions/check.c
>  >  fs/partitions/check.c |    8 +++++++-
>  >  1 files changed, 7 insertions(+), 1 deletions(-)
>  >
>  > diff --git a/fs/partitions/check.c b/fs/partitions/check.c
>  > index 6149e4b..7a87fad 100644
>  > --- a/fs/partitions/check.c
>  > +++ b/fs/partitions/check.c
>  > @@ -378,7 +378,13 @@ void add_partition(struct gendisk *disk, int part, sector_t start, sector_t len,
>  >
>  >       /* delay uevent until 'holders' subdir is created */
>  >       p->dev.uevent_suppress = 1;
>  > -     device_add(&p->dev);
>  > +     if (device_add(&p->dev)) {
>  > +             put_device(&p->dev);
>  > +             free_part_stats(p);
>  > +             kfree(p);
>  > +             return;
>  > +     }
>  > +
>  >       partition_sysfs_add_subdir(p);
>  >       p->dev.uevent_suppress = 0;
>  >       if (flags & ADDPART_FLAG_WHOLEDISK)
>  
>  We should go further than this.  add_partition() just drops the error
>  on the floor.  It should be propagated back to callers, and callers
>  should be modified to handle it appropriately.
>  
>  Presumably we should also handle a device_create_file() failure as well
>  - that is presently being silently ignored.
>  
>  

done.
I make 2 patch so that it will be easier to read.




^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2008-05-13 20:03 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-05-13 20:02 [PATCH 0/2] /fs/partition/check.c : fix return value warning (V2) Abdel Benamrouche

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®