mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joerg Roedel <joerg.roedel@amd.com>
To: avi@redhat.com, mingo@redhat.com, dwmw2@infradead.org,
	gregkh@suse.de, weidong.han@intel.com
Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
	kvm@vger.kernel.org, Joerg Roedel <joerg.roedel@amd.com>
Subject: [PATCH 02/11] introcude linux/iommu.h for an iommu api
Date: Thu, 4 Dec 2008 18:28:47 +0100	[thread overview]
Message-ID: <1228411736-22644-3-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <20081204172142.GH12816@amd.com>

This patch introduces the API to abstract the exported VT-d functions
for KVM into a generic API. This way the AMD IOMMU implementation can
plug into this API later.

Signed-off-by: Joerg Roedel <joerg.roedel@amd.com>
---
 include/linux/iommu.h |  112 +++++++++++++++++++++++++++++++++++++++++++++++++
 1 files changed, 112 insertions(+), 0 deletions(-)
 create mode 100644 include/linux/iommu.h

diff --git a/include/linux/iommu.h b/include/linux/iommu.h
new file mode 100644
index 0000000..8a7bfb1
--- /dev/null
+++ b/include/linux/iommu.h
@@ -0,0 +1,112 @@
+/*
+ * Copyright (C) 2007-2008 Advanced Micro Devices, Inc.
+ * Author: Joerg Roedel <joerg.roedel@amd.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ *
+ * This program is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307 USA
+ */
+
+#ifndef __LINUX_IOMMU_H
+#define __LINUX_IOMMU_H
+
+#define IOMMU_READ	(1)
+#define IOMMU_WRITE	(2)
+
+struct device;
+
+struct iommu_domain {
+	void *priv;
+};
+
+struct iommu_ops {
+	int (*domain_init)(struct iommu_domain *domain);
+	void (*domain_destroy)(struct iommu_domain *domain);
+	int (*attach_dev)(struct iommu_domain *domain, struct device *dev);
+	void (*detach_dev)(struct iommu_domain *domain, struct device *dev);
+	int (*map)(struct iommu_domain *domain, unsigned long iova,
+		   phys_addr_t paddr, size_t size, int prot);
+	void (*unmap)(struct iommu_domain *domain, unsigned long iova,
+		      size_t size);
+	phys_addr_t (*iova_to_phys)(struct iommu_domain *domain,
+				    unsigned long iova);
+};
+
+#ifdef CONFIG_IOMMU_API
+
+extern void register_iommu(struct iommu_ops *ops);
+extern bool iommu_found(void);
+extern struct iommu_domain *iommu_domain_alloc(void);
+extern void iommu_domain_free(struct iommu_domain *domain);
+extern int iommu_attach_device(struct iommu_domain *domain,
+			       struct device *dev);
+extern void iommu_detach_device(struct iommu_domain *domain,
+				struct device *dev);
+extern int iommu_map_range(struct iommu_domain *domain, unsigned long iova,
+			   phys_addr_t paddr, size_t size, int prot);
+extern void iommu_unmap_range(struct iommu_domain *domain, unsigned long iova,
+			      size_t size);
+extern phys_addr_t iommu_iova_to_phys(struct iommu_domain *domain,
+				      unsigned long iova);
+
+#else /* CONFIG_IOMMU_API */
+
+static inline void register_iommu(struct iommu_ops *ops)
+{
+}
+
+static inline bool iommu_found(void)
+{
+	return false;
+}
+
+static inline struct iommu_domain *iommu_domain_alloc(void)
+{
+	return NULL;
+}
+
+static inline void iommu_domain_free(struct iommu_domain *domain)
+{
+}
+
+static inline int iommu_attach_device(struct iommu_domain *domain,
+				      struct device *dev)
+{
+	return -ENODEV;
+}
+
+static inline void iommu_detach_device(struct iommu_domain *domain,
+				       struct device *dev)
+{
+}
+
+static inline int iommu_map_range(struct iommu_domain *domain,
+				  unsigned long iova, phys_addr_t paddr,
+				  size_t size, int prot)
+{
+	return -ENODEV;
+}
+
+static inline void iommu_unmap_range(struct iommu_domain *domain,
+				     unsigned long iova, size_t size)
+{
+}
+
+static inline phys_addr_t iommu_iova_to_phys(struct iommu_domain *domain,
+					     unsigned long iova)
+{
+	return 0;
+}
+
+#endif /* CONFIG_IOMMU_API */
+
+#endif /* __LINUX_IOMMU_H */
-- 
1.5.6.4



  parent reply	other threads:[~2008-12-04 17:29 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-12-04 17:21 [PATCHSETS] KVM device passthrough support with AMD IOMMU Joerg Roedel
2008-12-04 17:28 ` [PATCH 0/11] Factor VT-d KVM functions into a generic API Joerg Roedel
2008-12-04 17:28 ` [PATCH 01/11] KVM: rename vtd.c to iommu.c Joerg Roedel
2008-12-04 17:28 ` Joerg Roedel [this message]
2008-12-04 17:28 ` [PATCH 03/11] add frontend implementation for the IOMMU API Joerg Roedel
2008-12-04 18:05   ` Greg KH
2008-12-04 17:28 ` [PATCH 04/11] select IOMMU_API when DMAR and/or AMD_IOMMU is selected Joerg Roedel
2008-12-04 17:28 ` [PATCH 05/11] KVM: change KVM to use IOMMU API Joerg Roedel
2008-12-04 17:28 ` [PATCH 06/11] VT-d: adapt domain init and destroy functions for " Joerg Roedel
2008-12-04 17:28 ` [PATCH 07/11] VT-d: adapt device attach and detach " Joerg Roedel
2008-12-04 17:28 ` [PATCH 08/11] VT-d: adapt domain map and unmap " Joerg Roedel
2008-12-04 17:28 ` [PATCH 09/11] VT-d: adapt domain iova_to_phys function " Joerg Roedel
2008-12-04 17:28 ` [PATCH 10/11] VT-d: register functions for the " Joerg Roedel
2008-12-04 17:28 ` [PATCH 11/11] VT-d: remove now unused intel_iommu_found function Joerg Roedel
2008-12-04 17:31 ` [PATCH 0/19] AMD IOMMU support for KVM device assignment Joerg Roedel
2008-12-04 17:31 ` [PATCH 01/19] AMD IOMMU: rename iommu_map to iommu_map_page Joerg Roedel
2008-12-04 17:31 ` [PATCH 02/19] AMD IOMMU: fix iommu_map_page function Joerg Roedel
2008-12-04 17:31 ` [PATCH 03/19] AMD IOMMU: fix loop counter in free_pagetable function Joerg Roedel
2008-12-04 17:31 ` [PATCH 04/19] AMD IOMMU: make dma_ops_free_pagetable generic Joerg Roedel
2008-12-04 17:31 ` [PATCH 05/19] AMD IOMMU: add domain id free function Joerg Roedel
2008-12-04 17:31 ` [PATCH 06/19] AMD IOMMU: refactor completion wait handling into separate functions Joerg Roedel
2008-12-04 17:31 ` [PATCH 07/19] AMD IOMMU: move invalidation command building to a separate function Joerg Roedel
2008-12-04 17:31 ` [PATCH 08/19] AMD IOMMU: add iommu_flush_domain function Joerg Roedel
2008-12-04 17:31 ` [PATCH 09/19] AMD IOMMU: add protection domain flags Joerg Roedel
2008-12-04 17:31 ` [PATCH 10/19] AMD IOMMU: add checks for dma_ops domain to dma_ops functions Joerg Roedel
2008-12-04 17:31 ` [PATCH 11/19] AMD IOMMU: add device reference counting for protection domains Joerg Roedel
2008-12-04 17:31 ` [PATCH 12/19] AMD IOMMU: add domain init function for IOMMU API Joerg Roedel
2008-12-04 17:31 ` [PATCH 13/19] AMD IOMMU: add domain destroy " Joerg Roedel
2008-12-04 17:31 ` [PATCH 14/19] AMD IOMMU: add device detach " Joerg Roedel
2008-12-04 17:31 ` [PATCH 15/19] AMD IOMMU: add device attach " Joerg Roedel
2008-12-04 17:31 ` [PATCH 16/19] AMD IOMMU: add domain map " Joerg Roedel
2008-12-04 17:31 ` [PATCH 17/19] AMD IOMMU: add domain unmap " Joerg Roedel
2008-12-04 17:31 ` [PATCH 18/19] AMD IOMMU: add domain address lookup " Joerg Roedel
2008-12-04 17:31 ` [PATCH 19/19] AMD IOMMU: register functions for the " Joerg Roedel
2008-12-08 13:05 ` [PATCHSETS] KVM device passthrough support with AMD IOMMU Joerg Roedel
2008-12-09 14:11 [PATCHSETS #2] " Joerg Roedel
2008-12-09 14:15 ` [PATCH 0/11] Factor VT-d KVM functions into a generic API Joerg Roedel
2008-12-09 14:16   ` [PATCH 01/11] KVM: rename vtd.c to iommu.c Joerg Roedel
2008-12-09 14:16     ` [PATCH 02/11] introcude linux/iommu.h for an iommu api Joerg Roedel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1228411736-22644-3-git-send-email-joerg.roedel@amd.com \
    --to=joerg.roedel@amd.com \
    --cc=avi@redhat.com \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@suse.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=weidong.han@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome