From: Joerg Roedel <joerg.roedel@amd.com>
To: avi@redhat.com, mingo@redhat.com, dwmw2@infradead.org,
gregkh@suse.de, weidong.han@intel.com
Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
kvm@vger.kernel.org
Subject: [PATCH 0/19] AMD IOMMU support for KVM device assignment
Date: Thu, 4 Dec 2008 18:31:37 +0100 [thread overview]
Message-ID: <1228411916-22668-1-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <20081204172142.GH12816@amd.com>
This patchset implements KVM device assignment support in the AMD IOMMU
driver. It uses the generic interface from the iommu-api patchset and
was successfully tested using an 10GBit network card passed through to
an KVM guest.
diffstat:
arch/x86/include/asm/amd_iommu_types.h | 15 +-
arch/x86/kernel/amd_iommu.c | 426 ++++++++++++++++++++++++++++----
2 files changed, 393 insertions(+), 48 deletions(-)
next prev parent reply other threads:[~2008-12-04 17:36 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-12-04 17:21 [PATCHSETS] KVM device passthrough support with AMD IOMMU Joerg Roedel
2008-12-04 17:28 ` [PATCH 0/11] Factor VT-d KVM functions into a generic API Joerg Roedel
2008-12-04 17:28 ` [PATCH 01/11] KVM: rename vtd.c to iommu.c Joerg Roedel
2008-12-04 17:28 ` [PATCH 02/11] introcude linux/iommu.h for an iommu api Joerg Roedel
2008-12-04 17:28 ` [PATCH 03/11] add frontend implementation for the IOMMU API Joerg Roedel
2008-12-04 18:05 ` Greg KH
2008-12-04 17:28 ` [PATCH 04/11] select IOMMU_API when DMAR and/or AMD_IOMMU is selected Joerg Roedel
2008-12-04 17:28 ` [PATCH 05/11] KVM: change KVM to use IOMMU API Joerg Roedel
2008-12-04 17:28 ` [PATCH 06/11] VT-d: adapt domain init and destroy functions for " Joerg Roedel
2008-12-04 17:28 ` [PATCH 07/11] VT-d: adapt device attach and detach " Joerg Roedel
2008-12-04 17:28 ` [PATCH 08/11] VT-d: adapt domain map and unmap " Joerg Roedel
2008-12-04 17:28 ` [PATCH 09/11] VT-d: adapt domain iova_to_phys function " Joerg Roedel
2008-12-04 17:28 ` [PATCH 10/11] VT-d: register functions for the " Joerg Roedel
2008-12-04 17:28 ` [PATCH 11/11] VT-d: remove now unused intel_iommu_found function Joerg Roedel
2008-12-04 17:31 ` Joerg Roedel [this message]
2008-12-04 17:31 ` [PATCH 01/19] AMD IOMMU: rename iommu_map to iommu_map_page Joerg Roedel
2008-12-04 17:31 ` [PATCH 02/19] AMD IOMMU: fix iommu_map_page function Joerg Roedel
2008-12-04 17:31 ` [PATCH 03/19] AMD IOMMU: fix loop counter in free_pagetable function Joerg Roedel
2008-12-04 17:31 ` [PATCH 04/19] AMD IOMMU: make dma_ops_free_pagetable generic Joerg Roedel
2008-12-04 17:31 ` [PATCH 05/19] AMD IOMMU: add domain id free function Joerg Roedel
2008-12-04 17:31 ` [PATCH 06/19] AMD IOMMU: refactor completion wait handling into separate functions Joerg Roedel
2008-12-04 17:31 ` [PATCH 07/19] AMD IOMMU: move invalidation command building to a separate function Joerg Roedel
2008-12-04 17:31 ` [PATCH 08/19] AMD IOMMU: add iommu_flush_domain function Joerg Roedel
2008-12-04 17:31 ` [PATCH 09/19] AMD IOMMU: add protection domain flags Joerg Roedel
2008-12-04 17:31 ` [PATCH 10/19] AMD IOMMU: add checks for dma_ops domain to dma_ops functions Joerg Roedel
2008-12-04 17:31 ` [PATCH 11/19] AMD IOMMU: add device reference counting for protection domains Joerg Roedel
2008-12-04 17:31 ` [PATCH 12/19] AMD IOMMU: add domain init function for IOMMU API Joerg Roedel
2008-12-04 17:31 ` [PATCH 13/19] AMD IOMMU: add domain destroy " Joerg Roedel
2008-12-04 17:31 ` [PATCH 14/19] AMD IOMMU: add device detach " Joerg Roedel
2008-12-04 17:31 ` [PATCH 15/19] AMD IOMMU: add device attach " Joerg Roedel
2008-12-04 17:31 ` [PATCH 16/19] AMD IOMMU: add domain map " Joerg Roedel
2008-12-04 17:31 ` [PATCH 17/19] AMD IOMMU: add domain unmap " Joerg Roedel
2008-12-04 17:31 ` [PATCH 18/19] AMD IOMMU: add domain address lookup " Joerg Roedel
2008-12-04 17:31 ` [PATCH 19/19] AMD IOMMU: register functions for the " Joerg Roedel
2008-12-08 13:05 ` [PATCHSETS] KVM device passthrough support with AMD IOMMU Joerg Roedel
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1228411916-22668-1-git-send-email-joerg.roedel@amd.com \
--to=joerg.roedel@amd.com \
--cc=avi@redhat.com \
--cc=dwmw2@infradead.org \
--cc=gregkh@suse.de \
--cc=iommu@lists.linux-foundation.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=weidong.han@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome