mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joerg Roedel <joerg.roedel@amd.com>
To: avi@redhat.com, mingo@redhat.com, dwmw2@infradead.org,
	gregkh@suse.de, weidong.han@intel.com
Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
	kvm@vger.kernel.org, Joerg Roedel <joerg.roedel@amd.com>
Subject: [PATCH 11/11] VT-d: remove now unused intel_iommu_found function
Date: Tue, 9 Dec 2008 15:16:10 +0100	[thread overview]
Message-ID: <1228832170-13405-12-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <1228832170-13405-11-git-send-email-joerg.roedel@amd.com>

Signed-off-by: Joerg Roedel <joerg.roedel@amd.com>
---
 drivers/pci/intel-iommu.c   |    6 ------
 include/linux/intel-iommu.h |    9 ---------
 2 files changed, 0 insertions(+), 15 deletions(-)

diff --git a/drivers/pci/intel-iommu.c b/drivers/pci/intel-iommu.c
index 81e04ec..ecb5fd3 100644
--- a/drivers/pci/intel-iommu.c
+++ b/drivers/pci/intel-iommu.c
@@ -3105,12 +3105,6 @@ static void intel_iommu_unmap_range(struct iommu_domain *domain,
 		dmar_domain->max_addr = base;
 }
 
-int intel_iommu_found(void)
-{
-	return g_num_of_iommus;
-}
-EXPORT_SYMBOL_GPL(intel_iommu_found);
-
 static phys_addr_t intel_iommu_iova_to_phys(struct iommu_domain *domain,
 					    unsigned long iova)
 {
diff --git a/include/linux/intel-iommu.h b/include/linux/intel-iommu.h
index 26ccc02..c4f6c10 100644
--- a/include/linux/intel-iommu.h
+++ b/include/linux/intel-iommu.h
@@ -330,15 +330,6 @@ extern int qi_flush_iotlb(struct intel_iommu *iommu, u16 did, u64 addr,
 
 extern void qi_submit_sync(struct qi_desc *desc, struct intel_iommu *iommu);
 
-#ifdef CONFIG_DMAR
-int intel_iommu_found(void);
-#else /* CONFIG_DMAR */
-static inline int intel_iommu_found(void)
-{
-	return 0;
-}
-#endif /* CONFIG_DMAR */
-
 extern void *intel_alloc_coherent(struct device *, size_t, dma_addr_t *, gfp_t);
 extern void intel_free_coherent(struct device *, size_t, void *, dma_addr_t);
 extern dma_addr_t intel_map_single(struct device *, phys_addr_t, size_t, int);
-- 
1.5.6.4



  reply	other threads:[~2008-12-09 14:18 UTC|newest]

Thread overview: 46+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-12-09 14:11 [PATCHSETS #2] KVM device passthrough support with AMD IOMMU Joerg Roedel
2008-12-09 14:15 ` [PATCH 0/21] AMD IOMMU support for KVM device assignment Joerg Roedel
2008-12-09 14:15   ` [PATCH 01/21] AMD IOMMU: rename iommu_map to iommu_map_page Joerg Roedel
2008-12-09 14:15     ` [PATCH 02/21] AMD IOMMU: fix iommu_map_page function Joerg Roedel
2008-12-09 14:16       ` [PATCH 03/21] AMD IOMMU: fix loop counter in free_pagetable function Joerg Roedel
2008-12-09 14:16         ` [PATCH 04/21] AMD IOMMU: make dma_ops_free_pagetable generic Joerg Roedel
2008-12-09 14:16           ` [PATCH 05/21] AMD IOMMU: add domain id free function Joerg Roedel
2008-12-09 14:16             ` [PATCH 06/21] AMD IOMMU: refactor completion wait handling into separate functions Joerg Roedel
2008-12-09 14:16               ` [PATCH 07/21] AMD IOMMU: move invalidation command building to a separate function Joerg Roedel
2008-12-09 14:16                 ` [PATCH 08/21] AMD IOMMU: add iommu_flush_domain function Joerg Roedel
2008-12-09 14:16                   ` [PATCH 09/21] AMD IOMMU: add protection domain flags Joerg Roedel
2008-12-09 14:16                     ` [PATCH 10/21] AMD IOMMU: add checks for dma_ops domain to dma_ops functions Joerg Roedel
2008-12-09 14:16                       ` [PATCH 11/21] AMD IOMMU: add device reference counting for protection domains Joerg Roedel
2008-12-09 14:16                         ` [PATCH 12/21] AMD IOMMU: add device detach helper functions Joerg Roedel
2008-12-09 14:16                           ` [PATCH 13/21] AMD IOMMU: add domain cleanup helper function Joerg Roedel
2008-12-09 14:16                             ` [PATCH 14/21] AMD IOMMU: add domain init function for IOMMU API Joerg Roedel
2008-12-09 14:16                               ` [PATCH 15/21] AMD IOMMU: add domain destroy " Joerg Roedel
2008-12-09 14:16                                 ` [PATCH 16/21] AMD IOMMU: add device detach " Joerg Roedel
2008-12-09 14:16                                   ` [PATCH 17/21] AMD IOMMU: add device attach " Joerg Roedel
2008-12-09 14:16                                     ` [PATCH 18/21] AMD IOMMU: add domain map " Joerg Roedel
2008-12-09 14:16                                       ` [PATCH 19/21] AMD IOMMU: add domain unmap " Joerg Roedel
2008-12-09 14:16                                         ` [PATCH 20/21] AMD IOMMU: add domain address lookup " Joerg Roedel
2008-12-09 14:16                                           ` [PATCH 21/21] AMD IOMMU: register functions for the " Joerg Roedel
2008-12-09 14:15 ` [PATCH 0/11] Factor VT-d KVM functions into a generic API Joerg Roedel
2008-12-09 14:16   ` [PATCH 01/11] KVM: rename vtd.c to iommu.c Joerg Roedel
2008-12-09 14:16     ` [PATCH 02/11] introcude linux/iommu.h for an iommu api Joerg Roedel
2008-12-09 14:16       ` [PATCH 03/11] add frontend implementation for the IOMMU API Joerg Roedel
2008-12-09 14:16         ` [PATCH 04/11] select IOMMU_API when DMAR and/or AMD_IOMMU is selected Joerg Roedel
2008-12-09 14:16           ` [PATCH 05/11] KVM: change KVM to use IOMMU API Joerg Roedel
2008-12-09 14:16             ` [PATCH 06/11] VT-d: adapt domain init and destroy functions for " Joerg Roedel
2008-12-09 14:16               ` [PATCH 07/11] VT-d: adapt device attach and detach " Joerg Roedel
2008-12-09 14:16                 ` [PATCH 08/11] VT-d: adapt domain map and unmap " Joerg Roedel
2008-12-09 14:16                   ` [PATCH 09/11] VT-d: adapt domain iova_to_phys function " Joerg Roedel
2008-12-09 14:16                     ` [PATCH 10/11] VT-d: register functions for the " Joerg Roedel
2008-12-09 14:16                       ` Joerg Roedel [this message]
2008-12-10  9:36 ` [PATCHSETS #2] KVM device passthrough support with AMD IOMMU Avi Kivity
2008-12-10 14:11   ` Joerg Roedel
2008-12-10 14:22     ` David Woodhouse
2008-12-10 14:25       ` Joerg Roedel
2008-12-10 18:24         ` David Woodhouse
2008-12-10 18:42           ` Joerg Roedel
2008-12-10 18:48             ` David Woodhouse
2008-12-15 11:29               ` Joerg Roedel
2008-12-11  1:11         ` Han, Weidong
2008-12-10 14:23     ` Avi Kivity
  -- strict thread matches above, loose matches on Subject: below --
2008-12-04 17:21 [PATCHSETS] " Joerg Roedel
2008-12-04 17:28 ` [PATCH 11/11] VT-d: remove now unused intel_iommu_found function Joerg Roedel

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1228832170-13405-12-git-send-email-joerg.roedel@amd.com \
    --to=joerg.roedel@amd.com \
    --cc=avi@redhat.com \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@suse.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=weidong.han@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®