mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joerg Roedel <joerg.roedel@amd.com>
To: avi@redhat.com, mingo@redhat.com, dwmw2@infradead.org,
	gregkh@suse.de, weidong.han@intel.com
Cc: iommu@lists.linux-foundation.org, linux-kernel@vger.kernel.org,
	kvm@vger.kernel.org, Joerg Roedel <joerg.roedel@amd.com>
Subject: [PATCH 12/21] AMD IOMMU: add device detach helper functions
Date: Tue, 9 Dec 2008 15:16:09 +0100	[thread overview]
Message-ID: <1228832178-13429-13-git-send-email-joerg.roedel@amd.com> (raw)
In-Reply-To: <1228832178-13429-12-git-send-email-joerg.roedel@amd.com>

Impact: add helper functions to detach a device from a domain

Signed-off-by: Joerg Roedel <joerg.roedel@amd.com>
---
 arch/x86/kernel/amd_iommu.c |   41 +++++++++++++++++++++++++++++++++++++++++
 1 files changed, 41 insertions(+), 0 deletions(-)

diff --git a/arch/x86/kernel/amd_iommu.c b/arch/x86/kernel/amd_iommu.c
index 61584d5..47158e3 100644
--- a/arch/x86/kernel/amd_iommu.c
+++ b/arch/x86/kernel/amd_iommu.c
@@ -1469,3 +1469,44 @@ free_domains:
 
 	return ret;
 }
+
+/*****************************************************************************
+ *
+ * The following functions belong to the exported interface of AMD IOMMU
+ *
+ * This interface allows access to lower level functions of the IOMMU
+ * like protection domain handling and assignement of devices to domains
+ * which is not possible with the dma_ops interface.
+ *
+ *****************************************************************************/
+
+static void __detach_device(struct protection_domain *domain, u16 devid)
+{
+
+	/* lock domain */
+	spin_lock(&domain->lock);
+
+	/* remove domain from the lookup table */
+	amd_iommu_pd_table[devid] = NULL;
+
+	/* remove entry from the device table seen by the hardware */
+	amd_iommu_dev_table[devid].data[0] = IOMMU_PTE_P | IOMMU_PTE_TV;
+	amd_iommu_dev_table[devid].data[1] = 0;
+	amd_iommu_dev_table[devid].data[2] = 0;
+
+	/* decrease reference counter */
+	domain->dev_cnt -= 1;
+
+	/* ready */
+	spin_unlock(&domain->lock);
+}
+
+static void detach_device(struct protection_domain *domain, u16 devid)
+{
+	unsigned long flags;
+
+	/* lock device table */
+	write_lock_irqsave(&amd_iommu_devtable_lock, flags);
+	__detach_device(domain, devid);
+	write_unlock_irqrestore(&amd_iommu_devtable_lock, flags);
+}
-- 
1.5.6.4



  reply	other threads:[~2008-12-09 14:21 UTC|newest]

Thread overview: 45+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-12-09 14:11 [PATCHSETS #2] KVM device passthrough support with AMD IOMMU Joerg Roedel
2008-12-09 14:15 ` [PATCH 0/21] AMD IOMMU support for KVM device assignment Joerg Roedel
2008-12-09 14:15   ` [PATCH 01/21] AMD IOMMU: rename iommu_map to iommu_map_page Joerg Roedel
2008-12-09 14:15     ` [PATCH 02/21] AMD IOMMU: fix iommu_map_page function Joerg Roedel
2008-12-09 14:16       ` [PATCH 03/21] AMD IOMMU: fix loop counter in free_pagetable function Joerg Roedel
2008-12-09 14:16         ` [PATCH 04/21] AMD IOMMU: make dma_ops_free_pagetable generic Joerg Roedel
2008-12-09 14:16           ` [PATCH 05/21] AMD IOMMU: add domain id free function Joerg Roedel
2008-12-09 14:16             ` [PATCH 06/21] AMD IOMMU: refactor completion wait handling into separate functions Joerg Roedel
2008-12-09 14:16               ` [PATCH 07/21] AMD IOMMU: move invalidation command building to a separate function Joerg Roedel
2008-12-09 14:16                 ` [PATCH 08/21] AMD IOMMU: add iommu_flush_domain function Joerg Roedel
2008-12-09 14:16                   ` [PATCH 09/21] AMD IOMMU: add protection domain flags Joerg Roedel
2008-12-09 14:16                     ` [PATCH 10/21] AMD IOMMU: add checks for dma_ops domain to dma_ops functions Joerg Roedel
2008-12-09 14:16                       ` [PATCH 11/21] AMD IOMMU: add device reference counting for protection domains Joerg Roedel
2008-12-09 14:16                         ` Joerg Roedel [this message]
2008-12-09 14:16                           ` [PATCH 13/21] AMD IOMMU: add domain cleanup helper function Joerg Roedel
2008-12-09 14:16                             ` [PATCH 14/21] AMD IOMMU: add domain init function for IOMMU API Joerg Roedel
2008-12-09 14:16                               ` [PATCH 15/21] AMD IOMMU: add domain destroy " Joerg Roedel
2008-12-09 14:16                                 ` [PATCH 16/21] AMD IOMMU: add device detach " Joerg Roedel
2008-12-09 14:16                                   ` [PATCH 17/21] AMD IOMMU: add device attach " Joerg Roedel
2008-12-09 14:16                                     ` [PATCH 18/21] AMD IOMMU: add domain map " Joerg Roedel
2008-12-09 14:16                                       ` [PATCH 19/21] AMD IOMMU: add domain unmap " Joerg Roedel
2008-12-09 14:16                                         ` [PATCH 20/21] AMD IOMMU: add domain address lookup " Joerg Roedel
2008-12-09 14:16                                           ` [PATCH 21/21] AMD IOMMU: register functions for the " Joerg Roedel
2008-12-09 14:15 ` [PATCH 0/11] Factor VT-d KVM functions into a generic API Joerg Roedel
2008-12-09 14:16   ` [PATCH 01/11] KVM: rename vtd.c to iommu.c Joerg Roedel
2008-12-09 14:16     ` [PATCH 02/11] introcude linux/iommu.h for an iommu api Joerg Roedel
2008-12-09 14:16       ` [PATCH 03/11] add frontend implementation for the IOMMU API Joerg Roedel
2008-12-09 14:16         ` [PATCH 04/11] select IOMMU_API when DMAR and/or AMD_IOMMU is selected Joerg Roedel
2008-12-09 14:16           ` [PATCH 05/11] KVM: change KVM to use IOMMU API Joerg Roedel
2008-12-09 14:16             ` [PATCH 06/11] VT-d: adapt domain init and destroy functions for " Joerg Roedel
2008-12-09 14:16               ` [PATCH 07/11] VT-d: adapt device attach and detach " Joerg Roedel
2008-12-09 14:16                 ` [PATCH 08/11] VT-d: adapt domain map and unmap " Joerg Roedel
2008-12-09 14:16                   ` [PATCH 09/11] VT-d: adapt domain iova_to_phys function " Joerg Roedel
2008-12-09 14:16                     ` [PATCH 10/11] VT-d: register functions for the " Joerg Roedel
2008-12-09 14:16                       ` [PATCH 11/11] VT-d: remove now unused intel_iommu_found function Joerg Roedel
2008-12-10  9:36 ` [PATCHSETS #2] KVM device passthrough support with AMD IOMMU Avi Kivity
2008-12-10 14:11   ` Joerg Roedel
2008-12-10 14:22     ` David Woodhouse
2008-12-10 14:25       ` Joerg Roedel
2008-12-10 18:24         ` David Woodhouse
2008-12-10 18:42           ` Joerg Roedel
2008-12-10 18:48             ` David Woodhouse
2008-12-15 11:29               ` Joerg Roedel
2008-12-11  1:11         ` Han, Weidong
2008-12-10 14:23     ` Avi Kivity

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1228832178-13429-13-git-send-email-joerg.roedel@amd.com \
    --to=joerg.roedel@amd.com \
    --cc=avi@redhat.com \
    --cc=dwmw2@infradead.org \
    --cc=gregkh@suse.de \
    --cc=iommu@lists.linux-foundation.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=weidong.han@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®