From: Ian Campbell <Ian.Campbell@eu.citrix.com>
To: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Cc: "jeremy@goop.org" <jeremy@goop.org>,
"beckyb@kernel.crashing.org" <beckyb@kernel.crashing.org>,
"okir@suse.de" <okir@suse.de>, "mingo@elte.hu" <mingo@elte.hu>,
"gregkh@suse.de" <gregkh@suse.de>,
"xendevel@lists.xensource.com" <xendevel@lists.xensource.com>,
"x86@kernel.org" <x86@kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] swiotlb: make swiotlb phys<->bus translations architecture-specific
Date: Fri, 22 May 2009 12:46:26 +0100 [thread overview]
Message-ID: <1242992786.22654.281.camel@zakaz.uk.xensource.com> (raw)
In-Reply-To: <20090522200437P.fujita.tomonori@lab.ntt.co.jp>
On Fri, 2009-05-22 at 07:13 -0400, FUJITA Tomonori wrote:
> > +static inline phys_addr_t swiotlb_bus_to_phys(struct device *hwdev,
> > + dma_addr_t baddr)
> > +{
> > + return baddr;
> > +}
> > +
> > +
>
> As I wrote in another mail, adding swiotlb specific code in
> dma-mapping.h is wrong.
They aren't really swiotlb specific, I just foolishly carried over the
old name, really I think they should be called just bus_to_phys and
phys_to_bus or something.
Ian.
next prev parent reply other threads:[~2009-05-22 11:46 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-05-14 19:54 Where do we stand with the Xen patches? Jeremy Fitzhardinge
2009-05-15 18:35 ` Ingo Molnar
2009-05-15 19:59 ` Jeremy Fitzhardinge
2009-05-18 1:36 ` FUJITA Tomonori
2009-05-18 1:42 ` Jeremy Fitzhardinge
2009-05-18 8:40 ` Ingo Molnar
2009-05-19 5:27 ` FUJITA Tomonori
2009-05-19 13:03 ` Ingo Molnar
2009-05-19 15:30 ` FUJITA Tomonori
2009-05-19 15:56 ` Ian Campbell
2009-05-20 17:06 ` Jeremy Fitzhardinge
2009-05-21 8:54 ` FUJITA Tomonori
2009-05-21 10:27 ` Ian Campbell
2009-05-21 10:28 ` Ian Campbell
2009-05-21 10:39 ` FUJITA Tomonori
2009-05-21 11:03 ` [Xen-devel] " Ian Campbell
2009-05-21 11:08 ` Ian Campbell
2009-05-21 11:19 ` FUJITA Tomonori
2009-05-21 11:45 ` Ian Campbell
2009-05-21 16:15 ` swiotlb: remove __weak hooks in favour of architecture-specific functions Ian Campbell
2009-05-21 16:19 ` Ian Campbell
2009-05-21 16:47 ` Randy Dunlap
2009-05-22 8:55 ` Ian Campbell
2009-05-22 11:13 ` FUJITA Tomonori
2009-05-22 11:43 ` Ian Campbell
2009-05-22 11:55 ` FUJITA Tomonori
2009-05-22 14:02 ` Ian Campbell
2009-05-22 14:24 ` FUJITA Tomonori
2009-05-21 16:15 ` [PATCH] swiotlb: make is_buffer_dma_capable architecture-specific Ian Campbell
2009-05-21 16:15 ` [PATCH] swiotlb: make range_needs_mapping architecture-specific Ian Campbell
2009-05-22 11:13 ` FUJITA Tomonori
2009-05-22 11:45 ` Ian Campbell
2009-05-21 16:15 ` [PATCH] swiotlb/xen: update xen for swiotlb_arch_force_mapping changes Ian Campbell
2009-05-21 16:15 ` [PATCH] swiotlb: make swiotlb allocation functions architecture-specific Ian Campbell
2009-05-22 11:13 ` FUJITA Tomonori
2009-05-22 11:46 ` Ian Campbell
2009-05-21 16:15 ` [PATCH] swiotlb/xen: update xen for changes to swiotlb allocation interface Ian Campbell
2009-05-21 16:15 ` [PATCH] swiotlb: make swiotlb phys<->bus translations architecture-specific Ian Campbell
2009-05-22 11:13 ` FUJITA Tomonori
2009-05-22 11:46 ` Ian Campbell [this message]
2009-05-21 16:15 ` [PATCH] swiotlb/xen: update xen swiotlb for phys<->bus API changes Ian Campbell
2009-05-21 17:21 ` [Xen-devel] Re: Where do we stand with the Xen patches? FUJITA Tomonori
2009-05-21 10:48 ` Ian Campbell
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1242992786.22654.281.camel@zakaz.uk.xensource.com \
--to=ian.campbell@eu.citrix.com \
--cc=beckyb@kernel.crashing.org \
--cc=fujita.tomonori@lab.ntt.co.jp \
--cc=gregkh@suse.de \
--cc=jeremy@goop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=okir@suse.de \
--cc=x86@kernel.org \
--cc=xendevel@lists.xensource.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®