mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY
@ 2009-09-02  3:14 David Rientjes
  2009-09-02  3:14 ` [patch 2/2 -mm] flex_array: add missing kerneldoc annotations David Rientjes
  2009-09-02 17:26 ` [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY Dave Hansen
  0 siblings, 2 replies; 4+ messages in thread
From: David Rientjes @ 2009-09-02  3:14 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Dave Hansen, linux-kernel

FLEX_ARRAY_INIT(element_size, total_nr_elements) cannot determine if
either parameter is valid, so flex arrays which are statically allocated
with this interface can easily become corrupted or reference beyond its
allocated memory.

This removes FLEX_ARRAY_INIT() as a struct flex_array initializer since
no initializer may perform the required checking.  Instead, the array
is now defined with a new interface:

	DEFINE_FLEX_ARRAY(name, element_size, total_nr_elements)

This may be prefixed with `static' for file scope.

This interface includes compile-time checking of the parameters to
ensure they are valid.  Since the validity of both element_size and
total_nr_elements depend on FLEX_ARRAY_BASE_SIZE and
FLEX_ARRAY_PART_SIZE, the kernel build will fail if either of these
predefined values changes such that the array parameters are no longer
valid.

Since BUILD_BUG_ON() requires compile time constants, several of the
static inline functions that were once local to lib/flex_array.c had to
be moved to include/linux/flex_array.h.

Cc: Dave Hansen <dave@linux.vnet.ibm.com>
Signed-off-by: David Rientjes <rientjes@google.com>
---
 include/linux/flex_array.h |   30 ++++++++++++++++++++++++++----
 lib/flex_array.c           |   36 ++++++++++--------------------------
 2 files changed, 36 insertions(+), 30 deletions(-)

diff --git a/include/linux/flex_array.h b/include/linux/flex_array.h
--- a/include/linux/flex_array.h
+++ b/include/linux/flex_array.h
@@ -31,10 +31,32 @@ struct flex_array {
 	};
 };
 
-#define FLEX_ARRAY_INIT(size, total) { { {\
-	.element_size = (size),		\
-	.total_nr_elements = (total),	\
-} } }
+/* Number of bytes left in base struct flex_array, excluding metadata */
+#define FLEX_ARRAY_BASE_BYTES_LEFT					\
+	(FLEX_ARRAY_BASE_SIZE - offsetof(struct flex_array, parts))
+
+/* Number of pointers in base to struct flex_array_part pages */
+#define FLEX_ARRAY_NR_BASE_PTRS						\
+	(FLEX_ARRAY_BASE_BYTES_LEFT / sizeof(struct flex_array_part *))
+
+/* Number of elements of size that fit in struct flex_array_part */
+#define FLEX_ARRAY_ELEMENTS_PER_PART(size)				\
+	(FLEX_ARRAY_PART_SIZE / size)
+
+/*
+ * Defines a statically allocated flex array and ensures its parameters are
+ * valid.
+ */
+#define DEFINE_FLEX_ARRAY(__arrayname, __element_size, __total)		\
+	struct flex_array __arrayname = { { {				\
+		.element_size = (__element_size),			\
+		.total_nr_elements = (__total),				\
+	} } };								\
+	static inline void __arrayname##_invalid_parameter(void)	\
+	{								\
+		BUILD_BUG_ON((__total) > FLEX_ARRAY_NR_BASE_PTRS *	\
+			FLEX_ARRAY_ELEMENTS_PER_PART(__element_size));	\
+	}
 
 struct flex_array *flex_array_alloc(int element_size, unsigned int total,
 		gfp_t flags);
diff --git a/lib/flex_array.c b/lib/flex_array.c
--- a/lib/flex_array.c
+++ b/lib/flex_array.c
@@ -28,23 +28,6 @@ struct flex_array_part {
 	char elements[FLEX_ARRAY_PART_SIZE];
 };
 
-static inline int __elements_per_part(int element_size)
-{
-	return FLEX_ARRAY_PART_SIZE / element_size;
-}
-
-static inline int bytes_left_in_base(void)
-{
-	int element_offset = offsetof(struct flex_array, parts);
-	int bytes_left = FLEX_ARRAY_BASE_SIZE - element_offset;
-	return bytes_left;
-}
-
-static inline int nr_base_part_ptrs(void)
-{
-	return bytes_left_in_base() / sizeof(struct flex_array_part *);
-}
-
 /*
  * If a user requests an allocation which is small
  * enough, we may simply use the space in the
@@ -54,7 +37,7 @@ static inline int nr_base_part_ptrs(void)
 static inline int elements_fit_in_base(struct flex_array *fa)
 {
 	int data_size = fa->element_size * fa->total_nr_elements;
-	if (data_size <= bytes_left_in_base())
+	if (data_size <= FLEX_ARRAY_BASE_BYTES_LEFT)
 		return 1;
 	return 0;
 }
@@ -103,7 +86,8 @@ struct flex_array *flex_array_alloc(int element_size, unsigned int total,
 					gfp_t flags)
 {
 	struct flex_array *ret;
-	int max_size = nr_base_part_ptrs() * __elements_per_part(element_size);
+	int max_size = FLEX_ARRAY_NR_BASE_PTRS *
+				FLEX_ARRAY_ELEMENTS_PER_PART(element_size);
 
 	/* max_size will end up 0 if element_size > PAGE_SIZE */
 	if (total > max_size)
@@ -114,14 +98,15 @@ struct flex_array *flex_array_alloc(int element_size, unsigned int total,
 	ret->element_size = element_size;
 	ret->total_nr_elements = total;
 	if (elements_fit_in_base(ret) && !(flags & __GFP_ZERO))
-		memset(ret->parts[0], FLEX_ARRAY_FREE, bytes_left_in_base());
+		memset(ret->parts[0], FLEX_ARRAY_FREE,
+						FLEX_ARRAY_BASE_BYTES_LEFT);
 	return ret;
 }
 
 static int fa_element_to_part_nr(struct flex_array *fa,
 					unsigned int element_nr)
 {
-	return element_nr / __elements_per_part(fa->element_size);
+	return element_nr / FLEX_ARRAY_ELEMENTS_PER_PART(fa->element_size);
 }
 
 /**
@@ -133,11 +118,10 @@ static int fa_element_to_part_nr(struct flex_array *fa,
 void flex_array_free_parts(struct flex_array *fa)
 {
 	int part_nr;
-	int max_part = nr_base_part_ptrs();
 
 	if (elements_fit_in_base(fa))
 		return;
-	for (part_nr = 0; part_nr < max_part; part_nr++)
+	for (part_nr = 0; part_nr < FLEX_ARRAY_NR_BASE_PTRS; part_nr++)
 		kfree(fa->parts[part_nr]);
 }
 
@@ -152,7 +136,8 @@ static unsigned int index_inside_part(struct flex_array *fa,
 {
 	unsigned int part_offset;
 
-	part_offset = element_nr % __elements_per_part(fa->element_size);
+	part_offset = element_nr %
+				FLEX_ARRAY_ELEMENTS_PER_PART(fa->element_size);
 	return part_offset * fa->element_size;
 }
 
@@ -313,13 +298,12 @@ static int part_is_free(struct flex_array_part *part)
 int flex_array_shrink(struct flex_array *fa)
 {
 	struct flex_array_part *part;
-	int max_part = nr_base_part_ptrs();
 	int part_nr;
 	int ret = 0;
 
 	if (elements_fit_in_base(fa))
 		return ret;
-	for (part_nr = 0; part_nr < max_part; part_nr++) {
+	for (part_nr = 0; part_nr < FLEX_ARRAY_NR_BASE_PTRS; part_nr++) {
 		part = fa->parts[part_nr];
 		if (!part)
 			continue;

^ permalink raw reply	[flat|nested] 4+ messages in thread

* [patch 2/2 -mm] flex_array: add missing kerneldoc annotations
  2009-09-02  3:14 [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY David Rientjes
@ 2009-09-02  3:14 ` David Rientjes
  2009-09-02 17:26 ` [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY Dave Hansen
  1 sibling, 0 replies; 4+ messages in thread
From: David Rientjes @ 2009-09-02  3:14 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Dave Hansen, Randy Dunlap, linux-kernel

This patch adds kerneldoc annotations for function formals of type
struct flex_array and gfp_t which are currently lacking.

Cc: Dave Hansen <dave@linux.vnet.ibm.com>
Cc: Randy Dunlap <randy.dunlap@oracle.com>
Signed-off-by: David Rientjes <rientjes@google.com>
---
 lib/flex_array.c |   12 +++++++++++-
 1 files changed, 11 insertions(+), 1 deletions(-)

diff --git a/lib/flex_array.c b/lib/flex_array.c
--- a/lib/flex_array.c
+++ b/lib/flex_array.c
@@ -46,6 +46,7 @@ static inline int elements_fit_in_base(struct flex_array *fa)
  * flex_array_alloc - allocate a new flexible array
  * @element_size:	the size of individual elements in the array
  * @total:		total number of elements that this should hold
+ * @flags:		page allocation flags to use for base array
  *
  * Note: all locking must be provided by the caller.
  *
@@ -111,6 +112,7 @@ static int fa_element_to_part_nr(struct flex_array *fa,
 
 /**
  * flex_array_free_parts - just free the second-level pages
+ * @fa:		the flex array from which to free parts
  *
  * This is to be used in cases where the base 'struct flex_array'
  * has been statically allocated and should not be free.
@@ -159,9 +161,12 @@ __fa_get_part(struct flex_array *fa, int part_nr, gfp_t flags)
 
 /**
  * flex_array_put - copy data into the array at @element_nr
- * @src:	address of data to copy into the array
+ * @fa:		the flex array to copy data into
  * @element_nr:	index of the position in which to insert
  * 		the new element.
+ * @src:	address of data to copy into the array
+ * @flags:	page allocation flags to use for array expansion
+ *
  *
  * Note that this *copies* the contents of @src into
  * the array.  If you are trying to store an array of
@@ -192,6 +197,7 @@ int flex_array_put(struct flex_array *fa, unsigned int element_nr, void *src,
 
 /**
  * flex_array_clear - clear element in array at @element_nr
+ * @fa:		the flex array of the element.
  * @element_nr:	index of the position to clear.
  *
  * Locking must be provided by the caller.
@@ -218,8 +224,10 @@ int flex_array_clear(struct flex_array *fa, unsigned int element_nr)
 
 /**
  * flex_array_prealloc - guarantee that array space exists
+ * @fa:		the flex array for which to preallocate parts
  * @start:	index of first array element for which space is allocated
  * @end:	index of last (inclusive) element for which space is allocated
+ * @flags:	page allocation flags
  *
  * This will guarantee that no future calls to flex_array_put()
  * will allocate memory.  It can be used if you are expecting to
@@ -252,6 +260,7 @@ int flex_array_prealloc(struct flex_array *fa, unsigned int start,
 
 /**
  * flex_array_get - pull data back out of the array
+ * @fa:		the flex array from which to extract data
  * @element_nr:	index of the element to fetch from the array
  *
  * Returns a pointer to the data at index @element_nr.  Note
@@ -289,6 +298,7 @@ static int part_is_free(struct flex_array_part *part)
 
 /**
  * flex_array_shrink - free unused second-level pages
+ * @fa:		the flex array to shrink
  *
  * Frees all second-level pages that consist solely of unused
  * elements.  Returns the number of pages freed.

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY
  2009-09-02  3:14 [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY David Rientjes
  2009-09-02  3:14 ` [patch 2/2 -mm] flex_array: add missing kerneldoc annotations David Rientjes
@ 2009-09-02 17:26 ` Dave Hansen
  2009-09-02 18:51   ` David Rientjes
  1 sibling, 1 reply; 4+ messages in thread
From: Dave Hansen @ 2009-09-02 17:26 UTC (permalink / raw)
  To: David Rientjes; +Cc: Andrew Morton, linux-kernel

On Tue, 2009-09-01 at 20:14 -0700, David Rientjes wrote:
> @@ -152,7 +136,8 @@ static unsigned int index_inside_part(struct
> flex_array *fa,
>  {
>         unsigned int part_offset;
> 
> -       part_offset = element_nr % __elements_per_part(fa->element_size);
> +       part_offset = element_nr %
> +                               FLEX_ARRAY_ELEMENTS_PER_PART(fa->element_size);
>         return part_offset * fa->element_size;
>  }

This all looks pretty good.  The only issue is that the macro name
lengths have gotten a bit out of hand.  

For instance.  This:

#define FLEX_ARRAY_ELEMENTS_PER_PART(size)                             \
       (FLEX_ARRAY_PART_SIZE / size)

ends up being longer in practice than just open-coding the operation:

	FLEX_ARRAY_ELEMENTS_PER_PART(fa->element_size)                      

vs.

	(FLEX_ARRAY_PART_SIZE / fa->element_size)

and the length also ends up making for a couple of pretty ugly line
wraps.

Otherwise, this is fine with me.

Acked-by: Dave Hansen <dave@linux.vnet.ibm.com>

-- Dave


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY
  2009-09-02 17:26 ` [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY Dave Hansen
@ 2009-09-02 18:51   ` David Rientjes
  0 siblings, 0 replies; 4+ messages in thread
From: David Rientjes @ 2009-09-02 18:51 UTC (permalink / raw)
  To: Dave Hansen; +Cc: Andrew Morton, linux-kernel

On Wed, 2 Sep 2009, Dave Hansen wrote:

> This all looks pretty good.  The only issue is that the macro name
> lengths have gotten a bit out of hand.  
> 
> For instance.  This:
> 
> #define FLEX_ARRAY_ELEMENTS_PER_PART(size)                             \
>        (FLEX_ARRAY_PART_SIZE / size)
> 
> ends up being longer in practice than just open-coding the operation:
> 
> 	FLEX_ARRAY_ELEMENTS_PER_PART(fa->element_size)                      
> 
> vs.
> 
> 	(FLEX_ARRAY_PART_SIZE / fa->element_size)
> 
> and the length also ends up making for a couple of pretty ugly line
> wraps.
> 

Agreed, it's difficult to shorten because they need to be prefixed with 
FLEX_ARRAY_ since they are global macros now that they've been included in 
linux/flex_array.h.

> Otherwise, this is fine with me.
> 
> Acked-by: Dave Hansen <dave@linux.vnet.ibm.com>
> 

Thanks!

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2009-09-02 18:51 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-09-02  3:14 [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY David Rientjes
2009-09-02  3:14 ` [patch 2/2 -mm] flex_array: add missing kerneldoc annotations David Rientjes
2009-09-02 17:26 ` [patch 1/2 -mm] flex_array: introduce DEFINE_FLEX_ARRAY Dave Hansen
2009-09-02 18:51   ` David Rientjes

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®