mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Akinobu Mita <akinobu.mita@gmail.com>
To: linux-kernel@vger.kernel.org, akpm@linux-foundation.org
Cc: Akinobu Mita <akinobu.mita@gmail.com>,
	Ingo Molnar <mingo@elte.hu>,
	Peter Zijlstra <peterz@infradead.org>
Subject: [PATCH 3/9] sched: Use for_each_set_bit
Date: Tue,  2 Feb 2010 00:10:34 +0900	[thread overview]
Message-ID: <1265037040-23413-3-git-send-email-akinobu.mita@gmail.com> (raw)
In-Reply-To: <1265037040-23413-1-git-send-email-akinobu.mita@gmail.com>

v2: rename for_each_bit to for_each_set_bit

Signed-off-by: Akinobu Mita <akinobu.mita@gmail.com>
Cc: Ingo Molnar <mingo@elte.hu>
Cc: Peter Zijlstra <peterz@infradead.org>
---
 kernel/sched_cpupri.c |    4 +---
 1 files changed, 1 insertions(+), 3 deletions(-)

diff --git a/kernel/sched_cpupri.c b/kernel/sched_cpupri.c
index 597b330..82095bf 100644
--- a/kernel/sched_cpupri.c
+++ b/kernel/sched_cpupri.c
@@ -47,9 +47,7 @@ static int convert_prio(int prio)
 }
 
 #define for_each_cpupri_active(array, idx)                    \
-  for (idx = find_first_bit(array, CPUPRI_NR_PRIORITIES);     \
-       idx < CPUPRI_NR_PRIORITIES;                            \
-       idx = find_next_bit(array, CPUPRI_NR_PRIORITIES, idx+1))
+	for_each_set_bit(idx, array, CPUPRI_NR_PRIORITIES)
 
 /**
  * cpupri_find - find the best (lowest-pri) CPU in the system
-- 
1.6.0.6


  parent reply	other threads:[~2010-02-01 15:14 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-02-01 15:10 [PATCH 1/9] bitops: rename for_each_bit to for_each_set_bit Akinobu Mita
2010-02-01 15:10 ` [PATCH 2/9] sgi-gru: Use for_each_set_bit Akinobu Mita
2010-02-01 15:10 ` Akinobu Mita [this message]
2010-02-01 15:10 ` [PATCH 4/9] bitmap: " Akinobu Mita
2010-02-01 15:10 ` [PATCH 5/9] phonet: " Akinobu Mita
2010-02-01 15:10 ` [PATCH 6/9] intel-iommu: " Akinobu Mita
2010-02-01 15:10 ` [PATCH 7/9] infiniband: " Akinobu Mita
2010-02-01 15:10 ` [PATCH 8/9] atm: " Akinobu Mita
2010-02-01 15:10 ` [PATCH 9/9] hpet: " Akinobu Mita
2010-02-01 17:25 ` [PATCH 1/9] bitops: rename for_each_bit to for_each_set_bit Joe Perches
2010-03-05  4:57 ` Stephen Rothwell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1265037040-23413-3-git-send-email-akinobu.mita@gmail.com \
    --to=akinobu.mita@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=peterz@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®