mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RFC][PATCH v2 0/4] perf: remove __weak function hw_perf_group_sched_in()
@ 2010-04-23  5:55 Lin Ming
  0 siblings, 0 replies; only message in thread
From: Lin Ming @ 2010-04-23  5:55 UTC (permalink / raw)
  To: Peter Zijlstra, Frederic Weisbecker, Ingo Molnar, eranian,
	Gary.Mohr@Bull.com, Corey Ashford, arjan, Zhang, Yanmin,
	Paul Mackerras, David S. Miller
  Cc: lkml

Hi, all

>From the discussion of thread "[RFC] perf_events: support for uncore
a.k.a. nest units", in order to support multiple hw pmu, Peter suggested
the first thing that needs to be done is get rid of all the __weak
functions (with exception of perf_callchain*, since that really is arch
specific), includes

hw_perf_group_sched_in
hw_perf_event_init
hw_perf_disable
hw_perf_enable

Peter Zijlstra <peterz@infradead.org> wrote:
> One thing not on that list, which should happen first I guess, is to
> remove hw_perf_group_sched_in(). The idea is to add some sort of
> transactional API to the struct pmu, so that we can delay the
> schedulability check until commit time (and roll back when it fails).
>
> Something as simple as:
>
>  struct pmu {
>    void start_txn(struct pmu *);
>    void commit_txn(struct pmu *);
>
>    ,,,
>  };
>
> and then change group_sched_in() to use this instead of
> hw_perf_group_sched_in(), whose implementations mostly replicate
> group_sched_in() in various buggy ways anyway.
>

This patch series is to remove hw_perf_group_sched_in() first.

patch 1: core, add group scheduling transactional APIs
patch 2: x86, implement group scheduling transactional APIs
patch 3: powerpc, implement group scheduling transactional APIs
patch 4: sparc, implement group scheduling transactional APIs

I have tested these patches on x86, but for powerpc and sparc it's only
cross build tested.
It's very appreciated if anybody has powerpc or sparc can help to test. 

Thanks for any comment.

Changes log:

v2.
Change transaction flag(cpu_hw_events->group_flag) from u8 to unsigned
int. RISC architecture deals better with word sized variable than u8.
(Peter Zijlstra)

Rename callback names, *_txn -> *_group_trans for better readability.
Add a few comments to describe the callbacks. (Frederic Weisbecker)

v1.
remove __weak function hw_perf_group_sched_in() based on Peter's idea.

Thanks,
Lin Ming


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2010-04-23  5:55 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-04-23  5:55 [RFC][PATCH v2 0/4] perf: remove __weak function hw_perf_group_sched_in() Lin Ming

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®