* [PATCH 1/2] asus_acpi: fix a memory leask in asus_hotk_get_info
@ 2010-07-05 0:53 Axel Lin
2010-07-05 0:54 ` [PATCH 2/2] asus_acpi: fix coding style to improve readability Axel Lin
0 siblings, 1 reply; 2+ messages in thread
From: Axel Lin @ 2010-07-05 0:53 UTC (permalink / raw)
To: linux-kernel
Cc: Corentin Chary, Karol Kozimor, Matthew Garrett, Len Brown,
Alan Jenkins, Andrew Morton, Alexey Dobriyan, acpi4asus-user,
platform-driver-x86
In the case of no match ( hotk->model == END_MODEL ), model sholud be
kfreed before return AE_OK.
This patch includes below fixes:
1. adds a missing kfree(model) before return AE_OK.
2. asus_hotk_get_info should return int, thus return 0 instead of AE_OK.
Signed-off-by: Axel Lin <axel.lin@gmail.com>
---
drivers/platform/x86/asus_acpi.c | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/platform/x86/asus_acpi.c b/drivers/platform/x86/asus_acpi.c
index 92fd30c..ae0914d 100644
--- a/drivers/platform/x86/asus_acpi.c
+++ b/drivers/platform/x86/asus_acpi.c
@@ -1340,7 +1340,8 @@ static int asus_hotk_get_info(void)
return -ENODEV;
}
hotk->methods = &model_conf[hotk->model];
- return AE_OK;
+ kfree(model);
+ return 0;
}
hotk->methods = &model_conf[hotk->model];
printk(KERN_NOTICE " %s model detected, supported\n", string);
@@ -1374,7 +1375,7 @@ static int asus_hotk_get_info(void)
kfree(model);
- return AE_OK;
+ return 0;
}
static int asus_hotk_check(void)
--
1.5.4.3
^ permalink raw reply [flat|nested] 2+ messages in thread
* [PATCH 2/2] asus_acpi: fix coding style to improve readability
2010-07-05 0:53 [PATCH 1/2] asus_acpi: fix a memory leask in asus_hotk_get_info Axel Lin
@ 2010-07-05 0:54 ` Axel Lin
0 siblings, 0 replies; 2+ messages in thread
From: Axel Lin @ 2010-07-05 0:54 UTC (permalink / raw)
To: linux-kernel
Cc: Corentin Chary, Karol Kozimor, Matthew Garrett, Len Brown,
Alan Jenkins, Andrew Morton, Alexey Dobriyan, acpi4asus-user,
platform-driver-x86
In the case of no match ( hotk->model == END_MODEL ),
the only posible case to return 0 is to have a Samsung P30 detected.
This patch improves readability by moving related code after if/else clause
to be inside if clause.
Signed-off-by: Axel Lin <axel.lin@gmail.com>
---
drivers/platform/x86/asus_acpi.c | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/platform/x86/asus_acpi.c b/drivers/platform/x86/asus_acpi.c
index ae0914d..e058c2b 100644
--- a/drivers/platform/x86/asus_acpi.c
+++ b/drivers/platform/x86/asus_acpi.c
@@ -1330,6 +1330,9 @@ static int asus_hotk_get_info(void)
hotk->model = P30;
printk(KERN_NOTICE
" Samsung P30 detected, supported\n");
+ hotk->methods = &model_conf[hotk->model];
+ kfree(model);
+ return 0;
} else {
hotk->model = M2E;
printk(KERN_NOTICE " unsupported model %s, trying "
@@ -1339,9 +1342,6 @@ static int asus_hotk_get_info(void)
kfree(model);
return -ENODEV;
}
- hotk->methods = &model_conf[hotk->model];
- kfree(model);
- return 0;
}
hotk->methods = &model_conf[hotk->model];
printk(KERN_NOTICE " %s model detected, supported\n", string);
--
1.5.4.3
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2010-07-05 0:54 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-07-05 0:53 [PATCH 1/2] asus_acpi: fix a memory leask in asus_hotk_get_info Axel Lin
2010-07-05 0:54 ` [PATCH 2/2] asus_acpi: fix coding style to improve readability Axel Lin
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome