mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Eric Dumazet <eric.dumazet@gmail.com>
To: Jeremy Fitzhardinge <jeremy@goop.org>
Cc: Peter Zijlstra <peterz@infradead.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Nick Piggin <npiggin@suse.de>, Jan Beulich <JBeulich@novell.com>,
	Avi Kivity <avi@redhat.com>,
	Xen-devel <xen-devel@lists.xensource.com>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Linux Virtualization <virtualization@lists.linux-foundation.org>,
	Srivatsa Vaddagiri <vatsa@linux.vnet.ibm.com>,
	Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>
Subject: Re: [PATCH 02/20] x86/ticketlock: convert spin loop to C
Date: Wed, 03 Nov 2010 16:11:32 +0100	[thread overview]
Message-ID: <1288797092.2511.141.camel@edumazet-laptop> (raw)
In-Reply-To: <3d9083892c28a7d3ed5a0191b0b4cd013022a186.1288794124.git.jeremy.fitzhardinge@citrix.com>

Le mercredi 03 novembre 2010 à 10:59 -0400, Jeremy Fitzhardinge a
écrit :
> From: Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>
> 
> The inner loop of __ticket_spin_lock isn't doing anything very special,
> so reimplement it in C.
> 
> For the 8 bit ticket lock variant, we use a register union to get direct
> access to the lower and upper bytes in the tickets, but unfortunately gcc
> won't generate a direct comparison between the two halves of the register,
> so the generated asm isn't quite as pretty as the hand-coded version.
> However benchmarking shows that this is actually a small improvement in
> runtime performance on some benchmarks, and never a slowdown.
> 
> We also need to make sure there's a barrier at the end of the lock loop
> to make sure that the compiler doesn't move any instructions from within
> the locked region into the region where we don't yet own the lock.
> 
> Signed-off-by: Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>
> ---
>  arch/x86/include/asm/spinlock.h |   58 +++++++++++++++++++-------------------
>  1 files changed, 29 insertions(+), 29 deletions(-)
> 
> diff --git a/arch/x86/include/asm/spinlock.h b/arch/x86/include/asm/spinlock.h
> index d6d5784..6711d36 100644
> --- a/arch/x86/include/asm/spinlock.h
> +++ b/arch/x86/include/asm/spinlock.h
> @@ -58,21 +58,21 @@
>  #if (NR_CPUS < 256)
>  static __always_inline void __ticket_spin_lock(arch_spinlock_t *lock)
>  {
> -	unsigned short inc = 1 << TICKET_SHIFT;
> -
> -	asm volatile (
> -		LOCK_PREFIX "xaddw %w0, %1\n"
> -		"1:\t"
> -		"cmpb %h0, %b0\n\t"
> -		"je 2f\n\t"
> -		"rep ; nop\n\t"
> -		"movb %1, %b0\n\t"
> -		/* don't need lfence here, because loads are in-order */
> -		"jmp 1b\n"
> -		"2:"
> -		: "+Q" (inc), "+m" (lock->slock)
> -		:
> -		: "memory", "cc");
> +	register union {
> +		struct __raw_tickets tickets;
> +		unsigned short slock;
> +	} inc = { .slock = 1 << TICKET_SHIFT };
> +
> +	asm volatile (LOCK_PREFIX "xaddw %w0, %1\n"
> +		      : "+Q" (inc), "+m" (lock->slock) : : "memory", "cc");
> +
> +	for (;;) {
> +		if (inc.tickets.head == inc.tickets.tail)
> +			return;
> +		cpu_relax();
> +		inc.tickets.head = ACCESS_ONCE(lock->tickets.head);
> +	}
> +	barrier();		/* make sure nothing creeps before the lock is taken */

Isnt this barrier() never reached ?


>  }
>  
>  static __always_inline int __ticket_spin_trylock(arch_spinlock_t *lock)
> @@ -105,22 +105,22 @@ static __always_inline void __ticket_spin_unlock(arch_spinlock_t *lock)
>  static __always_inline void __ticket_spin_lock(arch_spinlock_t *lock)
>  {
>  	unsigned inc = 1 << TICKET_SHIFT;
> -	unsigned tmp;
> +	__ticket_t tmp;
>  
> -	asm volatile(LOCK_PREFIX "xaddl %0, %1\n"
> -		     "movzwl %w0, %2\n\t"
> -		     "shrl $16, %0\n\t"
> -		     "1:\t"
> -		     "cmpl %0, %2\n\t"
> -		     "je 2f\n\t"
> -		     "rep ; nop\n\t"
> -		     "movzwl %1, %2\n\t"
> -		     /* don't need lfence here, because loads are in-order */
> -		     "jmp 1b\n"
> -		     "2:"
> -		     : "+r" (inc), "+m" (lock->slock), "=&r" (tmp)
> -		     :
> -		     : "memory", "cc");
> +	asm volatile(LOCK_PREFIX "xaddl %0, %1\n\t"
> +		     : "+r" (inc), "+m" (lock->slock)
> +		     : : "memory", "cc");
> +
> +	tmp = inc;
> +	inc >>= TICKET_SHIFT;
> +
> +	for (;;) {
> +		if ((__ticket_t)inc == tmp)
> +			return;
> +		cpu_relax();
> +		tmp = ACCESS_ONCE(lock->tickets.head);
> +	}
> +	barrier();		/* make sure nothing creeps before the lock is taken */

same here

>  }
>  
>  static __always_inline int __ticket_spin_trylock(arch_spinlock_t *lock)



  reply	other threads:[~2010-11-03 15:11 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-03 14:59 [PATCH 00/20] x86: ticket lock rewrite and paravirtualization Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 01/20] x86/ticketlock: clean up types and accessors Jeremy Fitzhardinge
2010-11-13  9:57   ` Américo Wang
2010-11-15 19:36     ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 02/20] x86/ticketlock: convert spin loop to C Jeremy Fitzhardinge
2010-11-03 15:11   ` Eric Dumazet [this message]
2010-11-03 15:38     ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 03/20] x86/ticketlock: Use C for __ticket_spin_unlock Jeremy Fitzhardinge
2010-11-03 15:13   ` Eric Dumazet
2010-11-03 18:00     ` Jeremy Fitzhardinge
2010-11-13 10:05   ` Américo Wang
2010-11-13 22:34     ` Paolo Bonzini
2010-11-15 19:38     ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 04/20] x86/ticketlock: make large and small ticket versions of spin_lock the same Jeremy Fitzhardinge
2010-11-12 12:19   ` Srivatsa Vaddagiri
2010-11-12 16:27     ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 05/20] x86/ticketlock: make __ticket_spin_lock common Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 06/20] x86/ticketlock: make __ticket_spin_trylock common Jeremy Fitzhardinge
2010-11-13 10:17   ` Américo Wang
2010-11-13 10:48     ` Eric Dumazet
2010-11-15 19:39       ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 07/20] x86/spinlocks: replace pv spinlocks with pv ticketlocks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 08/20] x86/ticketlock: collapse a layer of functions Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 09/20] xen/pvticketlock: Xen implementation for PV ticket locks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 10/20] x86/pvticketlock: keep count of blocked cpus Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 11/20] x86/pvticketlock: use callee-save for lock_spinning Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 12/20] x86/pvticketlock: use callee-save for unlock_kick as well Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 13/20] x86/pvticketlock: make sure unlock is seen by everyone before checking waiters Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 14/20] x86/ticketlock: loosen ordering restraints on unlock Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 15/20] x86/ticketlock: prevent compiler reordering into locked region Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 16/20] x86/ticketlock: don't inline _spin_unlock when using paravirt spinlocks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 17/20] x86/ticketlock: clarify barrier in arch_spin_lock Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 18/20] x86/ticketlock: remove .slock Jeremy Fitzhardinge
2010-11-03 15:00 ` [PATCH 19/20] x86/ticketlocks: use overlapping read to eliminate mb() Jeremy Fitzhardinge
2010-11-03 15:00 ` [PATCH 20/20] x86/ticketlock: rename ticketpair to head_tail Jeremy Fitzhardinge
2010-11-12 22:12 ` [PATCH 00/20] x86: ticket lock rewrite and paravirtualization H. Peter Anvin
2010-11-12 22:17   ` Jeremy Fitzhardinge
2010-11-12 22:20     ` H. Peter Anvin
2010-11-15 20:00       ` Jeremy Fitzhardinge
2010-11-15 20:03         ` H. Peter Anvin
2010-11-15 20:14           ` Peter Zijlstra
2010-11-15 21:02             ` Jeremy Fitzhardinge
2010-11-15 21:08               ` Peter Zijlstra

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1288797092.2511.141.camel@edumazet-laptop \
    --to=eric.dumazet@gmail.com \
    --cc=JBeulich@novell.com \
    --cc=avi@redhat.com \
    --cc=hpa@zytor.com \
    --cc=jeremy.fitzhardinge@citrix.com \
    --cc=jeremy@goop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=npiggin@suse.de \
    --cc=peterz@infradead.org \
    --cc=vatsa@linux.vnet.ibm.com \
    --cc=virtualization@lists.linux-foundation.org \
    --cc=xen-devel@lists.xensource.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®