From: Jeremy Fitzhardinge <jeremy@goop.org>
To: "Américo Wang" <xiyou.wangcong@gmail.com>
Cc: Peter Zijlstra <peterz@infradead.org>,
Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
Jan Beulich <JBeulich@novell.com>, Avi Kivity <avi@redhat.com>,
Xen-devel <xen-devel@lists.xensource.com>,
"H. Peter Anvin" <hpa@zytor.com>,
Linux Virtualization <virtualization@lists.linux-foundation.org>,
Srivatsa Vaddagiri <vatsa@linux.vnet.ibm.com>,
Jeremy Fitzhardinge <jeremy.fitzhardinge@citrix.com>
Subject: Re: [PATCH 01/20] x86/ticketlock: clean up types and accessors
Date: Mon, 15 Nov 2010 11:36:54 -0800 [thread overview]
Message-ID: <4CE18BD6.40809@goop.org> (raw)
In-Reply-To: <20101113095732.GF3837@hack>
On 11/13/2010 01:57 AM, Américo Wang wrote:
> On Wed, Nov 03, 2010 at 10:59:42AM -0400, Jeremy Fitzhardinge wrote:
> ...
>> static __always_inline void __ticket_spin_lock(arch_spinlock_t *lock)
>> {
>> - int inc = 0x00010000;
>> - int tmp;
>> + unsigned inc = 1 << TICKET_SHIFT;
>> + unsigned tmp;
> Please don't use old implicit-int.
I don't mind much either way, but I don't think I've seen anyone worry
about this before.
>> - return (((tmp >> TICKET_SHIFT) - tmp) & ((1 << TICKET_SHIFT) - 1)) > 1;
>> + return ((tmp.tail - tmp.head) & TICKET_MASK) > 1;
>
> There is a type promotion here.
...
>> }
>>
>> #ifndef CONFIG_PARAVIRT_SPINLOCKS
>> diff --git a/arch/x86/include/asm/spinlock_types.h b/arch/x86/include/asm/spinlock_types.h
>> index dcb48b2..4582640 100644
>> --- a/arch/x86/include/asm/spinlock_types.h
>> +++ b/arch/x86/include/asm/spinlock_types.h
>> @@ -5,11 +5,27 @@
>> # error "please don't include this file directly"
>> #endif
>>
>> +#include <linux/types.h>
>> +
>> +#if (CONFIG_NR_CPUS < 256)
>> +typedef u8 __ticket_t;
>> +#else
>> +typedef u16 __ticket_t;
>> +#endif
>> +
>> +#define TICKET_SHIFT (sizeof(__ticket_t) * 8)
>> +#define TICKET_MASK ((1 << TICKET_SHIFT) - 1)
>
> So here you may need to cast the result to __ticket_t.
OK.
J
next prev parent reply other threads:[~2010-11-15 19:36 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-11-03 14:59 [PATCH 00/20] x86: ticket lock rewrite and paravirtualization Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 01/20] x86/ticketlock: clean up types and accessors Jeremy Fitzhardinge
2010-11-13 9:57 ` Américo Wang
2010-11-15 19:36 ` Jeremy Fitzhardinge [this message]
2010-11-03 14:59 ` [PATCH 02/20] x86/ticketlock: convert spin loop to C Jeremy Fitzhardinge
2010-11-03 15:11 ` Eric Dumazet
2010-11-03 15:38 ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 03/20] x86/ticketlock: Use C for __ticket_spin_unlock Jeremy Fitzhardinge
2010-11-03 15:13 ` Eric Dumazet
2010-11-03 18:00 ` Jeremy Fitzhardinge
2010-11-13 10:05 ` Américo Wang
2010-11-13 22:34 ` Paolo Bonzini
2010-11-15 19:38 ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 04/20] x86/ticketlock: make large and small ticket versions of spin_lock the same Jeremy Fitzhardinge
2010-11-12 12:19 ` Srivatsa Vaddagiri
2010-11-12 16:27 ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 05/20] x86/ticketlock: make __ticket_spin_lock common Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 06/20] x86/ticketlock: make __ticket_spin_trylock common Jeremy Fitzhardinge
2010-11-13 10:17 ` Américo Wang
2010-11-13 10:48 ` Eric Dumazet
2010-11-15 19:39 ` Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 07/20] x86/spinlocks: replace pv spinlocks with pv ticketlocks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 08/20] x86/ticketlock: collapse a layer of functions Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 09/20] xen/pvticketlock: Xen implementation for PV ticket locks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 10/20] x86/pvticketlock: keep count of blocked cpus Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 11/20] x86/pvticketlock: use callee-save for lock_spinning Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 12/20] x86/pvticketlock: use callee-save for unlock_kick as well Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 13/20] x86/pvticketlock: make sure unlock is seen by everyone before checking waiters Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 14/20] x86/ticketlock: loosen ordering restraints on unlock Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 15/20] x86/ticketlock: prevent compiler reordering into locked region Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 16/20] x86/ticketlock: don't inline _spin_unlock when using paravirt spinlocks Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 17/20] x86/ticketlock: clarify barrier in arch_spin_lock Jeremy Fitzhardinge
2010-11-03 14:59 ` [PATCH 18/20] x86/ticketlock: remove .slock Jeremy Fitzhardinge
2010-11-03 15:00 ` [PATCH 19/20] x86/ticketlocks: use overlapping read to eliminate mb() Jeremy Fitzhardinge
2010-11-03 15:00 ` [PATCH 20/20] x86/ticketlock: rename ticketpair to head_tail Jeremy Fitzhardinge
2010-11-12 22:12 ` [PATCH 00/20] x86: ticket lock rewrite and paravirtualization H. Peter Anvin
2010-11-12 22:17 ` Jeremy Fitzhardinge
2010-11-12 22:20 ` H. Peter Anvin
2010-11-15 20:00 ` Jeremy Fitzhardinge
2010-11-15 20:03 ` H. Peter Anvin
2010-11-15 20:14 ` Peter Zijlstra
2010-11-15 21:02 ` Jeremy Fitzhardinge
2010-11-15 21:08 ` Peter Zijlstra
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4CE18BD6.40809@goop.org \
--to=jeremy@goop.org \
--cc=JBeulich@novell.com \
--cc=avi@redhat.com \
--cc=hpa@zytor.com \
--cc=jeremy.fitzhardinge@citrix.com \
--cc=linux-kernel@vger.kernel.org \
--cc=peterz@infradead.org \
--cc=vatsa@linux.vnet.ibm.com \
--cc=virtualization@lists.linux-foundation.org \
--cc=xen-devel@lists.xensource.com \
--cc=xiyou.wangcong@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®