mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data
@ 2026-02-27 17:56 Krzysztof Kozlowski
  2026-02-27 17:56 ` [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data Krzysztof Kozlowski
  2026-02-27 18:12 ` [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Konrad Dybcio
  0 siblings, 2 replies; 5+ messages in thread
From: Krzysztof Kozlowski @ 2026-02-27 17:56 UTC (permalink / raw)
  To: Bjorn Andersson, Konrad Dybcio, linux-arm-msm, linux-kernel
  Cc: Krzysztof Kozlowski

UBWC data for X1E80100 is exactly the same as one for SM8550, so reduce
code duplication by reusing older entry.

Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
---
 drivers/soc/qcom/ubwc_config.c | 15 ++-------------
 1 file changed, 2 insertions(+), 13 deletions(-)

diff --git a/drivers/soc/qcom/ubwc_config.c b/drivers/soc/qcom/ubwc_config.c
index 1c25aaf55e52..63e77fceb6b8 100644
--- a/drivers/soc/qcom/ubwc_config.c
+++ b/drivers/soc/qcom/ubwc_config.c
@@ -217,17 +217,6 @@ static const struct qcom_ubwc_cfg_data sm8750_data = {
 	.macrotile_mode = true,
 };
 
-static const struct qcom_ubwc_cfg_data x1e80100_data = {
-	.ubwc_enc_version = UBWC_4_0,
-	.ubwc_dec_version = UBWC_4_3,
-	.ubwc_swizzle = UBWC_SWIZZLE_ENABLE_LVL2 |
-			UBWC_SWIZZLE_ENABLE_LVL3,
-	.ubwc_bank_spread = true,
-	/* TODO: highest_bank_bit = 15 for LP_DDR4 */
-	.highest_bank_bit = 16,
-	.macrotile_mode = true,
-};
-
 static const struct qcom_ubwc_cfg_data glymur_data = {
 	.ubwc_enc_version = UBWC_5_0,
 	.ubwc_dec_version = UBWC_5_0,
@@ -294,8 +283,8 @@ static const struct of_device_id qcom_ubwc_configs[] __maybe_unused = {
 	{ .compatible = "qcom,sm8550", .data = &sm8550_data, },
 	{ .compatible = "qcom,sm8650", .data = &sm8550_data, },
 	{ .compatible = "qcom,sm8750", .data = &sm8750_data, },
-	{ .compatible = "qcom,x1e80100", .data = &x1e80100_data, },
-	{ .compatible = "qcom,x1p42100", .data = &x1e80100_data, },
+	{ .compatible = "qcom,x1e80100", .data = &sm8550_data, },
+	{ .compatible = "qcom,x1p42100", .data = &sm8550_data, },
 	{ }
 };
 
-- 
2.51.0


^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data
  2026-02-27 17:56 [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Krzysztof Kozlowski
@ 2026-02-27 17:56 ` Krzysztof Kozlowski
  2026-02-27 18:12   ` Konrad Dybcio
  2026-02-27 19:47   ` Dmitry Baryshkov
  2026-02-27 18:12 ` [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Konrad Dybcio
  1 sibling, 2 replies; 5+ messages in thread
From: Krzysztof Kozlowski @ 2026-02-27 17:56 UTC (permalink / raw)
  To: Bjorn Andersson, Konrad Dybcio, linux-arm-msm, linux-kernel
  Cc: Krzysztof Kozlowski

UBWC data for Glymur is exactly the same as one for SM8750, except
representing same ubwc_swizzle with value instead of defines, so reduce
code duplication by reusing older entry.

Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
---
 drivers/soc/qcom/ubwc_config.c | 12 +-----------
 1 file changed, 1 insertion(+), 11 deletions(-)

diff --git a/drivers/soc/qcom/ubwc_config.c b/drivers/soc/qcom/ubwc_config.c
index 63e77fceb6b8..eb71b2356c75 100644
--- a/drivers/soc/qcom/ubwc_config.c
+++ b/drivers/soc/qcom/ubwc_config.c
@@ -208,16 +208,6 @@ static const struct qcom_ubwc_cfg_data sm8550_data = {
 };
 
 static const struct qcom_ubwc_cfg_data sm8750_data = {
-	.ubwc_enc_version = UBWC_5_0,
-	.ubwc_dec_version = UBWC_5_0,
-	.ubwc_swizzle = 6,
-	.ubwc_bank_spread = true,
-	/* TODO: highest_bank_bit = 15 for LP_DDR4 */
-	.highest_bank_bit = 16,
-	.macrotile_mode = true,
-};
-
-static const struct qcom_ubwc_cfg_data glymur_data = {
 	.ubwc_enc_version = UBWC_5_0,
 	.ubwc_dec_version = UBWC_5_0,
 	.ubwc_swizzle = UBWC_SWIZZLE_ENABLE_LVL2 |
@@ -234,7 +224,7 @@ static const struct of_device_id qcom_ubwc_configs[] __maybe_unused = {
 	{ .compatible = "qcom,apq8074", .data = &no_ubwc_data },
 	{ .compatible = "qcom,apq8096", .data = &msm8998_data },
 	{ .compatible = "qcom,kaanapali", .data = &kaanapali_data, },
-	{ .compatible = "qcom,glymur", .data = &glymur_data},
+	{ .compatible = "qcom,glymur", .data = &sm8750_data},
 	{ .compatible = "qcom,msm8226", .data = &no_ubwc_data },
 	{ .compatible = "qcom,msm8916", .data = &no_ubwc_data },
 	{ .compatible = "qcom,msm8917", .data = &no_ubwc_data },
-- 
2.51.0


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data
  2026-02-27 17:56 [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Krzysztof Kozlowski
  2026-02-27 17:56 ` [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data Krzysztof Kozlowski
@ 2026-02-27 18:12 ` Konrad Dybcio
  1 sibling, 0 replies; 5+ messages in thread
From: Konrad Dybcio @ 2026-02-27 18:12 UTC (permalink / raw)
  To: Krzysztof Kozlowski, Bjorn Andersson, Konrad Dybcio,
	linux-arm-msm, linux-kernel

On 2/27/26 6:56 PM, Krzysztof Kozlowski wrote:
> UBWC data for X1E80100 is exactly the same as one for SM8550, so reduce
> code duplication by reusing older entry.
> 
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
> ---

Reviewed-by: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>

Konrad

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data
  2026-02-27 17:56 ` [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data Krzysztof Kozlowski
@ 2026-02-27 18:12   ` Konrad Dybcio
  2026-02-27 19:47   ` Dmitry Baryshkov
  1 sibling, 0 replies; 5+ messages in thread
From: Konrad Dybcio @ 2026-02-27 18:12 UTC (permalink / raw)
  To: Krzysztof Kozlowski, Bjorn Andersson, Konrad Dybcio,
	linux-arm-msm, linux-kernel

On 2/27/26 6:56 PM, Krzysztof Kozlowski wrote:
> UBWC data for Glymur is exactly the same as one for SM8750, except
> representing same ubwc_swizzle with value instead of defines, so reduce
> code duplication by reusing older entry.
> 
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
> ---

Reviewed-by: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>

Konrad

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data
  2026-02-27 17:56 ` [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data Krzysztof Kozlowski
  2026-02-27 18:12   ` Konrad Dybcio
@ 2026-02-27 19:47   ` Dmitry Baryshkov
  1 sibling, 0 replies; 5+ messages in thread
From: Dmitry Baryshkov @ 2026-02-27 19:47 UTC (permalink / raw)
  To: Krzysztof Kozlowski
  Cc: Bjorn Andersson, Konrad Dybcio, linux-arm-msm, linux-kernel

On Fri, Feb 27, 2026 at 06:56:15PM +0100, Krzysztof Kozlowski wrote:
> UBWC data for Glymur is exactly the same as one for SM8750, except
> representing same ubwc_swizzle with value instead of defines, so reduce
> code duplication by reusing older entry.

I'm sorry, I'd like to ask to defer this patch, we are discussing
whether this data is correct or not.

> 
> Signed-off-by: Krzysztof Kozlowski <krzysztof.kozlowski@oss.qualcomm.com>
> ---
>  drivers/soc/qcom/ubwc_config.c | 12 +-----------
>  1 file changed, 1 insertion(+), 11 deletions(-)
> 
> diff --git a/drivers/soc/qcom/ubwc_config.c b/drivers/soc/qcom/ubwc_config.c
> index 63e77fceb6b8..eb71b2356c75 100644
> --- a/drivers/soc/qcom/ubwc_config.c
> +++ b/drivers/soc/qcom/ubwc_config.c
> @@ -208,16 +208,6 @@ static const struct qcom_ubwc_cfg_data sm8550_data = {
>  };
>  
>  static const struct qcom_ubwc_cfg_data sm8750_data = {
> -	.ubwc_enc_version = UBWC_5_0,
> -	.ubwc_dec_version = UBWC_5_0,
> -	.ubwc_swizzle = 6,
> -	.ubwc_bank_spread = true,
> -	/* TODO: highest_bank_bit = 15 for LP_DDR4 */
> -	.highest_bank_bit = 16,
> -	.macrotile_mode = true,
> -};
> -
> -static const struct qcom_ubwc_cfg_data glymur_data = {
>  	.ubwc_enc_version = UBWC_5_0,
>  	.ubwc_dec_version = UBWC_5_0,
>  	.ubwc_swizzle = UBWC_SWIZZLE_ENABLE_LVL2 |
> @@ -234,7 +224,7 @@ static const struct of_device_id qcom_ubwc_configs[] __maybe_unused = {
>  	{ .compatible = "qcom,apq8074", .data = &no_ubwc_data },
>  	{ .compatible = "qcom,apq8096", .data = &msm8998_data },
>  	{ .compatible = "qcom,kaanapali", .data = &kaanapali_data, },
> -	{ .compatible = "qcom,glymur", .data = &glymur_data},
> +	{ .compatible = "qcom,glymur", .data = &sm8750_data},
>  	{ .compatible = "qcom,msm8226", .data = &no_ubwc_data },
>  	{ .compatible = "qcom,msm8916", .data = &no_ubwc_data },
>  	{ .compatible = "qcom,msm8917", .data = &no_ubwc_data },
> -- 
> 2.51.0
> 

-- 
With best wishes
Dmitry

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2026-02-27 19:47 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-02-27 17:56 [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Krzysztof Kozlowski
2026-02-27 17:56 ` [PATCH 2/2] soc: qcom: ubwc: Remove redundant glymur_data Krzysztof Kozlowski
2026-02-27 18:12   ` Konrad Dybcio
2026-02-27 19:47   ` Dmitry Baryshkov
2026-02-27 18:12 ` [PATCH 1/2] soc: qcom: ubwc: Remove redundant x1e80100_data Konrad Dybcio

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®