From: "Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
To: linux-kernel@vger.kernel.org
Cc: mingo@elte.hu, laijs@cn.fujitsu.com, dipankar@in.ibm.com,
akpm@linux-foundation.org, mathieu.desnoyers@polymtl.ca,
josh@joshtriplett.org, niv@us.ibm.com, tglx@linutronix.de,
peterz@infradead.org, rostedt@goodmis.org,
Valdis.Kletnieks@vt.edu, dhowells@redhat.com,
eric.dumazet@gmail.com, darren@dvhart.com, fweisbec@gmail.com,
sbw@mit.edu, patches@linaro.org,
"Paul E. McKenney" <paul.mckenney@linaro.org>,
"Paul E. McKenney" <paulmck@linux.vnet.ibm.com>
Subject: [PATCH tip/core/rcu 02/17] rcu: Consolidate duplicate callback-list initialization
Date: Fri, 22 Jun 2012 08:34:57 -0700 [thread overview]
Message-ID: <1340379312-6684-2-git-send-email-paulmck@linux.vnet.ibm.com> (raw)
In-Reply-To: <1340379312-6684-1-git-send-email-paulmck@linux.vnet.ibm.com>
From: "Paul E. McKenney" <paul.mckenney@linaro.org>
There are a couple of open-coded initializations of the rcu_data
structure's RCU callback list. This commit therefore consolidates
them into a new init_callback_list() function.
Signed-off-by: Paul E. McKenney <paul.mckenney@linaro.org>
Signed-off-by: Paul E. McKenney <paulmck@linux.vnet.ibm.com>
Reviewed-by: Josh Triplett <josh@joshtriplett.org>
---
kernel/rcutree.c | 23 ++++++++++++++---------
1 files changed, 14 insertions(+), 9 deletions(-)
diff --git a/kernel/rcutree.c b/kernel/rcutree.c
index 0f04480..d938671 100644
--- a/kernel/rcutree.c
+++ b/kernel/rcutree.c
@@ -936,6 +936,18 @@ check_for_new_grace_period(struct rcu_state *rsp, struct rcu_data *rdp)
}
/*
+ * Initialize the specified rcu_data structure's callback list to empty.
+ */
+static void init_callback_list(struct rcu_data *rdp)
+{
+ int i;
+
+ rdp->nxtlist = NULL;
+ for (i = 0; i < RCU_NEXT_SIZE; i++)
+ rdp->nxttail[i] = &rdp->nxtlist;
+}
+
+/*
* Advance this CPU's callbacks, but only if the current grace period
* has ended. This may be called only from the CPU to whom the rdp
* belongs. In addition, the corresponding leaf rcu_node structure's
@@ -1327,8 +1339,6 @@ static void
rcu_send_cbs_to_orphanage(int cpu, struct rcu_state *rsp,
struct rcu_node *rnp, struct rcu_data *rdp)
{
- int i;
-
/*
* Orphan the callbacks. First adjust the counts. This is safe
* because ->onofflock excludes _rcu_barrier()'s adoption of
@@ -1368,9 +1378,7 @@ rcu_send_cbs_to_orphanage(int cpu, struct rcu_state *rsp,
}
/* Finally, initialize the rcu_data structure's list to empty. */
- rdp->nxtlist = NULL;
- for (i = 0; i < RCU_NEXT_SIZE; i++)
- rdp->nxttail[i] = &rdp->nxtlist;
+ init_callback_list(rdp);
}
/*
@@ -2404,16 +2412,13 @@ static void __init
rcu_boot_init_percpu_data(int cpu, struct rcu_state *rsp)
{
unsigned long flags;
- int i;
struct rcu_data *rdp = per_cpu_ptr(rsp->rda, cpu);
struct rcu_node *rnp = rcu_get_root(rsp);
/* Set up local state, ensuring consistent view of global state. */
raw_spin_lock_irqsave(&rnp->lock, flags);
rdp->grpmask = 1UL << (cpu - rdp->mynode->grplo);
- rdp->nxtlist = NULL;
- for (i = 0; i < RCU_NEXT_SIZE; i++)
- rdp->nxttail[i] = &rdp->nxtlist;
+ init_callback_list(rdp);
rdp->qlen_lazy = 0;
rdp->qlen = 0;
rdp->dynticks = &per_cpu(rcu_dynticks, cpu);
--
1.7.8
next prev parent reply other threads:[~2012-06-22 15:35 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-06-22 15:35 [PATCH tip/core/rcu 0/17] v2 Fixups for 3.6 Paul E. McKenney
2012-06-22 15:34 ` [PATCH tip/core/rcu 01/17] rcu: Fix detection of abruptly-ending stall Paul E. McKenney
2012-06-22 15:34 ` Paul E. McKenney [this message]
2012-06-22 15:34 ` [PATCH tip/core/rcu 03/17] rcu: Add ACCESS_ONCE() to ->qlen accesses Paul E. McKenney
2012-06-22 15:34 ` [PATCH tip/core/rcu 04/17] rcu: Add a gcc-style structure initializer for RCU pointers Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 05/17] rcu: Use new RCU_POINTER_INITIALIZER for gcc-style initializations Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 06/17] rcu: Remove return value from RCU_INIT_POINTER() Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 07/17] key: Remove extraneous parentheses from rcu_assign_keypointer() Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 08/17] rcu: Remove return value from rcu_assign_pointer() Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 09/17] rcu: Consolidate tree/tiny __rcu_read_{,un}lock() implementations Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 10/17] rcu: Remove function versions of __kfree_rcu and __is_kfree_rcu_offset Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 11/17] rcu: Make __call_rcu() handle invocation from idle Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 12/17] rcu: Prevent __call_rcu() from invoking RCU core on offline CPUs Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 13/17] rcu: Split RCU core processing out of __call_rcu() Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 14/17] rcu: Fix rcu_is_cpu_idle() #ifdef in TINY_RCU Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 15/17] Prevent uninitialized string in RCU stall info Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 16/17] rcu: Disable preemption in rcu_blocking_is_gp() Paul E. McKenney
2012-06-22 15:35 ` [PATCH tip/core/rcu 17/17] rcu: Add check for CPUs going offline with callbacks queued Paul E. McKenney
2012-06-22 16:02 ` [PATCH tip/core/rcu 04/17] rcu: Add a gcc-style structure initializer for RCU pointers David Howells
2012-06-22 16:02 ` [PATCH tip/core/rcu 05/17] rcu: Use new RCU_POINTER_INITIALIZER for gcc-style initializations David Howells
2012-06-22 16:04 ` [PATCH tip/core/rcu 07/17] key: Remove extraneous parentheses from rcu_assign_keypointer() David Howells
2012-06-23 5:59 ` Paul E. McKenney
2012-06-25 4:02 ` Paul E. McKenney
2012-06-22 16:06 ` [PATCH tip/core/rcu 06/17] rcu: Remove return value from RCU_INIT_POINTER() David Howells
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1340379312-6684-2-git-send-email-paulmck@linux.vnet.ibm.com \
--to=paulmck@linux.vnet.ibm.com \
--cc=Valdis.Kletnieks@vt.edu \
--cc=akpm@linux-foundation.org \
--cc=darren@dvhart.com \
--cc=dhowells@redhat.com \
--cc=dipankar@in.ibm.com \
--cc=eric.dumazet@gmail.com \
--cc=fweisbec@gmail.com \
--cc=josh@joshtriplett.org \
--cc=laijs@cn.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mathieu.desnoyers@polymtl.ca \
--cc=mingo@elte.hu \
--cc=niv@us.ibm.com \
--cc=patches@linaro.org \
--cc=paul.mckenney@linaro.org \
--cc=peterz@infradead.org \
--cc=rostedt@goodmis.org \
--cc=sbw@mit.edu \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®