mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/3] staging/gdm72xx: Include corresponding header file (fix sparse warning)
@ 2013-02-19 17:50 Peter Huewe
  2013-02-19 17:50 ` [PATCH 2/3] staging/gdm72xx: Remove unused variable in gdm_qos.c Peter Huewe
  2013-02-19 17:50 ` [PATCH 3/3] staging/gdm72xx: Remove duplicated code " Peter Huewe
  0 siblings, 2 replies; 3+ messages in thread
From: Peter Huewe @ 2013-02-19 17:50 UTC (permalink / raw)
  To: Greg Kroah-Hartman
  Cc: David S. Miller, Pablo Neira Ayuso, Stephen Hemminger,
	Eric W. Biederman, Sage Ahn, Macpaul Lin, YAMANE Toshiaki,
	Devendra Naga, devel, linux-kernel, Peter Huewe

sdio_boot.c and netlink_k.c both have a corresponding header file with
their function prototypes but fail to include them, which leads to the
following sparse warnings:
sdio_boot.c:135:5: warning: symbol 'sdio_boot' was not declared. Should it be static?
netlink_k.c:89:13: warning: symbol 'netlink_init' was not declared. Should it be static?
netlink_k.c:109:6: warning: symbol 'netlink_exit' was not declared. Should it be static?
netlink_k.c:114:5: warning: symbol 'netlink_send' was not declared. Should it be static?

-> Add the include files and silence the warning

Signed-off-by: Peter Huewe <peterhuewe@gmx.de>
---
 drivers/staging/gdm72xx/netlink_k.c |    1 +
 drivers/staging/gdm72xx/sdio_boot.c |    1 +
 2 files changed, 2 insertions(+), 0 deletions(-)

diff --git a/drivers/staging/gdm72xx/netlink_k.c b/drivers/staging/gdm72xx/netlink_k.c
index 52c25ba..8a92605 100644
--- a/drivers/staging/gdm72xx/netlink_k.c
+++ b/drivers/staging/gdm72xx/netlink_k.c
@@ -18,6 +18,7 @@
 #include <linux/netlink.h>
 #include <asm/byteorder.h>
 #include <net/sock.h>
+#include "netlink_k.h"
 
 #if !defined(NLMSG_HDRLEN)
 #define NLMSG_HDRLEN	 ((int) NLMSG_ALIGN(sizeof(struct nlmsghdr)))
diff --git a/drivers/staging/gdm72xx/sdio_boot.c b/drivers/staging/gdm72xx/sdio_boot.c
index 93046dd..4302fcb 100644
--- a/drivers/staging/gdm72xx/sdio_boot.c
+++ b/drivers/staging/gdm72xx/sdio_boot.c
@@ -27,6 +27,7 @@
 #include <linux/firmware.h>
 
 #include "gdm_sdio.h"
+#include "sdio_boot.h"
 
 #define TYPE_A_HEADER_SIZE	4
 #define TYPE_A_LOOKAHEAD_SIZE   16
-- 
1.7.8.6


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2013-02-19 17:45 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-02-19 17:50 [PATCH 1/3] staging/gdm72xx: Include corresponding header file (fix sparse warning) Peter Huewe
2013-02-19 17:50 ` [PATCH 2/3] staging/gdm72xx: Remove unused variable in gdm_qos.c Peter Huewe
2013-02-19 17:50 ` [PATCH 3/3] staging/gdm72xx: Remove duplicated code " Peter Huewe

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®