mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Zhang Rui <rui.zhang@intel.com>
To: Eduardo Valentin <eduardo.valentin@ti.com>
Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH RESEND 01/11] thermal: use strlcpy instead of strcpy
Date: Wed, 17 Apr 2013 23:36:21 +0800	[thread overview]
Message-ID: <1366212981.2091.67.camel@rzhang1-mobl4> (raw)
In-Reply-To: <1365437258-31412-2-git-send-email-eduardo.valentin@ti.com>

On Mon, 2013-04-08 at 12:07 -0400, Eduardo Valentin wrote:
> For memory boundaries safety, use strlcpy instead of strcpy.
> 
> Signed-off-by: Eduardo Valentin <eduardo.valentin@ti.com>

ACK.

thanks,
rui
> ---
>  drivers/thermal/thermal_sys.c |    4 ++--
>  1 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
> index 5b7863a..7875607 100644
> --- a/drivers/thermal/thermal_sys.c
> +++ b/drivers/thermal/thermal_sys.c
> @@ -1289,7 +1289,7 @@ thermal_cooling_device_register(char *type, void *devdata,
>  		return ERR_PTR(result);
>  	}
>  
> -	strcpy(cdev->type, type ? : "");
> +	strlcpy(cdev->type, type ? : "", sizeof(cdev->type));
>  	mutex_init(&cdev->lock);
>  	INIT_LIST_HEAD(&cdev->thermal_instances);
>  	cdev->ops = ops;
> @@ -1594,7 +1594,7 @@ struct thermal_zone_device *thermal_zone_device_register(const char *type,
>  		return ERR_PTR(result);
>  	}
>  
> -	strcpy(tz->type, type ? : "");
> +	strlcpy(tz->type, type ? : "", sizeof(tz->type));
>  	tz->ops = ops;
>  	tz->tzp = tzp;
>  	tz->device.class = &thermal_class;



  reply	other threads:[~2013-04-17 15:36 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-04-08 16:07 From: Eduardo Valentin <eduardo.valentin@ti.com> Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 01/11] thermal: use strlcpy instead of strcpy Eduardo Valentin
2013-04-17 15:36   ` Zhang Rui [this message]
2013-04-08 16:07 ` [PATCH RESEND 02/11] thermal: update driver license Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 03/11] thermal: rename notify_thermal_framework to thermal_notify_framework Eduardo Valentin
2013-04-17 15:37   ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 04/11] thermal: rename get_thermal_instance to thermal_instance_get Eduardo Valentin
2013-04-17 15:09   ` Zhang Rui
2013-04-17 19:18     ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 05/11] thermal: rename get_tz_trend to thermal_zone_trend_get Eduardo Valentin
2013-04-17 15:10   ` Zhang Rui
2013-04-17 19:20     ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 06/11] thermal: use EXPORT_SYMBOL_GPL Eduardo Valentin
2013-04-17 15:20   ` Zhang Rui
2013-04-17 19:22     ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 07/11] thermal: update kernel-doc for thermal_zone_bind_cooling_device Eduardo Valentin
2013-04-17 15:26   ` Zhang Rui
2013-04-17 15:28     ` Zhang Rui
2013-04-17 19:24       ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 08/11] thermal: update kernel-doc for thermal_zone_unbind_cooling_device Eduardo Valentin
2013-04-17 15:29   ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 09/11] thermal: update kernel-doc for thermal_cooling_device_register Eduardo Valentin
2013-04-17 15:31   ` Zhang Rui
2013-04-17 19:25     ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 10/11] thermal: update kernel-doc for create_trip_attrs Eduardo Valentin
2013-04-17 15:31   ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 11/11] thermal: update kernel-doc for thermal_zone_device_register Eduardo Valentin
2013-04-17 15:24   ` Zhang Rui
2013-04-17 19:30     ` Eduardo Valentin
2013-04-24 16:50       ` Zhang, Rui
2013-04-17 17:15 ` From: Eduardo Valentin <eduardo.valentin@ti.com> Eduardo Valentin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1366212981.2091.67.camel@rzhang1-mobl4 \
    --to=rui.zhang@intel.com \
    --cc=eduardo.valentin@ti.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®