From: Zhang Rui <rui.zhang@intel.com>
To: Eduardo Valentin <eduardo.valentin@ti.com>
Cc: linux-pm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH RESEND 03/11] thermal: rename notify_thermal_framework to thermal_notify_framework
Date: Wed, 17 Apr 2013 23:37:21 +0800 [thread overview]
Message-ID: <1366213041.2091.68.camel@rzhang1-mobl4> (raw)
In-Reply-To: <1365437258-31412-4-git-send-email-eduardo.valentin@ti.com>
On Mon, 2013-04-08 at 12:07 -0400, Eduardo Valentin wrote:
> To follow the prefix names used by the thermal exported functions,
> this patch renames notify_thermal_framework to thermal_notify_framework.
>
> Signed-off-by: Eduardo Valentin <eduardo.valentin@ti.com>
Hmm, I'm okay with this one.
thanks,
rui
> ---
> Documentation/thermal/sysfs-api.txt | 2 +-
> drivers/thermal/thermal_sys.c | 6 +++---
> include/linux/thermal.h | 2 +-
> 3 files changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/Documentation/thermal/sysfs-api.txt b/Documentation/thermal/sysfs-api.txt
> index 6859661..4b23190 100644
> --- a/Documentation/thermal/sysfs-api.txt
> +++ b/Documentation/thermal/sysfs-api.txt
> @@ -363,7 +363,7 @@ This function returns the thermal_instance corresponding to a given
> {thermal_zone, cooling_device, trip_point} combination. Returns NULL
> if such an instance does not exist.
>
> -5.3:notify_thermal_framework:
> +5.3:thermal_notify_framework:
> This function handles the trip events from sensor drivers. It starts
> throttling the cooling devices according to the policy configured.
> For CRITICAL and HOT trip points, this notifies the respective drivers,
> diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
> index 9542600..ffaf6d3 100644
> --- a/drivers/thermal/thermal_sys.c
> +++ b/drivers/thermal/thermal_sys.c
> @@ -1420,7 +1420,7 @@ void thermal_cdev_update(struct thermal_cooling_device *cdev)
> EXPORT_SYMBOL(thermal_cdev_update);
>
> /**
> - * notify_thermal_framework - Sensor drivers use this API to notify framework
> + * thermal_notify_framework - Sensor drivers use this API to notify framework
> * @tz: thermal zone device
> * @trip: indicates which trip point has been crossed
> *
> @@ -1431,11 +1431,11 @@ EXPORT_SYMBOL(thermal_cdev_update);
> * The throttling policy is based on the configured platform data; if no
> * platform data is provided, this uses the step_wise throttling policy.
> */
> -void notify_thermal_framework(struct thermal_zone_device *tz, int trip)
> +void thermal_notify_framework(struct thermal_zone_device *tz, int trip)
> {
> handle_thermal_trip(tz, trip);
> }
> -EXPORT_SYMBOL(notify_thermal_framework);
> +EXPORT_SYMBOL(thermal_notify_framework);
>
> /**
> * create_trip_attrs - create attributes for trip points
> diff --git a/include/linux/thermal.h b/include/linux/thermal.h
> index f0bd7f9..e8ec9d8 100644
> --- a/include/linux/thermal.h
> +++ b/include/linux/thermal.h
> @@ -242,7 +242,7 @@ int get_tz_trend(struct thermal_zone_device *, int);
> struct thermal_instance *get_thermal_instance(struct thermal_zone_device *,
> struct thermal_cooling_device *, int);
> void thermal_cdev_update(struct thermal_cooling_device *);
> -void notify_thermal_framework(struct thermal_zone_device *, int);
> +void thermal_notify_framework(struct thermal_zone_device *, int);
>
> int thermal_register_governor(struct thermal_governor *);
> void thermal_unregister_governor(struct thermal_governor *);
next prev parent reply other threads:[~2013-04-17 15:37 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-04-08 16:07 From: Eduardo Valentin <eduardo.valentin@ti.com> Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 01/11] thermal: use strlcpy instead of strcpy Eduardo Valentin
2013-04-17 15:36 ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 02/11] thermal: update driver license Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 03/11] thermal: rename notify_thermal_framework to thermal_notify_framework Eduardo Valentin
2013-04-17 15:37 ` Zhang Rui [this message]
2013-04-08 16:07 ` [PATCH RESEND 04/11] thermal: rename get_thermal_instance to thermal_instance_get Eduardo Valentin
2013-04-17 15:09 ` Zhang Rui
2013-04-17 19:18 ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 05/11] thermal: rename get_tz_trend to thermal_zone_trend_get Eduardo Valentin
2013-04-17 15:10 ` Zhang Rui
2013-04-17 19:20 ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 06/11] thermal: use EXPORT_SYMBOL_GPL Eduardo Valentin
2013-04-17 15:20 ` Zhang Rui
2013-04-17 19:22 ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 07/11] thermal: update kernel-doc for thermal_zone_bind_cooling_device Eduardo Valentin
2013-04-17 15:26 ` Zhang Rui
2013-04-17 15:28 ` Zhang Rui
2013-04-17 19:24 ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 08/11] thermal: update kernel-doc for thermal_zone_unbind_cooling_device Eduardo Valentin
2013-04-17 15:29 ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 09/11] thermal: update kernel-doc for thermal_cooling_device_register Eduardo Valentin
2013-04-17 15:31 ` Zhang Rui
2013-04-17 19:25 ` Eduardo Valentin
2013-04-08 16:07 ` [PATCH RESEND 10/11] thermal: update kernel-doc for create_trip_attrs Eduardo Valentin
2013-04-17 15:31 ` Zhang Rui
2013-04-08 16:07 ` [PATCH RESEND 11/11] thermal: update kernel-doc for thermal_zone_device_register Eduardo Valentin
2013-04-17 15:24 ` Zhang Rui
2013-04-17 19:30 ` Eduardo Valentin
2013-04-24 16:50 ` Zhang, Rui
2013-04-17 17:15 ` From: Eduardo Valentin <eduardo.valentin@ti.com> Eduardo Valentin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1366213041.2091.68.camel@rzhang1-mobl4 \
--to=rui.zhang@intel.com \
--cc=eduardo.valentin@ti.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®