From: Huang Shijie <b32955@freescale.com>
To: <dwmw2@infradead.org>
Cc: <dedekind1@gmail.com>, <computersforpeace@gmail.com>,
<linux-mtd@lists.infradead.org>, <linux-kernel@vger.kernel.org>,
Huang Shijie <b32955@freescale.com>
Subject: [PATCH v5 00/11] mtd: add datasheet's ECC information to nand_chip{}
Date: Wed, 15 May 2013 16:40:23 +0800 [thread overview]
Message-ID: <1368607232-2210-1-git-send-email-b32955@freescale.com> (raw)
1.) Why add the ECC information to the nand_chip{} ?
Each nand chip has its requirement for the ECC correctability, such as
"4bit ECC for each 512Byte" or "40bit ECC for each 1024Byte".
This ECC info is very important to the nand controller, such as gpmi.
Take the Micron MT29F64G08CBABA for example, its geometry is
8k page size, 744 bytes oob size and it requires 40bit ECC per 1K bytes.
If we do not provide the ECC info to the gpmi nand driver, it has to
calculate the ECC correctability itself. The gpmi driver will gets the 56bit
ECC for per 1K bytes which is beyond its BCH's 40bit ecc capibility.
The gpmi will quits in this case. But in actually, the gpmi can supports
this nand chip if it can get the right ECC info.
2.) About the patch set:
2.1) patch 1:
The keynote patch.
2.2) patch 2 ~ patch 7:
These patches are for ONFI nand.
Parse out the ecc info from the parameter page if we can, else
parse out the ecc info from the extended parameter page.
2.2) patch 8 ~ patch 10:
Add the ECC info for full-id nand, and parse it out.
2.3) patch 11
The gpmi uses the ecc info to set the BCH module. and with this
patch set, the gpmi can supports the MT29F64G08CBABA now.
v4 --> v5:
[0] rebase the new l2-mtd(dropped the 3 merged patches).
[1] rename ecc_size to ecc_step.
[2] change the comment for the new fields.
v3 --> v4:
[0] remove the printk for "out of memory".
[1] remove the hardcode nand_command_lp(). Update the chip->cmd_func
before we call the nand_flash_detect_ext_param_page().
[2] split the ecc_info to two fields for full id nand.
[3] update the comments for ecc_strength/ecc_size (from Brian).
v2 --> v3:
[0] add a new patch to define the semantics of the two fields.
[1] Use the Change Read Column command to remove the "last" argument.
[2] simplify the onfi_feature().
[3] Use kmalloc() to replace kcalloc().
[4] others.
v1 --> v2:
[0] Since the first 3 patches are accepted, I do not send them in the
version 2.
[1] add NAND_ prefix for macros used by the full-id nands.
[2] add onfi_ prefix for the extend parameter page data structures.
[3] rename the onfi_get_feature() to onfi_feature().
[4] I re-test this patch set again.
Huang Shijie (11):
mtd: add datasheet's ECC information to nand_chip{}
mtd: increase max OOB size to 744
mtd: get the ECC info from the parameter page for ONFI nand
mtd: add data structures for Extended Parameter Page
mtd: add a helper to get the supported features for ONFI nand
mtd: get the ECC info from the Extended Parameter Page
mtd: replace the hardcode with the onfi_feature()
mtd: add ECC info for nand_flash_dev{}
mtd: parse out the ECC info for the full-id nand chips
mtd: add the ecc info for some full-id nand chips
mtd: gpmi: set the BCH's geometry with the ecc info
drivers/mtd/nand/gpmi-nand/gpmi-nand.c | 128 +++++++++++++++++++++++++++++++-
drivers/mtd/nand/nand_base.c | 90 +++++++++++++++++++++-
drivers/mtd/nand/nand_ids.c | 8 +-
include/linux/mtd/nand.h | 74 ++++++++++++++++++-
4 files changed, 290 insertions(+), 10 deletions(-)
next reply other threads:[~2013-05-15 8:56 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-05-15 8:40 Huang Shijie [this message]
2013-05-15 8:40 ` [PATCH v5 01/11] " Huang Shijie
2013-05-15 12:11 ` Artem Bityutskiy
2013-05-16 2:16 ` Huang Shijie
2013-05-16 7:14 ` Artem Bityutskiy
2013-05-16 8:06 ` Huang Shijie
2013-05-16 9:36 ` Artem Bityutskiy
2013-05-16 10:46 ` Huang Shijie
2013-05-15 8:40 ` [PATCH v5 02/11] mtd: increase max OOB size to 744 Huang Shijie
2013-05-15 12:12 ` Artem Bityutskiy
2013-05-15 8:40 ` [PATCH v5 03/11] mtd: get the ECC info from the parameter page for ONFI nand Huang Shijie
2013-05-15 8:40 ` [PATCH v5 04/11] mtd: add data structures for Extended Parameter Page Huang Shijie
2013-05-15 8:40 ` [PATCH v5 05/11] mtd: add a helper to get the supported features for ONFI nand Huang Shijie
2013-05-15 8:40 ` [PATCH v5 06/11] mtd: get the ECC info from the Extended Parameter Page Huang Shijie
2013-05-15 8:40 ` [PATCH v5 07/11] mtd: replace the hardcode with the onfi_feature() Huang Shijie
2013-05-15 8:40 ` [PATCH v5 08/11] mtd: add ECC info for nand_flash_dev{} Huang Shijie
2013-05-15 8:40 ` [PATCH v5 09/11] mtd: parse out the ECC info for the full-id nand chips Huang Shijie
2013-05-15 8:54 ` [PATCH v5 10/11] mtd: add the ecc info for some " Huang Shijie
2013-05-15 8:54 ` [PATCH v5 11/11] mtd: gpmi: set the BCH's geometry with the ecc info Huang Shijie
2013-05-15 10:05 ` [PATCH v5 00/11] mtd: add datasheet's ECC information to nand_chip{} Artem Bityutskiy
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1368607232-2210-1-git-send-email-b32955@freescale.com \
--to=b32955@freescale.com \
--cc=computersforpeace@gmail.com \
--cc=dedekind1@gmail.com \
--cc=dwmw2@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®