mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Rusty Russell <rusty@rustcorp.com.au>
To: linux-kernel@vger.kernel.org
Cc: Rusty Russell <rusty@rustcorp.com.au>,
	Julia Lawall <julia.lawall@lip6.fr>,
	"Michael S. Tsirkin" <mst@redhat.com>
Subject: [PATCH 1/9] PTR_RET is now PTR_ERR_OR_ZERO
Date: Sun, 16 Jun 2013 14:12:40 +0930	[thread overview]
Message-ID: <1371357768-4968-1-git-send-email-rusty@rustcorp.com.au> (raw)
In-Reply-To: <87ehc2rczo.fsf@rustcorp.com.au>

True, it's often used in return statements, but after much bikeshedding
it's probably better to have an explicit name.

(I tried just putting the IS_ERR check inside PTR_ERR itself and gcc
usually generated no more code.  But that clashes current expectations
of how PTR_ERR behaves, so having a separate function is better).

Suggested-by: Julia Lawall <julia.lawall@lip6.fr>
Suggested-by: "Michael S. Tsirkin" <mst@redhat.com>
Cc: Julia Lawall <julia.lawall@lip6.fr>
Cc: "Michael S. Tsirkin" <mst@redhat.com>
Signed-off-by: Rusty Russell <rusty@rustcorp.com.au>
---
 include/linux/err.h | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/include/linux/err.h b/include/linux/err.h
index f2edce2..ee365c4 100644
--- a/include/linux/err.h
+++ b/include/linux/err.h
@@ -52,7 +52,7 @@ static inline void * __must_check ERR_CAST(const void *ptr)
 	return (void *) ptr;
 }
 
-static inline int __must_check PTR_RET(const void *ptr)
+static inline int __must_check PTR_ERR_OR_ZERO(const void *ptr)
 {
 	if (IS_ERR(ptr))
 		return PTR_ERR(ptr);
@@ -60,6 +60,9 @@ static inline int __must_check PTR_RET(const void *ptr)
 		return 0;
 }
 
+/* Deprecated */
+#define PTR_RET(p) PTR_ERR_OR_ZERO(p)
+
 #endif
 
 #endif /* _LINUX_ERR_H */
-- 
1.8.1.2


  reply	other threads:[~2013-06-16  4:46 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-01  9:56 [PATCH] virtio-mmio: Cocci spatch "ptr_ret.spatch" Thomas Meyer
2013-06-03  2:29 ` [RFC] PTR_ERR: return 0 if ptr isn't an error value Rusty Russell
2013-06-03  7:15   ` Uwe Kleine-König
2013-06-08 21:07     ` Julia Lawall
2013-06-13  4:37       ` Rusty Russell
2013-06-13  7:30         ` Michael S. Tsirkin
2013-06-13  7:56           ` Julia Lawall
2013-06-16  2:44             ` Rusty Russell
2013-06-16  4:42               ` Rusty Russell [this message]
2013-06-16  4:42                 ` [PATCH 2/9] PTR_RET is now PTR_ERR_OR_ZERO(): Replace most Rusty Russell
2013-06-20  6:05                   ` David Miller
2013-06-25  7:47                   ` Benjamin Herrenschmidt
2013-06-16  4:42                 ` [PATCH 3/9] s390: Replace weird use of PTR_RET Rusty Russell
2013-06-17  5:03                   ` Heiko Carstens
2013-06-16  4:42                 ` [PATCH 4/9] acpi: " Rusty Russell
2013-06-16 11:55                   ` Rafael J. Wysocki
2013-06-16  4:42                 ` [PATCH 5/9] pinctrl: don't use PTR_RET() Rusty Russell
2013-06-16  4:42                 ` [PATCH 6/9] remoteproc: " Rusty Russell
2013-06-17  3:15                   ` Ohad Ben-Cohen
2013-06-17  3:49                     ` Rusty Russell
2013-06-16  4:42                 ` [PATCH 7/9] staging/zcache: " Rusty Russell
2013-06-16  4:42                 ` [PATCH 8/9] x86: remove weird PTR_ERR() in do_debug Rusty Russell
2013-06-19 18:43                   ` [tip:x86/debug] x86: Remove " tip-bot for Rusty Russell
2013-06-16  4:42                 ` [PATCH 9/9] mm/oom_kill: remove weird use of ERR_PTR()/PTR_ERR() Rusty Russell
2013-06-16 18:11                   ` David Rientjes
2013-06-17  3:50                     ` Rusty Russell
2013-06-09  5:55     ` [RFC] PTR_ERR: return 0 if ptr isn't an error value Rusty Russell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1371357768-4968-1-git-send-email-rusty@rustcorp.com.au \
    --to=rusty@rustcorp.com.au \
    --cc=julia.lawall@lip6.fr \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mst@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome