From: Joe Perches <joe@perches.com>
To: Rupesh Gujare <rupesh.gujare@atmel.com>
Cc: shigekatsu.tateno@atmel.com, Greg KH <gregkh@linuxfoundation.org>,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org,
devel@linuxdriverproject.org
Subject: Re: [PATCH] staging: ozwpan: Use normal Makefile, convert oz_trace to oz_dbg
Date: Wed, 26 Jun 2013 07:19:08 -0700 [thread overview]
Message-ID: <1372256348.2076.11.camel@joe-AO722> (raw)
In-Reply-To: <1372255013.2076.4.camel@joe-AO722>
On Wed, 2013-06-26 at 06:56 -0700, Joe Perches wrote:
> On Wed, 2013-06-26 at 12:53 +0100, Rupesh Gujare wrote:
> > Above macros look good, however Greg have objection to define new macros
> > & he had suggested to use dev_dbg() & pr_debug().
These macros already use pr_debug and should
use dev_dbg and netdev_dbg where appropriate
and possible. These uses also don't depend
on a single saved global "struct device *".
The grouping/verbose flags are just as you
use them now, but a lot simpler and allow
an easy conversion to a runtime module_param.
next prev parent reply other threads:[~2013-06-26 14:19 UTC|newest]
Thread overview: 34+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-06-25 16:30 [PATCH] staging: ozwpan: Convert printk to dev_dbg() Rupesh Gujare
2013-06-25 16:40 ` Joe Perches
2013-06-25 17:02 ` Greg KH
2013-06-25 17:29 ` Joe Perches
2013-06-25 17:38 ` Greg KH
2013-06-25 17:56 ` Joe Perches
2013-06-25 18:03 ` Joe Perches
2013-06-26 17:51 ` Jason Baron
2013-06-26 1:00 ` [PATCH] staging: ozwpan: Use normal Makefile, convert oz_trace to oz_dbg Joe Perches
2013-06-26 11:53 ` Rupesh Gujare
2013-06-26 13:56 ` Joe Perches
2013-06-26 14:19 ` Joe Perches [this message]
2013-07-04 12:35 ` [PATCH v2 0/5] Replace debug macro Rupesh Gujare
2013-07-04 14:31 ` Joe Perches
2013-07-04 12:35 ` [PATCH v2 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-04 12:35 ` [PATCH v2 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-07-04 12:45 ` Rupesh Gujare
2013-07-22 17:43 ` Rupesh Gujare
2013-07-22 17:55 ` Greg Kroah-Hartman
2013-07-22 22:08 ` Gujare, Rupesh
2013-07-23 12:44 ` [PATCH v3 0/5] staging: ozwpan: Replace debug macro Rupesh Gujare
2013-07-23 12:44 ` [PATCH v3 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-23 12:45 ` [PATCH v3 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-06-26 17:46 ` [PATCH] staging: ozwpan: Convert printk to dev_dbg() Jason Baron
2013-06-27 0:26 ` Joe Perches
2013-06-25 17:49 ` Rupesh Gujare
2013-06-25 17:55 ` Alan Stern
2013-06-25 17:57 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1372256348.2076.11.camel@joe-AO722 \
--to=joe@perches.com \
--cc=devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=rupesh.gujare@atmel.com \
--cc=shigekatsu.tateno@atmel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®