mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Rupesh Gujare <rupesh.gujare@atmel.com>
To: <joe@perches.com>, <devel@linuxdriverproject.org>
Cc: <linux-usb@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
	<gregkh@linuxfoundation.org>
Subject: [PATCH v3 0/5] staging: ozwpan: Replace debug macro
Date: Tue, 23 Jul 2013 13:44:58 +0100	[thread overview]
Message-ID: <1374583503-5642-1-git-send-email-rupesh.gujare@atmel.com> (raw)
In-Reply-To: <20130722175535.GA3682@kroah.com>

This is v3 of this original patch series here:-
http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2013-June/039280.html

v3 adds commit log for each patch as suggested by Joe here:-
http://driverdev.linuxdriverproject.org/pipermail/driverdev-devel/2013-July/039361.html

Joe Perches (5):
  staging: ozwpan: Remove extra debug logs.
  staging: ozwpan: Replace oz_trace with oz_dbg
  staging: ozwpan: Remove old debug macro.
  staging: ozwpan: Convert macro to function.
  staging: ozwpan: Rename Kbuild to Makefile

 drivers/staging/ozwpan/Kbuild          |   18 --
 drivers/staging/ozwpan/Makefile        |   16 ++
 drivers/staging/ozwpan/ozcdev.c        |   52 +++---
 drivers/staging/ozwpan/ozconfig.h      |   26 ---
 drivers/staging/ozwpan/ozdbg.h         |   54 ++++++
 drivers/staging/ozwpan/ozeltbuf.c      |   32 ++--
 drivers/staging/ozwpan/ozhcd.c         |  296 +++++++++++++++-----------------
 drivers/staging/ozwpan/ozmain.c        |    7 +-
 drivers/staging/ozwpan/ozpd.c          |   67 ++++----
 drivers/staging/ozwpan/ozproto.c       |   60 +++----
 drivers/staging/ozwpan/ozproto.h       |    2 +-
 drivers/staging/ozwpan/oztrace.c       |   36 ----
 drivers/staging/ozwpan/oztrace.h       |   35 ----
 drivers/staging/ozwpan/ozurbparanoia.c |   14 +-
 drivers/staging/ozwpan/ozurbparanoia.h |    4 +-
 drivers/staging/ozwpan/ozusbsvc.c      |   25 +--
 drivers/staging/ozwpan/ozusbsvc1.c     |   19 +-
 17 files changed, 348 insertions(+), 415 deletions(-)
 delete mode 100644 drivers/staging/ozwpan/Kbuild
 create mode 100644 drivers/staging/ozwpan/Makefile
 delete mode 100644 drivers/staging/ozwpan/ozconfig.h
 create mode 100644 drivers/staging/ozwpan/ozdbg.h
 delete mode 100644 drivers/staging/ozwpan/oztrace.c
 delete mode 100644 drivers/staging/ozwpan/oztrace.h

-- 
1.7.9.5


  parent reply	other threads:[~2013-07-23 12:45 UTC|newest]

Thread overview: 34+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-06-25 16:30 [PATCH] staging: ozwpan: Convert printk to dev_dbg() Rupesh Gujare
2013-06-25 16:40 ` Joe Perches
2013-06-25 17:02 ` Greg KH
2013-06-25 17:29   ` Joe Perches
2013-06-25 17:38     ` Greg KH
2013-06-25 17:56       ` Joe Perches
2013-06-25 18:03         ` Joe Perches
2013-06-26 17:51           ` Jason Baron
2013-06-26  1:00       ` [PATCH] staging: ozwpan: Use normal Makefile, convert oz_trace to oz_dbg Joe Perches
2013-06-26 11:53         ` Rupesh Gujare
2013-06-26 13:56           ` Joe Perches
2013-06-26 14:19             ` Joe Perches
2013-07-04 12:35             ` [PATCH v2 0/5] Replace debug macro Rupesh Gujare
2013-07-04 14:31               ` Joe Perches
2013-07-04 12:35             ` [PATCH v2 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-04 12:35             ` [PATCH v2 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-04 12:35             ` [PATCH v2 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-04 12:35             ` [PATCH v2 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-04 12:35             ` [PATCH v2 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-07-04 12:45               ` Rupesh Gujare
2013-07-22 17:43                 ` Rupesh Gujare
2013-07-22 17:55                   ` Greg Kroah-Hartman
2013-07-22 22:08                     ` Gujare, Rupesh
2013-07-23 12:44                     ` Rupesh Gujare [this message]
2013-07-23 12:44                     ` [PATCH v3 1/5] staging: ozwpan: Remove extra debug logs Rupesh Gujare
2013-07-23 12:45                     ` [PATCH v3 2/5] staging: ozwpan: Replace oz_trace with oz_dbg Rupesh Gujare
2013-07-23 12:45                     ` [PATCH v3 3/5] staging: ozwpan: Remove old debug macro Rupesh Gujare
2013-07-23 12:45                     ` [PATCH v3 4/5] staging: ozwpan: Convert macro to function Rupesh Gujare
2013-07-23 12:45                     ` [PATCH v3 5/5] staging: ozwpan: Rename Kbuild to Makefile Rupesh Gujare
2013-06-26 17:46     ` [PATCH] staging: ozwpan: Convert printk to dev_dbg() Jason Baron
2013-06-27  0:26       ` Joe Perches
2013-06-25 17:49   ` Rupesh Gujare
2013-06-25 17:55     ` Alan Stern
2013-06-25 17:57     ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1374583503-5642-1-git-send-email-rupesh.gujare@atmel.com \
    --to=rupesh.gujare@atmel.com \
    --cc=devel@linuxdriverproject.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=joe@perches.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®