From: Ian Campbell <Ian.Campbell@citrix.com>
To: Stefano Stabellini <stefano.stabellini@eu.citrix.com>
Cc: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>,
<xen-devel@lists.xenproject.org>, <linux-kernel@vger.kernel.org>,
<boris.ostrovsky@oracle.com>, <david.vrabel@citrix.com>,
<leosilva@linux.vnet.ibm.com>, <ashley@ashleylai.com>,
<peterhuewe@gmx.de>, <mail@srajiv.net>, <tpmdd@selhorst.net>,
<tpmdd@sirrix.com>, <dmitry.torokhov@gmail.com>,
<bhelgaas@google.com>, <plagnioj@jcrosoft.com>,
<tomi.valkeinen@ti.com>, <tpmdd-devel@lists.sourceforge.net>,
<linux-input@vger.kernel.org>, <netdev@vger.kernel.org>,
<linux-pci@vger.kernel.org>, <linux-fbdev@vger.kernel.org>
Subject: Re: [PATCH] xen/pvhvm: If xen_platform_pci=0 is set don't blow up.
Date: Wed, 4 Dec 2013 11:23:40 +0000 [thread overview]
Message-ID: <1386156220.17466.29.camel@kazak.uk.xensource.com> (raw)
In-Reply-To: <alpine.DEB.2.02.1312041116230.7093@kaball.uk.xensource.com>
On Wed, 2013-12-04 at 11:18 +0000, Stefano Stabellini wrote:
> On Wed, 4 Dec 2013, Ian Campbell wrote:
> > On Wed, 2013-12-04 at 11:05 +0000, Stefano Stabellini wrote:
> > > On Wed, 4 Dec 2013, Ian Campbell wrote:
> > > > On Wed, 2013-12-04 at 10:51 +0000, Stefano Stabellini wrote:
> > > > > On Wed, 4 Dec 2013, Ian Campbell wrote:
> > > > > > > +bool xen_has_pv_devices(void)
> > > > > > > +{
> > > > > > > + if (!xen_domain())
> > > > > > > + return false;
> > > > > > > +
> > > > > > > + if (xen_hvm_domain()) {
> > > > > > > + /* User requested no unplug, so no PV drivers. */
> > > > > > > + if (xen_emul_unplug & XEN_UNPLUG_NEVER)
> > > > > > > + return false;
> > > > > >
> > > > > > I think you need
> > > > > > if (xen_emul_unpug & XEN_UNPLUG_UNNECESSARY)
> > > > > > return true;
> > > > > > don't you?
> > > > >
> > > > > XEN_UNPLUG_UNNECESSARY was introduced to enable the platform PCI device
> > > > > even if it didn't respond properly to the unplug protocol.
> > > > > The corresponding parameter is called "unnecessary" because if you pass
> > > > > it to the kernel you mean that it is unnecessary to unplug the emulated
> > > > > devices but you can use the pv devices anyway.
> > > > >
> > > > > So no, we shouldn't check for XEN_UNPLUG_UNNECESSARY here.
> > > >
> > > > Oh, we will eventually fall through to the return true, so it does
> > > > actually work out OK.
> > > >
> > > > I'd still be in favour of handling each option explicitly, for clarity.
> > > > Which means checking for XEN_UNPLUG_UNNECESSARY.
> > >
> > > I think is wrong to check for any xen_emul_unpug options in this function.
> > > The xen_emul_unpug options should be used to set the right value of
> > > xen_platform_pci_unplug. (See my other reply.)
> >
> > Whichever one we check we should still be checking explicitly for the
> > "unnecessary" case, for clarity if nothing else.
>
> Sure, that is OK for me.
> In that case should we check for the full list of possible options?
We probably should. That probably means an extra
xen_has_pv_{disk,nic}_devices() which is the existing one plus the
specific checks?
>
> ide-disks -- unplug primary master IDE devices
> aux-ide-disks -- unplug non-primary-master IDE devices
> nics -- unplug network devices
> all -- unplug all emulated devices (NICs and IDE disks)
> unnecessary -- unplugging emulated devices is
> unnecessary even if the host did not respond to
> the unplug protocol
> never -- do not unplug even if version check succeeds
next prev parent reply other threads:[~2013-12-04 11:23 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-12-03 21:14 Konrad Rzeszutek Wilk
2013-12-04 0:03 ` [Xen-devel] " Matthew Daley
2013-12-04 9:37 ` Ian Campbell
2013-12-04 10:51 ` Stefano Stabellini
2013-12-04 10:59 ` Ian Campbell
2013-12-04 11:05 ` Stefano Stabellini
2013-12-04 11:08 ` Ian Campbell
2013-12-04 11:18 ` Stefano Stabellini
2013-12-04 11:23 ` Ian Campbell [this message]
2013-12-04 10:48 ` Stefano Stabellini
2013-12-04 13:00 ` David Vrabel
2013-12-04 13:06 ` Ian Campbell
2013-12-04 16:42 ` Dmitry Torokhov
2013-12-04 16:48 ` Konrad Rzeszutek Wilk
2013-12-04 17:08 ` Dmitry Torokhov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1386156220.17466.29.camel@kazak.uk.xensource.com \
--to=ian.campbell@citrix.com \
--cc=ashley@ashleylai.com \
--cc=bhelgaas@google.com \
--cc=boris.ostrovsky@oracle.com \
--cc=david.vrabel@citrix.com \
--cc=dmitry.torokhov@gmail.com \
--cc=konrad.wilk@oracle.com \
--cc=leosilva@linux.vnet.ibm.com \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-input@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=mail@srajiv.net \
--cc=netdev@vger.kernel.org \
--cc=peterhuewe@gmx.de \
--cc=plagnioj@jcrosoft.com \
--cc=stefano.stabellini@eu.citrix.com \
--cc=tomi.valkeinen@ti.com \
--cc=tpmdd-devel@lists.sourceforge.net \
--cc=tpmdd@selhorst.net \
--cc=tpmdd@sirrix.com \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®