mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/27] DRBD code reorganization
@ 2013-12-23 21:50 Philipp Reisner
  2013-12-23 21:50 ` [PATCH 01/27] drbd: Rename net_conf variables old_conf -> old_net_conf and new_conf -> new_net_conf Philipp Reisner
                   ` (26 more replies)
  0 siblings, 27 replies; 28+ messages in thread
From: Philipp Reisner @ 2013-12-23 21:50 UTC (permalink / raw)
  To: linux-kernel, Jens Axboe; +Cc: drbd-dev

Hi,

we are preparing DRBD for the ability to have multiple connections,
in other words the ability to mirror a single block device to multiple
peers concurrently.

This patch set is the second half of a preparation step. With part 1
it introduces a new in memory object (struct drbd_resource),
and renames the current in memory objects for clarity.

This patch set does not introduce any new functionality.


Andreas Gruenbacher (27):
  drbd: Rename net_conf variables old_conf -> old_net_conf and new_conf
    -> new_net_conf
  drbd: Iterate over all connections
  drbd: drbd_adm_prepare(): Only set adm_ctx.connection when a
    connection is requested
  drbd: Move conf_mutex from connection to resource
  drbd: Move susp, susp_nod, susp_fen from connection to resource
  drbd: Define the size of res_opts->cpu_mask in a single place
  drbd: Move cpu_mask from connection to resource
  drbd: Rename drbdd_init() -> drbd_receiver()
  drbd: Function prototype cleanups
  drbd: drbd_csum_bio(), drbd_csum_ee(): Remove unused device argument
  drbd: Replace vnr_to_mdev() with conn_peer_device()
  drbd: Pass a peer device to a number of fuctions
  drbd: Kill drbd_task_to_thread_name()
  drbd: Remove useless assertion
  drbd: Move string function prototypes from linux/drbd.h to
    drbd_string.h
  drbd: Rename w_prev_work_done -> w_complete
  drbd: Create a dedicated struct drbd_device_work
  drbd: Turn conn_flush_workqueue() into drbd_flush_workqueue()
  drbd: struct after_conn_state_chg_work: Use drbd_work instead of
    drbd_device_work
  drbd: struct drbd_peer_request: Use drbd_work instead of
    drbd_device_work
  drbd: Make w_make_resync_request() static
  drbd: Turn w_make_ov_request and make_resync_request into "normal"
    functions
  drbd: In the worker thread, process drbd_work instead of
    drbd_device_work items
  drbd: Get rid of first_peer_device() in handle_write_conflicts()
  drbd: Remove unused parameter of wire_flags_to_bio()
  drbd: Use the right peer device
  drbd: Add drbd_thread->resource and make drbd_thread->connection
    optional

 drivers/block/drbd/drbd_actlog.c   |   16 +-
 drivers/block/drbd/drbd_bitmap.c   |   16 +-
 drivers/block/drbd/drbd_int.h      |  148 ++++-----
 drivers/block/drbd/drbd_main.c     |  558 ++++++++++++++++++---------------
 drivers/block/drbd/drbd_nl.c       |  260 +++++++--------
 drivers/block/drbd/drbd_receiver.c |  608 ++++++++++++++++++++----------------
 drivers/block/drbd/drbd_req.c      |   59 ++--
 drivers/block/drbd/drbd_req.h      |    8 +-
 drivers/block/drbd/drbd_state.c    |  116 +++----
 drivers/block/drbd/drbd_strings.c  |    1 +
 drivers/block/drbd/drbd_strings.h  |    9 +
 drivers/block/drbd/drbd_worker.c   |  216 ++++++-------
 include/linux/drbd.h               |    8 +-
 include/linux/drbd_genl.h          |    2 +-
 14 files changed, 1074 insertions(+), 951 deletions(-)
 create mode 100644 drivers/block/drbd/drbd_strings.h

-- 
1.7.9.5


^ permalink raw reply	[flat|nested] 28+ messages in thread

end of thread, other threads:[~2013-12-23 22:06 UTC | newest]

Thread overview: 28+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-12-23 21:50 [PATCH 00/27] DRBD code reorganization Philipp Reisner
2013-12-23 21:50 ` [PATCH 01/27] drbd: Rename net_conf variables old_conf -> old_net_conf and new_conf -> new_net_conf Philipp Reisner
2013-12-23 21:50 ` [PATCH 02/27] drbd: Iterate over all connections Philipp Reisner
2013-12-23 21:50 ` [PATCH 03/27] drbd: drbd_adm_prepare(): Only set adm_ctx.connection when a connection is requested Philipp Reisner
2013-12-23 21:50 ` [PATCH 04/27] drbd: Move conf_mutex from connection to resource Philipp Reisner
2013-12-23 21:50 ` [PATCH 05/27] drbd: Move susp, susp_nod, susp_fen " Philipp Reisner
2013-12-23 21:50 ` [PATCH 06/27] drbd: Define the size of res_opts->cpu_mask in a single place Philipp Reisner
2013-12-23 21:50 ` [PATCH 07/27] drbd: Move cpu_mask from connection to resource Philipp Reisner
2013-12-23 21:50 ` [PATCH 08/27] drbd: Rename drbdd_init() -> drbd_receiver() Philipp Reisner
2013-12-23 21:50 ` [PATCH 09/27] drbd: Function prototype cleanups Philipp Reisner
2013-12-23 21:50 ` [PATCH 10/27] drbd: drbd_csum_bio(), drbd_csum_ee(): Remove unused device argument Philipp Reisner
2013-12-23 21:50 ` [PATCH 11/27] drbd: Replace vnr_to_mdev() with conn_peer_device() Philipp Reisner
2013-12-23 21:50 ` [PATCH 12/27] drbd: Pass a peer device to a number of fuctions Philipp Reisner
2013-12-23 21:50 ` [PATCH 13/27] drbd: Kill drbd_task_to_thread_name() Philipp Reisner
2013-12-23 21:50 ` [PATCH 14/27] drbd: Remove useless assertion Philipp Reisner
2013-12-23 21:50 ` [PATCH 15/27] drbd: Move string function prototypes from linux/drbd.h to drbd_string.h Philipp Reisner
2013-12-23 21:50 ` [PATCH 16/27] drbd: Rename w_prev_work_done -> w_complete Philipp Reisner
2013-12-23 21:50 ` [PATCH 17/27] drbd: Create a dedicated struct drbd_device_work Philipp Reisner
2013-12-23 21:50 ` [PATCH 18/27] drbd: Turn conn_flush_workqueue() into drbd_flush_workqueue() Philipp Reisner
2013-12-23 21:50 ` [PATCH 19/27] drbd: struct after_conn_state_chg_work: Use drbd_work instead of drbd_device_work Philipp Reisner
2013-12-23 21:50 ` [PATCH 20/27] drbd: struct drbd_peer_request: " Philipp Reisner
2013-12-23 21:50 ` [PATCH 21/27] drbd: Make w_make_resync_request() static Philipp Reisner
2013-12-23 21:50 ` [PATCH 22/27] drbd: Turn w_make_ov_request and make_resync_request into "normal" functions Philipp Reisner
2013-12-23 21:50 ` [PATCH 23/27] drbd: In the worker thread, process drbd_work instead of drbd_device_work items Philipp Reisner
2013-12-23 21:50 ` [PATCH 24/27] drbd: Get rid of first_peer_device() in handle_write_conflicts() Philipp Reisner
2013-12-23 21:50 ` [PATCH 25/27] drbd: Remove unused parameter of wire_flags_to_bio() Philipp Reisner
2013-12-23 21:50 ` [PATCH 26/27] drbd: Use the right peer device Philipp Reisner
2013-12-23 21:50 ` [PATCH 27/27] drbd: Add drbd_thread->resource and make drbd_thread->connection optional Philipp Reisner

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®