From: Li Zhong <zhong@linux.vnet.ibm.com>
To: Zhang Yanfei <zhangyanfei@cn.fujitsu.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
nfont@linux.vnet.ibm.com, gregkh@linuxfoundation.org,
Andrew Morton <akpm@linux-foundation.org>,
KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com>,
KOSAKI Motohiro <kosaki.motohiro@jp.fujitsu.com>,
Dave Hansen <dave.hansen@intel.com>
Subject: Re: [RFC PATCH] memory driver: make phys_index/end_phys_index reflect the start/end section number
Date: Thu, 03 Apr 2014 10:37:03 +0800 [thread overview]
Message-ID: <1396492623.2913.31.camel@ThinkPad-T5421.cn.ibm.com> (raw)
In-Reply-To: <533CBB46.4050800@cn.fujitsu.com>
On Thu, 2014-04-03 at 09:37 +0800, Zhang Yanfei wrote:
> Add ccing
>
> On 04/02/2014 04:56 PM, Li Zhong wrote:
> > I noticed the phys_index and end_phys_index under
> > /sys/devices/system/memory/memoryXXX/ have the same value, e.g.
> > (for the test machine, one memory block has 8 sections, that is
> > sections_per_block equals 8)
> >
> > # cd /sys/devices/system/memory/memory100/
> > # cat phys_index end_phys_index
> > 00000064
> > 00000064
> >
> > Seems they should reflect the start/end section number respectively, which
> > also matches what is said in Documentation/memory-hotplug.txt
>
Hi Yanfei,
Thanks for the review.
> Indeed. I've noticed this before. The value in 'end_phys_index' doesn't
> match what it really means. But, the name itself is vague, it looks like
> it is the index of some page frame. (we keep this name for compatibility?)
I guess so, Dave just reminded me that the RFC would also break
userspace..
And now my plan is:
leave the code unchanged
update the document, state the end_phys_index/phys_index are the same,
and means the memory block index
[optional] create two new files start_sec_nr, end_sec_nr if needed
Do you have any other suggestions?
Thanks, Zhong
>
> The corresponding member in struct memory_block is:
>
> struct memory_block {
> unsigned long start_section_nr;
> unsigned long end_section_nr;
> ...
>
> The two members seem to have the right name, and have the right value in kernel.
>
>
> >
> > This patch tries to modify that so the two files could show the start/end
> > section number of the memory block.
> >
> > After this change, output of the above example looks like:
> >
> > # cat phys_index end_phys_index
> > 00000320
> > 00000327
> >
> > Signed-off-by: Li Zhong <zhong@linux.vnet.ibm.com>
> > ---
> > drivers/base/memory.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/base/memory.c b/drivers/base/memory.c
> > index bece691..b10f2fa 100644
> > --- a/drivers/base/memory.c
> > +++ b/drivers/base/memory.c
> > @@ -114,7 +114,7 @@ static ssize_t show_mem_start_phys_index(struct device *dev,
> > struct memory_block *mem = to_memory_block(dev);
> > unsigned long phys_index;
> >
> > - phys_index = mem->start_section_nr / sections_per_block;
> > + phys_index = mem->start_section_nr;
> > return sprintf(buf, "%08lx\n", phys_index);
> > }
> >
> > @@ -124,7 +124,7 @@ static ssize_t show_mem_end_phys_index(struct device *dev,
> > struct memory_block *mem = to_memory_block(dev);
> > unsigned long phys_index;
> >
> > - phys_index = mem->end_section_nr / sections_per_block;
> > + phys_index = mem->end_section_nr;
> > return sprintf(buf, "%08lx\n", phys_index);
> > }
> >
> >
> >
> > --
> > To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> > the body of a message to majordomo@vger.kernel.org
> > More majordomo info at http://vger.kernel.org/majordomo-info.html
> > Please read the FAQ at http://www.tux.org/lkml/
> >
>
>
next prev parent reply other threads:[~2014-04-03 2:37 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-04-02 8:56 Li Zhong
2014-04-02 16:09 ` Dave Hansen
2014-04-03 1:50 ` Li Zhong
2014-04-03 22:41 ` KOSAKI Motohiro
2014-04-03 1:37 ` Zhang Yanfei
2014-04-03 2:37 ` Li Zhong [this message]
2014-04-03 3:06 ` Zhang Yanfei
2014-04-03 6:45 ` Li Zhong
2014-04-04 1:29 ` Yasuaki Ishimatsu
2014-04-08 8:27 ` Li Zhong
2014-04-08 16:13 ` Dave Hansen
2014-04-08 18:23 ` Nathan Fontenot
2014-04-08 19:47 ` Dave Hansen
2014-04-09 9:20 ` Li Zhong
2014-04-09 15:49 ` Dave Hansen
2014-04-09 16:16 ` Nathan Fontenot
2014-04-10 3:14 ` Li Zhong
2014-04-10 3:47 ` Zhang Yanfei
2014-04-09 16:20 ` Nathan Fontenot
2014-04-09 17:39 ` Nathan Fontenot
2014-04-10 1:03 ` Zhang Yanfei
2014-04-10 4:17 ` Li Zhong
2014-04-11 18:54 ` Nathan Fontenot
2014-04-14 8:43 ` [RFC PATCH v2] memory-hotplug: Update documentation to hide information about SECTIONS and remove end_phys_index Li Zhong
2014-04-14 9:13 ` Zhang Yanfei
2014-04-15 2:49 ` Li Zhong
2014-04-16 1:49 ` [RFC PATCH v3] " Li Zhong
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1396492623.2913.31.camel@ThinkPad-T5421.cn.ibm.com \
--to=zhong@linux.vnet.ibm.com \
--cc=akpm@linux-foundation.org \
--cc=dave.hansen@intel.com \
--cc=gregkh@linuxfoundation.org \
--cc=kamezawa.hiroyu@jp.fujitsu.com \
--cc=kosaki.motohiro@jp.fujitsu.com \
--cc=linux-kernel@vger.kernel.org \
--cc=nfont@linux.vnet.ibm.com \
--cc=zhangyanfei@cn.fujitsu.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®