From: Joe Perches <joe@perches.com>
To: Alan Stern <stern@rowland.harvard.edu>
Cc: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>,
"balbi@ti.com" <balbi@ti.com>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
LKML <linux-kernel@vger.kernel.org>,
Linux USB Mailing List <linux-usb@vger.kernel.org>,
Amit Uttamchandani <auttamchandani@logicube.com>
Subject: Re: [PATCH 5/5] usb: gadget: net2280: Use pr_* function
Date: Mon, 19 May 2014 13:29:54 -0700 [thread overview]
Message-ID: <1400531394.14238.35.camel@joe-AO725> (raw)
In-Reply-To: <Pine.LNX.4.44L0.1405191615451.1538-100000@iolanthe.rowland.org>
On Mon, 2014-05-19 at 16:17 -0400, Alan Stern wrote:
> On Mon, 19 May 2014, Ricardo Ribalda Delgado wrote:
> > I really think that setting/unsetting DEBUG and VERBOSE is not a good
> > idea, and the generic functions are there to be used.
> You could change the definitions of DEBUG and VDEBUG to make them use
> the generic functions.
> > What do you think that makes it more difficult to read? The GETDEV macro?
Maybe add ep_<level> helper macros and remove xprint
#define ep_err(ep, fmt, ...) \
dev_err(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_warn(ep, fmt, ...) \
dev_warn(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_info(ep, fmt, ...) \
dev_info(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_dbg(ep, fmt, ...) \
dev_dbg(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
#define ep_vdbg(ep, fmt, ...) \
dev_vdbg(&(ep)->dev->pdev->dev, fmt, ##__VA_ARGS__)
but even that conversion isn't straightforward.
next prev parent reply other threads:[~2014-05-19 20:29 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-05-19 19:11 [PATCH 0/5] usb: gadget: net2280: Code cleanout Ricardo Ribalda Delgado
2014-05-19 19:11 ` [PATCH 1/5] usb: gadget: net2280: Refactor queues_show Ricardo Ribalda Delgado
2014-05-19 19:11 ` [PATCH 2/5] usb: gadget: net2280: Use S_I macros Ricardo Ribalda Delgado
2014-05-19 19:30 ` Alan Stern
2014-05-19 19:35 ` Ricardo Ribalda Delgado
2014-05-19 20:03 ` Alan Stern
2014-05-19 19:11 ` [PATCH 3/5] usb: gadget: net2280: Pass checkpacth.pl test Ricardo Ribalda Delgado
2014-05-19 19:39 ` Alan Stern
2014-05-20 8:52 ` David Laight
2014-05-20 8:55 ` Ricardo Ribalda Delgado
2014-05-19 19:11 ` [PATCH 4/5] usb: gadget: net2280: Code Cleanup Ricardo Ribalda Delgado
2014-05-19 19:43 ` Alan Stern
2014-05-19 19:44 ` Ricardo Ribalda Delgado
2014-05-19 20:02 ` Alan Stern
2014-05-19 19:11 ` [PATCH 5/5] usb: gadget: net2280: Use pr_* function Ricardo Ribalda Delgado
2014-05-19 19:16 ` Joe Perches
2014-05-19 19:33 ` Ricardo Ribalda Delgado
2014-05-19 19:42 ` Joe Perches
2014-05-19 19:43 ` Ricardo Ribalda Delgado
2014-05-19 19:44 ` Alan Stern
2014-05-19 20:03 ` Ricardo Ribalda Delgado
2014-05-19 20:17 ` Alan Stern
2014-05-19 20:29 ` Joe Perches [this message]
2014-05-19 20:41 ` Ricardo Ribalda Delgado
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1400531394.14238.35.camel@joe-AO725 \
--to=joe@perches.com \
--cc=auttamchandani@logicube.com \
--cc=balbi@ti.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=ricardo.ribalda@gmail.com \
--cc=stern@rowland.harvard.edu \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®