From: navin patidar <navin.patidar@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org,
navin patidar <navin.patidar@gmail.com>
Subject: [PATCH 02/16] staging: rtl8188eu: Remove function rtw_set_channel_plan()
Date: Sun, 13 Jul 2014 19:59:24 +0530 [thread overview]
Message-ID: <1405261778-7653-2-git-send-email-navin.patidar@gmail.com> (raw)
In-Reply-To: <1405261778-7653-1-git-send-email-navin.patidar@gmail.com>
Signed-off-by: navin patidar <navin.patidar@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 15 +--------------
drivers/staging/rtl8188eu/include/rtw_ioctl_set.h | 1 -
2 files changed, 1 insertion(+), 15 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c b/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
index 39932cb..5eb21cd 100644
--- a/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
+++ b/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
@@ -1092,19 +1092,6 @@ int rtw_set_scan_mode(struct adapter *adapter, enum rt_scan_type scan_mode)
}
/*
-* rtw_set_channel_plan -
-* @adapter: pointer to struct adapter structure
-* @channel_plan:
-*
-* Return _SUCCESS or _FAIL
-*/
-int rtw_set_channel_plan(struct adapter *adapter, u8 channel_plan)
-{
- /* handle by cmd_thread to sync with scan operation */
- return rtw_set_chplan_cmd(adapter, channel_plan, 1);
-}
-
-/*
* rtw_set_country -
* @adapter: pointer to struct adapter structure
* @country_code: string of country code
@@ -1130,5 +1117,5 @@ int rtw_set_country(struct adapter *adapter, const char *country_code)
else
DBG_88E("%s unknown country_code:%s\n", __func__, country_code);
- return rtw_set_channel_plan(adapter, channel_plan);
+ return rtw_set_chplan_cmd(adapter, channel_plan, 1);
}
diff --git a/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h b/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
index 005ec17..7335147 100644
--- a/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
+++ b/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
@@ -43,7 +43,6 @@ u8 rtw_set_802_11_remove_key(struct adapter *adapt,
u8 rtw_validate_ssid(struct ndis_802_11_ssid *ssid);
u16 rtw_get_cur_max_rate(struct adapter *adapter);
int rtw_set_scan_mode(struct adapter *adapter, enum rt_scan_type scan_mode);
-int rtw_set_channel_plan(struct adapter *adapter, u8 channel_plan);
int rtw_set_country(struct adapter *adapter, const char *country_code);
#endif
--
1.7.10.4
next prev parent reply other threads:[~2014-07-13 14:30 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-13 14:29 [PATCH 01/16] staging: rtl8188eu: Remove unused function rtw_use_tkipkey_handler() navin patidar
2014-07-13 14:29 ` navin patidar [this message]
2014-07-13 14:29 ` [PATCH 03/16] staging: rtl8188eu: Remove unused function rtw_set_scan_mode() navin patidar
2014-07-13 14:29 ` [PATCH 04/16] staging: rtl8188eu: Remove unused function rtw_validate_ssid() navin patidar
2014-07-13 14:29 ` [PATCH 05/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_add_key() navin patidar
2014-07-13 14:29 ` [PATCH 06/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_remove_key() navin patidar
2014-07-13 14:29 ` [PATCH 07/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_remove_wep() navin patidar
2014-07-13 14:29 ` [PATCH 08/16] staging: rtl8188eu: Remove unused function _rtw_IOL_append_WW_cmd() navin patidar
2014-07-13 14:29 ` [PATCH 09/16] staging: rtl8188eu: Remove unused function rtw_get_timestampe_from_ie() navin patidar
2014-07-13 14:29 ` [PATCH 10/16] staging: rtl8188eu: Rename _rtw_free_network_queue() to rtw_free_network_queue() navin patidar
2014-07-13 14:29 ` [PATCH 11/16] staging: rtl8188eu: Rename _rtw_find_network() to rtw_find_network() navin patidar
2014-07-13 14:29 ` [PATCH 12/16] staging: rtl8188eu: Make _rtw_free_network() static navin patidar
2014-07-13 14:29 ` [PATCH 13/16] staging: rtl8188eu: Remove unused function _rtw_dequeue_network() navin patidar
2014-07-13 14:29 ` [PATCH 14/16] staging: rtl8188eu: Remove unused function _rtw_enqueue_network() navin patidar
2014-07-13 14:29 ` [PATCH 15/16] staging: rtl8188eu: Rename _rtw_free_mlme_priv() to rtw_free_mlme_priv() navin patidar
2014-07-13 14:29 ` [PATCH 16/16] staging: rtl8188eu: Rename _rtw_init_mlme_priv() to rtw_init_mlme_priv() navin patidar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1405261778-7653-2-git-send-email-navin.patidar@gmail.com \
--to=navin.patidar@gmail.com \
--cc=Larry.Finger@lwfinger.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®