From: navin patidar <navin.patidar@gmail.com>
To: gregkh@linuxfoundation.org
Cc: Larry.Finger@lwfinger.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org,
navin patidar <navin.patidar@gmail.com>
Subject: [PATCH 07/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_remove_wep()
Date: Sun, 13 Jul 2014 19:59:29 +0530 [thread overview]
Message-ID: <1405261778-7653-7-git-send-email-navin.patidar@gmail.com> (raw)
In-Reply-To: <1405261778-7653-1-git-send-email-navin.patidar@gmail.com>
Signed-off-by: navin patidar <navin.patidar@gmail.com>
---
drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 25 ---------------------
drivers/staging/rtl8188eu/include/rtw_ioctl_set.h | 1 -
2 files changed, 26 deletions(-)
diff --git a/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c b/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
index f4116d1..fc280ce5 100644
--- a/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
+++ b/drivers/staging/rtl8188eu/core/rtw_ioctl_set.c
@@ -566,31 +566,6 @@ exit:
return ret;
}
-u8 rtw_set_802_11_remove_wep(struct adapter *padapter, u32 keyindex)
-{
- u8 ret = _SUCCESS;
-
- if (keyindex >= 0x80000000 || padapter == NULL) {
- ret = false;
- goto exit;
- } else {
- int res;
- struct security_priv *psecuritypriv = &(padapter->securitypriv);
- if (keyindex < 4) {
- memset(&psecuritypriv->dot11DefKey[keyindex], 0, 16);
- res = rtw_set_key(padapter, psecuritypriv, keyindex, 0);
- psecuritypriv->dot11DefKeylen[keyindex] = 0;
- if (res == _FAIL)
- ret = _FAIL;
- } else {
- ret = _FAIL;
- }
- }
-exit:
-
- return ret;
-}
-
/*
* rtw_get_cur_max_rate -
* @adapter: pointer to struct adapter structure
diff --git a/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h b/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
index a325326..fa9d655 100644
--- a/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
+++ b/drivers/staging/rtl8188eu/include/rtw_ioctl_set.h
@@ -35,7 +35,6 @@ u8 rtw_set_802_11_bssid_list_scan(struct adapter *adapter,
int ssid_max_num);
u8 rtw_set_802_11_infrastructure_mode(struct adapter *adapter,
enum ndis_802_11_network_infra type);
-u8 rtw_set_802_11_remove_wep(struct adapter *adapter, u32 keyindex);
u8 rtw_set_802_11_ssid(struct adapter *adapt, struct ndis_802_11_ssid *ssid);
u16 rtw_get_cur_max_rate(struct adapter *adapter);
int rtw_set_country(struct adapter *adapter, const char *country_code);
--
1.7.10.4
next prev parent reply other threads:[~2014-07-13 14:31 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-07-13 14:29 [PATCH 01/16] staging: rtl8188eu: Remove unused function rtw_use_tkipkey_handler() navin patidar
2014-07-13 14:29 ` [PATCH 02/16] staging: rtl8188eu: Remove function rtw_set_channel_plan() navin patidar
2014-07-13 14:29 ` [PATCH 03/16] staging: rtl8188eu: Remove unused function rtw_set_scan_mode() navin patidar
2014-07-13 14:29 ` [PATCH 04/16] staging: rtl8188eu: Remove unused function rtw_validate_ssid() navin patidar
2014-07-13 14:29 ` [PATCH 05/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_add_key() navin patidar
2014-07-13 14:29 ` [PATCH 06/16] staging: rtl8188eu: Remove unused function rtw_set_802_11_remove_key() navin patidar
2014-07-13 14:29 ` navin patidar [this message]
2014-07-13 14:29 ` [PATCH 08/16] staging: rtl8188eu: Remove unused function _rtw_IOL_append_WW_cmd() navin patidar
2014-07-13 14:29 ` [PATCH 09/16] staging: rtl8188eu: Remove unused function rtw_get_timestampe_from_ie() navin patidar
2014-07-13 14:29 ` [PATCH 10/16] staging: rtl8188eu: Rename _rtw_free_network_queue() to rtw_free_network_queue() navin patidar
2014-07-13 14:29 ` [PATCH 11/16] staging: rtl8188eu: Rename _rtw_find_network() to rtw_find_network() navin patidar
2014-07-13 14:29 ` [PATCH 12/16] staging: rtl8188eu: Make _rtw_free_network() static navin patidar
2014-07-13 14:29 ` [PATCH 13/16] staging: rtl8188eu: Remove unused function _rtw_dequeue_network() navin patidar
2014-07-13 14:29 ` [PATCH 14/16] staging: rtl8188eu: Remove unused function _rtw_enqueue_network() navin patidar
2014-07-13 14:29 ` [PATCH 15/16] staging: rtl8188eu: Rename _rtw_free_mlme_priv() to rtw_free_mlme_priv() navin patidar
2014-07-13 14:29 ` [PATCH 16/16] staging: rtl8188eu: Rename _rtw_init_mlme_priv() to rtw_init_mlme_priv() navin patidar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1405261778-7653-7-git-send-email-navin.patidar@gmail.com \
--to=navin.patidar@gmail.com \
--cc=Larry.Finger@lwfinger.net \
--cc=devel@driverdev.osuosl.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®