mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jamie Lentin <jm@lentin.co.uk>
To: Jiri Kosina <jkosina@suse.cz>, Antonio Ospite <ao2@ao2.it>,
	Hans de Goede <hdegoede@redhat.com>
Cc: linux-input@vger.kernel.org, linux-kernel@vger.kernel.org,
	Jamie Lentin <jm@lentin.co.uk>
Subject: [PATCH v5 0/4] HID: lenovo: Add support for Lenovo Compact Keyboard
Date: Wed, 23 Jul 2014 23:30:44 +0100	[thread overview]
Message-ID: <1406154648-14000-1-git-send-email-jm@lentin.co.uk> (raw)

This patchset follows on from my previous attempts to add support for
these keyboards from Lenovo.

Antonio, I've used cptkbd_data and left data_pointer for now. It'd be
an easy patch to change data_pointer to tpkbd_data, but is drifting
away from what this patchset is supposed to do. Could send that
afterwards though.

Changes since v4: https://lkml.org/lkml/2014/7/13/14
* Remember to add prefixes to subjects (whooops) [Antonio Ospite]
* Don't allocate drvdata for non-interesting half of USB
  keyboard [Antonio Ospite]
* Some pointer/trackpoint comment clarifications [Antonio Ospite]
* Change tpcsc -> cptkbd_data [Antonio Ospite]
* Only bother doing sysfs_remove_group if there's a data_pointer
  [Antonio Ospite]

Changes since v3: https://lkml.org/lkml/2014/6/15/159
* Break up first patch [Antonio Ospite]
* Rename ABI docs too [Jiri Kosina]
* Spelling and Grammar, style fixes [Antonio Ospite]
* Driver should just be called 'lenovo' [Antonio Ospite]
* Remove useless id from probe functions [Antonio Ospite]
* Use KEY_SCALE to match Thinkpad ??40 models [Hans de Goede]
* Add ABI documentation for fn_lock setting [Jiri Kosina]
* Use a bool for fn_lock instead of uint [Antonio Ospite]
* hid_output_raw_report has been replaced with hid_hw_raw_request [Antonio Ospite]

Changes since v2: https://lkml.org/lkml/2014/6/10/730
* Rename hid-lenovo-tpkbd to hid-lenovo, to make it obvious this is
  for any Lenovo-manufactured device [Antonio Ospite, Jiri Kosina]
* Style fixes: function calls in conditions, combine checks for 
  both USB & BT keyboards [Antonio Ospite]

Changes since v1: https://lkml.org/lkml/2014/3/25/535
* Merge driver into hid-lenovo-tpkbd.c instead of creating our own
  driver for the hardware [Jiri Kosina]
* Remove key mappings which are now supported by standard
* Use KEY_FILE for Fn-F12 (opens My Computer on Windows)
* Support the USB variant as well as Bluetooth
* Expose the Fn Lock setting as a sysfs attribute instead of trying to
  build a mechanism to toggle into the kernel

Applies against v3.16-rc4, tested with Bluetooth and USB variants of the
Compact Keyboard with Trackpoint.

Cheers,

Jamie Lentin (4):
  HID: lenovo: Rename hid-lenovo-tpkbd to hid-lenovo
  HID: lenovo: Prepare support for adding other devices
  HID: lenovo: Style fixes
  HID: lenovo: Add support for Compact (BT|USB) keyboard

 ...er-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} |  12 +
 drivers/hid/Kconfig                                |  16 +-
 drivers/hid/Makefile                               |   2 +-
 drivers/hid/hid-core.c                             |   4 +-
 drivers/hid/hid-ids.h                              |   2 +
 drivers/hid/hid-lenovo-tpkbd.c                     | 462 --------------
 drivers/hid/hid-lenovo.c                           | 708 +++++++++++++++++++++
 include/linux/hid.h                                |   1 +
 8 files changed, 736 insertions(+), 471 deletions(-)
 rename Documentation/ABI/testing/{sysfs-driver-hid-lenovo-tpkbd => sysfs-driver-hid-lenovo} (75%)
 delete mode 100644 drivers/hid/hid-lenovo-tpkbd.c
 create mode 100644 drivers/hid/hid-lenovo.c

-- 
2.0.0


             reply	other threads:[~2014-07-23 22:31 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-07-23 22:30 Jamie Lentin [this message]
2014-07-23 22:30 ` [PATCH v5 1/4] HID: lenovo: Rename hid-lenovo-tpkbd to hid-lenovo Jamie Lentin
2014-07-25 12:56   ` Antonio Ospite
2014-07-23 22:30 ` [PATCH v5 2/4] HID: lenovo: Prepare support for adding other devices Jamie Lentin
2014-07-25 12:58   ` Antonio Ospite
2014-07-23 22:30 ` [PATCH v5 3/4] HID: lenovo: Style fixes Jamie Lentin
2014-07-23 23:37   ` Dmitry Torokhov
2014-07-25 13:33   ` Antonio Ospite
2014-07-26 14:42   ` [PATCH v6 3/4] HID: lenovo: Don't call function in condition, show error codes Jamie Lentin
2014-07-28 17:46     ` Dmitry Torokhov
2014-07-23 22:30 ` [PATCH v5 4/4] HID: lenovo: Add support for Compact (BT|USB) keyboard Jamie Lentin
2014-07-25 13:39   ` Antonio Ospite
2014-07-25 14:05 ` [PATCH v5 0/4] HID: lenovo: Add support for Lenovo Compact Keyboard Antonio Ospite
2014-07-26 10:09   ` Jamie Lentin
2014-07-29  9:25   ` Jiri Kosina

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1406154648-14000-1-git-send-email-jm@lentin.co.uk \
    --to=jm@lentin.co.uk \
    --cc=ao2@ao2.it \
    --cc=hdegoede@redhat.com \
    --cc=jkosina@suse.cz \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®