From: Chun-Hao Lin <hau@realtek.com>
To: <netdev@vger.kernel.org>
Cc: <nic_swsd@realtek.com>, <linux-kernel@vger.kernel.org>,
Chun-Hao Lin <hau@realtek.com>
Subject: [PATCH v2 net-next 03/10] r8169:add disable/enable RTL8411B pll function
Date: Wed, 1 Oct 2014 23:17:14 +0800 [thread overview]
Message-ID: <1412176641-24393-3-git-send-email-hau@realtek.com> (raw)
In-Reply-To: <1412176641-24393-1-git-send-email-hau@realtek.com>
RTL8411B can support disable/enable pll function.
Signed-off-by: Chun-Hao Lin <hau@realtek.com>
---
drivers/net/ethernet/realtek/r8169.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/net/ethernet/realtek/r8169.c b/drivers/net/ethernet/realtek/r8169.c
index 93f8d3f..86c55a0 100644
--- a/drivers/net/ethernet/realtek/r8169.c
+++ b/drivers/net/ethernet/realtek/r8169.c
@@ -4367,6 +4367,7 @@ static void r8168_pll_power_down(struct rtl8169_private *tp)
case RTL_GIGA_MAC_VER_31:
case RTL_GIGA_MAC_VER_32:
case RTL_GIGA_MAC_VER_33:
+ case RTL_GIGA_MAC_VER_44:
case RTL_GIGA_MAC_VER_45:
case RTL_GIGA_MAC_VER_46:
RTL_W8(PMCH, RTL_R8(PMCH) & ~0x80);
@@ -4394,6 +4395,7 @@ static void r8168_pll_power_up(struct rtl8169_private *tp)
case RTL_GIGA_MAC_VER_33:
RTL_W8(PMCH, RTL_R8(PMCH) | 0x80);
break;
+ case RTL_GIGA_MAC_VER_44:
case RTL_GIGA_MAC_VER_45:
case RTL_GIGA_MAC_VER_46:
RTL_W8(PMCH, RTL_R8(PMCH) | 0xc0);
--
1.8.3.2
next prev parent reply other threads:[~2014-10-01 15:21 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-10-01 15:17 [PATCH v2 net-next 01/10] r8169:change uppercase number to lowercase nubmer Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 02/10] r8169:add disable/enable RTL8168G pll function Chun-Hao Lin
2014-10-01 15:17 ` Chun-Hao Lin [this message]
2014-10-01 15:17 ` [PATCH v2 net-next 04/10] r8169:add support more chips to get mac address from backup mac address register Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 05/10] r8169:add more chips to support magic packet v2 Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 06/10] r8169:for function "rtl_w1w0_phy" change its name and behavior Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 07/10] r8169:change the name of function"rtl_w1w0_eri" Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 08/10] r8169:change the name of function "r8168dp_check_dash" to "r8168_check_dash" Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 09/10] r8169:modify the behavior of function "rtl8168_oob_notify" Chun-Hao Lin
2014-10-01 15:17 ` [PATCH v2 net-next 10/10] r8169:call "rtl8168_driver_start" "rtl8168_driver_stop" only when hardware dash function is enabled Chun-Hao Lin
2014-10-01 17:17 ` [PATCH v2 net-next 01/10] r8169:change uppercase number to lowercase nubmer Sergei Shtylyov
2014-10-01 19:34 ` David Miller
2014-10-02 5:35 ` [PATCH v2 net-next 01/10] r8169:change uppercase numbertolowercase nubmer Hau
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1412176641-24393-3-git-send-email-hau@realtek.com \
--to=hau@realtek.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=nic_swsd@realtek.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®