mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Konrad Zapalowicz <bergo.torino@gmail.com>
To: cascardo@linux.vnet.ibm.com
Cc: gregkh@linuxfoundation.org, jslaby@suse.cz,
	linux-serial@vger.kernel.org, linux-kernel@vger.kernel.org,
	Konrad Zapalowicz <bergo.torino@gmail.com>
Subject: [PATCH 4/5] serial: jsm: Replace magic value with the proper define
Date: Sun,  9 Nov 2014 02:22:19 +0100	[thread overview]
Message-ID: <1415496140-14997-5-git-send-email-bergo.torino@gmail.com> (raw)
In-Reply-To: <1415496140-14997-4-git-send-email-bergo.torino@gmail.com>

The changed function flushes the tx UART and the '4' corresponds to the
UART_FCR_CLEAR_XMIT value. This commit replaces the magic number with
this define.

Signed-off-by: Konrad Zapalowicz <bergo.torino@gmail.com>
---
 drivers/tty/serial/jsm/jsm_neo.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/tty/serial/jsm/jsm_neo.c b/drivers/tty/serial/jsm/jsm_neo.c
index 5de6dffb..7291c21 100644
--- a/drivers/tty/serial/jsm/jsm_neo.c
+++ b/drivers/tty/serial/jsm/jsm_neo.c
@@ -644,7 +644,7 @@ static void neo_flush_uart_write(struct jsm_channel *ch)
 
 		/* Check to see if the UART feels it completely flushed the FIFO. */
 		tmp = readb(&ch->ch_neo_uart->isr_fcr);
-		if (tmp & 4) {
+		if (tmp & UART_FCR_CLEAR_XMIT) {
 			jsm_dbg(IOCTL, &ch->ch_bd->pci_dev,
 				"Still flushing TX UART... i: %d\n", i);
 			udelay(10);
-- 
1.9.1


  reply	other threads:[~2014-11-09  1:23 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-11-09  1:22 [PATCH 0/5] serial: jsm: Provide better code quality Konrad Zapalowicz
2014-11-09  1:22 ` [PATCH 1/5] serial: jsm: Remove unnecessary parameter from clear_break() Konrad Zapalowicz
2014-11-09  1:22   ` [PATCH 2/5] serial: jsm: Remove unnecessary if statement Konrad Zapalowicz
2014-11-09  1:22     ` [PATCH 3/5] serial: jsm: Fix the alignment of the switch satement Konrad Zapalowicz
2014-11-09  1:22       ` Konrad Zapalowicz [this message]
2014-11-09  1:22         ` [PATCH 5/5] serial: jsm: Fix unnecessary space before function ptr arguments Konrad Zapalowicz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1415496140-14997-5-git-send-email-bergo.torino@gmail.com \
    --to=bergo.torino@gmail.com \
    --cc=cascardo@linux.vnet.ibm.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=jslaby@suse.cz \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-serial@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®