From: "K. Y. Srinivasan" <kys@microsoft.com>
To: gregkh@linuxfoundation.org, linux-kernel@vger.kernel.org,
devel@linuxdriverproject.org, olaf@aepfle.de, apw@canonical.com,
vkuznets@redhat.com
Cc: "K. Y. Srinivasan" <kys@microsoft.com>
Subject: [PATCH RESEND 02/15] Drivers: hv: vmbus: rename channel work queues
Date: Fri, 27 Feb 2015 11:25:52 -0800 [thread overview]
Message-ID: <1425065165-21823-2-git-send-email-kys@microsoft.com> (raw)
In-Reply-To: <1425065165-21823-1-git-send-email-kys@microsoft.com>
From: Vitaly Kuznetsov <vkuznets@redhat.com>
All channel work queues are named 'hv_vmbus_ctl', this makes them
indistinguishable in ps output and makes it hard to link to the corresponding
vmbus device. Rename them to hv_vmbus_ctl/N and make vmbus device names match,
e.g. now vmbus_1 device is served by hv_vmbus_ctl/1 work queue.
Signed-off-by: Vitaly Kuznetsov <vkuznets@redhat.com>
Signed-off-by: K. Y. Srinivasan <kys@microsoft.com>
---
drivers/hv/channel_mgmt.c | 5 ++++-
drivers/hv/vmbus_drv.c | 6 ++----
include/linux/hyperv.h | 3 +++
3 files changed, 9 insertions(+), 5 deletions(-)
diff --git a/drivers/hv/channel_mgmt.c b/drivers/hv/channel_mgmt.c
index 3736f71..ba4b25f 100644
--- a/drivers/hv/channel_mgmt.c
+++ b/drivers/hv/channel_mgmt.c
@@ -139,19 +139,22 @@ EXPORT_SYMBOL_GPL(vmbus_prep_negotiate_resp);
*/
static struct vmbus_channel *alloc_channel(void)
{
+ static atomic_t chan_num = ATOMIC_INIT(0);
struct vmbus_channel *channel;
channel = kzalloc(sizeof(*channel), GFP_ATOMIC);
if (!channel)
return NULL;
+ channel->id = atomic_inc_return(&chan_num);
spin_lock_init(&channel->inbound_lock);
spin_lock_init(&channel->lock);
INIT_LIST_HEAD(&channel->sc_list);
INIT_LIST_HEAD(&channel->percpu_list);
- channel->controlwq = create_workqueue("hv_vmbus_ctl");
+ channel->controlwq = alloc_workqueue("hv_vmbus_ctl/%d", WQ_MEM_RECLAIM,
+ 1, channel->id);
if (!channel->controlwq) {
kfree(channel);
return NULL;
diff --git a/drivers/hv/vmbus_drv.c b/drivers/hv/vmbus_drv.c
index 90c3400..4e3760c 100644
--- a/drivers/hv/vmbus_drv.c
+++ b/drivers/hv/vmbus_drv.c
@@ -875,10 +875,8 @@ int vmbus_device_register(struct hv_device *child_device_obj)
{
int ret = 0;
- static atomic_t device_num = ATOMIC_INIT(0);
-
- dev_set_name(&child_device_obj->device, "vmbus_0_%d",
- atomic_inc_return(&device_num));
+ dev_set_name(&child_device_obj->device, "vmbus_%d",
+ child_device_obj->channel->id);
child_device_obj->device.bus = &hv_bus;
child_device_obj->device.parent = &hv_acpi_dev->dev;
diff --git a/include/linux/hyperv.h b/include/linux/hyperv.h
index 5a2ba67..26a32b7 100644
--- a/include/linux/hyperv.h
+++ b/include/linux/hyperv.h
@@ -646,6 +646,9 @@ struct hv_input_signal_event_buffer {
};
struct vmbus_channel {
+ /* Unique channel id */
+ int id;
+
struct list_head listentry;
struct hv_device *device_obj;
--
1.7.4.1
next prev parent reply other threads:[~2015-02-27 18:10 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-02-27 19:25 [PATCH RESEND 00/15] Drivers: hv: vmbus: Miscellaneous fixes/enhancements K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 01/15] Drivers: hv: vmbus: prevent cpu offlining on newer hypervisors K. Y. Srinivasan
2015-02-27 19:25 ` K. Y. Srinivasan [this message]
2015-02-27 19:25 ` [PATCH RESEND 03/15] Drivers: hv: vmbus: avoid double kfree for device_obj K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 04/15] Drivers: hv: vmbus: teardown hv_vmbus_con workqueue and vmbus_connection pages on shutdown K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 05/15] drivers: hv: vmbus: Teardown synthetic interrupt controllers on module unload K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 06/15] clockevents: export clockevents_unbind_device instead of clockevents_unbind K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 07/15] Drivers: hv: vmbus: Teardown clockevent devices on module unload K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 08/15] hv: hv_util: move vmbus_open() to a later place K. Y. Srinivasan
2015-02-27 19:25 ` [PATCH RESEND 09/15] hv: vmbus_post_msg: retry the hypercall on some transient errors K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 10/15] hv: vmbus_open(): reset the channel state on ENOMEM K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 11/15] hv: channel: match var type to return type of wait_for_completion K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 12/15] hv: channel_mgmt: " K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 13/15] hv: hv_balloon: " K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 14/15] Drivers: hv: vmbus: Fix a bug in the error path in vmbus_open() K. Y. Srinivasan
2015-02-27 19:26 ` [PATCH RESEND 15/15] Drivers: hv: vmbus: Add support for the NetworkDirect GUID K. Y. Srinivasan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1425065165-21823-2-git-send-email-kys@microsoft.com \
--to=kys@microsoft.com \
--cc=apw@canonical.com \
--cc=devel@linuxdriverproject.org \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=olaf@aepfle.de \
--cc=vkuznets@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®