From: Sjoerd Simons <sjoerd.simons@collabora.co.uk>
To: Heiko Stuebner <heiko@sntech.de>
Cc: linux-rockchip@lists.infradead.org,
Jaroslav Kysela <perex@perex.cz>,
devicetree@vger.kernel.org, alsa-devel@alsa-project.org,
Mark Brown <broonie@kernel.org>,
linux-kernel@vger.kernel.org, Kumar Gala <galak@codeaurora.org>,
Ian Campbell <ijc+devicetree@hellion.org.uk>,
Takashi Iwai <tiwai@suse.com>,
Liam Girdwood <lgirdwood@gmail.com>,
Pawel Moll <pawel.moll@arm.com>, Rob Herring <robh+dt@kernel.org>,
Mark Rutland <mark.rutland@arm.com>,
Russell King <linux@arm.linux.org.uk>,
linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v3 2/4] ASoC: rockchip: Add rockchip SPDIF transceiver driver
Date: Wed, 19 Aug 2015 08:56:48 +0200 [thread overview]
Message-ID: <1439967408.4135.84.camel@collabora.co.uk> (raw)
In-Reply-To: <1463451.tH10lfH9Hm@phil>
Hey Heiko,
Thanks for the comments, i'm hoping to address them and Marks comments
in a next patch series next week.
On Tue, 2015-08-18 at 20:25 +0200, Heiko Stuebner wrote:
> > +
> > + spdif->hclk = devm_clk_get(&pdev->dev, "spdif_hclk");
> I guess this could be named just "hclk" - as it is the identifier
> local to the spdif-ip. (Of course in the binding too)
I'm entirely happy to change that, just wanted to note that the reason
i used spdif_hclk and spidf_clk is for consistency with the rockchip
-i2s binding which uses i2s_hclk ans i2s_mclk.
However i guess we could update the i2s binding at some poit as well to
follow similar names (with fallbacks to the old one). In general a lot
of the comments yourself and Mark have given actually apply to the
rockchip-i2s code as well so there is some cleanup to do there :)
--
Sjoerd Simons
Collabora Ltd.
next prev parent reply other threads:[~2015-08-19 6:56 UTC|newest]
Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-08-07 11:44 [PATCH v3 0/4] Add SPDIF support for rockchip Sjoerd Simons
2015-08-07 11:44 ` [PATCH v3 1/4] ASoC: dt-bindings: add rockchip tranceiver bindings Sjoerd Simons
2015-08-07 13:05 ` Mark Brown
2015-08-07 11:44 ` [PATCH v3 2/4] ASoC: rockchip: Add rockchip SPDIF transceiver driver Sjoerd Simons
2015-08-07 13:03 ` Mark Brown
2015-08-18 18:25 ` Heiko Stuebner
2015-08-19 6:56 ` Sjoerd Simons [this message]
2015-08-19 7:28 ` Heiko Stuebner
2015-08-07 11:44 ` [PATCH v3 3/4] ARM: dts: rockchip: Add SPDIF transceiver for RK3188 Sjoerd Simons
2015-08-07 11:44 ` [PATCH v3 4/4] ARM: dts: rockchip: Add SPDIF optical out on Radxa Rock Sjoerd Simons
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1439967408.4135.84.camel@collabora.co.uk \
--to=sjoerd.simons@collabora.co.uk \
--cc=alsa-devel@alsa-project.org \
--cc=broonie@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=galak@codeaurora.org \
--cc=heiko@sntech.de \
--cc=ijc+devicetree@hellion.org.uk \
--cc=lgirdwood@gmail.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=linux@arm.linux.org.uk \
--cc=mark.rutland@arm.com \
--cc=pawel.moll@arm.com \
--cc=perex@perex.cz \
--cc=robh+dt@kernel.org \
--cc=tiwai@suse.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome