From: Joe Perches <joe@perches.com>
To: Mark Brown <broonie@kernel.org>
Cc: Paul Kocialkowski <contact@paulk.fr>,
Liam Girdwood <lgirdwood@gmail.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range
Date: Fri, 22 Jan 2016 13:42:33 -0800 [thread overview]
Message-ID: <1453498953.13870.41.camel@perches.com> (raw)
In-Reply-To: <20160122213115.GF6588@sirena.org.uk>
On Fri, 2016-01-22 at 21:31 +0000, Mark Brown wrote:
> On Fri, Jan 22, 2016 at 11:15:28AM -0800, Joe Perches wrote:
> > On Thu, 2016-01-21 at 20:24 +0000, Mark Brown wrote:
>
> > > - bool continuous_voltage_range;
> > > + unsigned int continuous_voltage_range:1;
>
> > Is this really valuable?
>
> > There are already padding bytes that are unused
> > and adding a couple more bools would be space
> > cost-free and more readable.
>
> > I believe that read/write of bytes is also more
> > efficient on some architectures than bit field
> > read/modify/write uses.
>
> It adds up when you get more flags and these are not in the least bit
> performance sensitive.
Sure, but intelligibility is useful too.
Do you expect to have more than 4 of these flags?
next prev parent reply other threads:[~2016-01-22 21:42 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-01-21 20:24 Mark Brown
2016-01-21 20:24 ` [PATCH 2/2] regulator: core: Provide per-regulator runtime PM support Mark Brown
2016-01-21 21:49 ` kbuild test robot
2016-01-29 12:02 ` Paul Kocialkowski
2016-02-09 20:51 ` Paul Kocialkowski
2016-02-12 19:24 ` Paul Kocialkowski
2016-02-26 2:13 ` Mark Brown
2016-01-22 19:15 ` [PATCH 1/2] regulator: core: Use a bitfield for continuous_voltage_range Joe Perches
2016-01-22 21:31 ` Mark Brown
2016-01-22 21:42 ` Joe Perches [this message]
2016-01-23 15:16 ` Mark Brown
2016-04-21 16:11 ` Applied "regulator: core: Use a bitfield for continuous_voltage_range" to the regulator tree Mark Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1453498953.13870.41.camel@perches.com \
--to=joe@perches.com \
--cc=broonie@kernel.org \
--cc=contact@paulk.fr \
--cc=lgirdwood@gmail.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome