mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Alexey Brodkin <Alexey.Brodkin@synopsys.com>
To: dri-devel@lists.freedesktop.org
Cc: linux-kernel@vger.kernel.org,
	Alexey Brodkin <Alexey.Brodkin@synopsys.com>,
	Daniel Vetter <daniel@ffwll.ch>, David Airlie <airlied@linux.ie>,
	Boris Brezillon <boris.brezillon@free-electrons.com>,
	Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
	linux-renesas-soc@vger.kernel.org,
	David Herrmann <dh.herrmann@gmail.com>
Subject: [PATCH 0/3 v4] drm: Introduce drm_connector_register_all() helper
Date: Tue, 29 Mar 2016 13:02:11 +0300	[thread overview]
Message-ID: <1459245734-2392-1-git-send-email-abrodkin@synopsys.com> (raw)

As a pair to already existing drm_connector_unplug_all()
(which we'll rename in this series to drm_connector_unregister_all())
we're adding generic implementation of what is already done in some drivers
for registering all connectors.

After implementation of that new helper we're updating 2 drivers
that used to use it's own implementation:
 [1] atmel_hlcdc
 [2] rcar_du

Other drivers still use load() callback and so should be first modified so
their load() gets called from their probe() explicitly.

Build- and run-tested on yet to be upstreamed ARC PGU (part of AXS10x board).

Changes v3 -> v4:
 * Based on current drm-intel/topic/drm-misc
   It's now on commit 6c87e5c3ec6db052f3744804a517b6fb003906e1
   And since thet new base already has
   "drm: Rename drm_connector_unplug_all() to drm_connector_unregister_all()"
   this series now only includes 3 subsequent patches.

 * In drm_connector_register_all() fail path which calls unregister_all()
   is moved outside of loop&locked section (as suggested by Daniel)

Changes v2 -> v3:
 * Added acks for 1, 3 and 4 patches
 * Updated kerneldoc descriptins of both register_ and unregister_all()
 * Updated commit messages (mostly spellos and grammar issues)

Changes v1 -> v2:
 * Rename drm_connector_unplug_all() to drm_connector_unregister_all()
 * Use drm_for_each_connector() instead of list_for_each_entry()
 * Updated kerneldoc for drm_dev_register()

Alexey Brodkin (3):
  drm: Introduce drm_connector_register_all() helper
  drm: atmel_hldc: Use generic drm_connector_register_all() helper
  drm: rcar-du: Use generic drm_connector_register_all() helper

Cc: Daniel Vetter <daniel@ffwll.ch>
Cc: David Airlie <airlied@linux.ie>
Cc: Boris Brezillon <boris.brezillon@free-electrons.com>
Cc: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: linux-renesas-soc@vger.kernel.org
Cc: David Herrmann <dh.herrmann@gmail.com>

 drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.c | 39 ++--------------------------
 drivers/gpu/drm/drm_crtc.c                   | 39 ++++++++++++++++++++++++++++
 drivers/gpu/drm/drm_drv.c                    |  6 ++++-
 drivers/gpu/drm/rcar-du/rcar_du_drv.c        |  9 +------
 include/drm/drm_crtc.h                       |  3 ++-
 5 files changed, 49 insertions(+), 47 deletions(-)

-- 
2.5.0

             reply	other threads:[~2016-03-29 10:02 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-29 10:02 Alexey Brodkin [this message]
2016-03-29 10:02 ` [PATCH 1/3 " Alexey Brodkin
2016-03-29 10:08   ` David Herrmann
2016-03-29 10:10     ` Alexey Brodkin
2016-03-29 10:02 ` [PATCH 2/3 v4] drm: atmel_hldc: Use generic " Alexey Brodkin
2016-03-29 10:02 ` [PATCH 3/3 v4] drm: rcar-du: " Alexey Brodkin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1459245734-2392-1-git-send-email-abrodkin@synopsys.com \
    --to=alexey.brodkin@synopsys.com \
    --cc=airlied@linux.ie \
    --cc=boris.brezillon@free-electrons.com \
    --cc=daniel@ffwll.ch \
    --cc=dh.herrmann@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-renesas-soc@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®