mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Alexey Brodkin <Alexey.Brodkin@synopsys.com>
To: "dh.herrmann@gmail.com" <dh.herrmann@gmail.com>
Cc: "dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"airlied@linux.ie" <airlied@linux.ie>
Subject: Re: [PATCH 1/3 v4] drm: Introduce drm_connector_register_all() helper
Date: Tue, 29 Mar 2016 10:10:08 +0000	[thread overview]
Message-ID: <1459246208.3021.15.camel@synopsys.com> (raw)
In-Reply-To: <CANq1E4RLcP5BmZyi01NwpY4h8BVkE2jpoPLXW+1UACqsiCA5+g@mail.gmail.com>

Hi David,

On Tue, 2016-03-29 at 12:08 +0200, David Herrmann wrote:
> Hi
> 
> On Tue, Mar 29, 2016 at 12:02 PM, Alexey Brodkin
> <Alexey.Brodkin@synopsys.com> wrote:
> > 
> > As a pair to already existing drm_connector_unregister_all() we're adding
> > generic implementation of what is already done in some drivers.
> > 
> > Once this helper is implemented we'll be ready to switch existing
> > driver-specific implementations with the generic one.
> > 
> > Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
> > Cc: Daniel Vetter <daniel@ffwll.ch>
> > Cc: David Airlie <airlied@linux.ie>
> > Cc: David Herrmann <dh.herrmann@gmail.com>
> > ---
> > 
> > Changes v3 -> v4:
> >  * In drm_connector_register_all() fail path which calls unregister_all()
> >    is moved outside of loop&locked section (as suggested by Daniel)
> > 
> > Changes v2 -> v3:
> >  * Updated title with capital after colon
> >  * Simplified failure path with direct and unconditional invocation of
> >    unregister_all()
> >  * Updated kerneldoc description of the drm_connector_register_all()
> > 
> > Changes v1 -> v2:
> >  * Rename drm_connector_unplug_all() to drm_connector_unregister_all()
> >  * Use drm_for_each_connector() instead of list_for_each_entry()
> >  * Updated kerneldoc for drm_dev_register()
> > 
> >  drivers/gpu/drm/drm_crtc.c | 39 +++++++++++++++++++++++++++++++++++++++
> >  drivers/gpu/drm/drm_drv.c  |  6 +++++-
> >  include/drm/drm_crtc.h     |  3 ++-
> >  3 files changed, 46 insertions(+), 2 deletions(-)
> > 
> > diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
> > index 7675826..3e4cdb1 100644
> > --- a/drivers/gpu/drm/drm_crtc.c
> > +++ b/drivers/gpu/drm/drm_crtc.c
> > @@ -1079,6 +1079,45 @@ void drm_connector_unregister(struct drm_connector *connector)
> >  EXPORT_SYMBOL(drm_connector_unregister);
> > 
> >  /**
> > + * drm_connector_register_all - register all connectors
> > + * @dev: drm device
> > + *
> > + * This function registers all connectors in sysfs and other places so that
> > + * userspace can start to access them. Drivers can call it after calling
> > + * drm_dev_register() to complete the device registration, if they don't call
> > + * drm_connector_register() on each connector individually.
> > + *
> > + * When a device is unplugged and should be removed from userspace access,
> > + * call drm_connector_unregister_all(), which is the inverse of this
> > + * function.
> > + *
> > + * Returns:
> > + * Zero on success, error code on failure.
> > + */
> > +int drm_connector_register_all(struct drm_device *dev)
> > +{
> > +       struct drm_connector *connector;
> > +       int ret;
> > +
> > +       mutex_lock(&dev->mode_config.mutex);
> > +
> > +       drm_for_each_connector(connector, dev) {
> > +               ret = drm_connector_register(connector);
> > +               if (ret)
> > +                       goto err;
> > +       }
> > +
> > +       mutex_unlock(&dev->mode_config.mutex);
> > +
> > +       return 0;
> > +
> > +err:
> > +       drm_connector_unregister_all(dev);
> You _must_ unlock the mutex before returning.

So true!

BTW that's why I liked the previous solution - code was much cleaner
with only 1 branch of execution.

Will resend v5 in a minute.

-Alexey

  reply	other threads:[~2016-03-29 10:10 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-29 10:02 [PATCH 0/3 " Alexey Brodkin
2016-03-29 10:02 ` [PATCH 1/3 " Alexey Brodkin
2016-03-29 10:08   ` David Herrmann
2016-03-29 10:10     ` Alexey Brodkin [this message]
2016-03-29 10:02 ` [PATCH 2/3 v4] drm: atmel_hldc: Use generic " Alexey Brodkin
2016-03-29 10:02 ` [PATCH 3/3 v4] drm: rcar-du: " Alexey Brodkin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1459246208.3021.15.camel@synopsys.com \
    --to=alexey.brodkin@synopsys.com \
    --cc=airlied@linux.ie \
    --cc=daniel@ffwll.ch \
    --cc=dh.herrmann@gmail.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®