From: Ming Lei <ming.lei@canonical.com>
To: Jens Axboe <axboe@fb.com>, linux-kernel@vger.kernel.org
Cc: linux-block@vger.kernel.org,
Christoph Hellwig <hch@infradead.org>,
Al Viro <viro@zeniv.linux.org.uk>,
Ming Lei <ming.lei@canonical.com>,
drbd-dev@lists.linbit.com (open list:DRBD DRIVER),
Jan Kara <jack@suse.cz>, Keith Busch <keith.busch@intel.com>,
Kent Overstreet <kent.overstreet@gmail.com>,
"Kirill A. Shutemov" <kirill.shutemov@linux.intel.com>,
Mike Snitzer <snitzer@redhat.com>, Shaohua Li <shli@fb.com>,
Tejun Heo <tj@kernel.org>,
xfs@oss.sgi.com (open list:XFS FILESYSTEM)
Subject: [PATCH v5 0/8] block: prepare for multipage bvecs
Date: Mon, 18 Apr 2016 05:29:49 +0800 [thread overview]
Message-ID: <1460928615-20894-1-git-send-email-ming.lei@canonical.com> (raw)
Hi,
Interests[1] have been shown in multipage bvecs, so this patchset
try to prepare for the support and do two things:
1) the 1st 4 patches use bvec iterator to implement iterate_bvec(),
then we can drop the non-standard way for iterating bvec, which
can be thought as a good cleanup for lib/iov_iter.c
2) remove BIO_MAX_SECTORS & BIO_MAX_SIZE, and now there is only
one user for each. Once multipage bvecs is introduced, one bio
may hold lots of sectors, and we should always use sort of BIO_MAX_VECS
which should be introduced in future and is similiar with current
BIO_MAX_PAGES.
The only functional change is iterate_bvec():lib/iov_iter.c
xfstests(-a auto) over loop aio is run for ext4/xfs to verify
the change and no regression found with this patchset.
Jens, I am confidant this time, so please give it a go if no one
objects. I appreciate someone(AI? or anyone) can give a review on
the patch 4/8 about iterate_bvec() change.
V5:
- use bvec's iterator to figure new base vec address and
update 'skip' correctly
- run xfstests(-a auto) on loop aio/dio for verifying
the change in iterate_bvec(), and no regression reported
- use stree-ng to trigger heavy swap over swapfile to verify
change in iterate_bvec() too, looks everything is fine
V4:
- make xfstests cover xfs
- rebase on for-next of block tree
V3:
- include kenrel.h & bug.h in bvec.h for fix comiling failure on arm
as reported by 0day ktest
- build test on arm & arm64
V2:
- rename bvec_iter.h as bvec.h
- always include bvec.h into blk_types.h as suggested by Christoph
V1:
- don't move BIO_MAX_* to bvec_iter.h as pointed out by Christoph
- run xfstests against v4.6-rc1-next-20160329
- add Reviewed-by
- for 1,4 and 5, Reviewd-by not added, Christoph still expressed
'this looks fine to me.'
Ming Lei (8):
block: move bvec iterator into include/linux/bvec.h
block: move two bvec structure into bvec.h
block: mark 1st parameter of bvec_iter_advance as const
iov_iter: use bvec iterator to implement iterate_bvec()
fs: xfs: replace BIO_MAX_SECTORS with BIO_MAX_PAGES
block: bio: remove BIO_MAX_SECTORS
block: drbd: avoid to use BIO_MAX_SIZE
block: bio: remove BIO_MAX_SIZE
drivers/block/drbd/drbd_int.h | 4 +-
fs/xfs/xfs_buf.c | 4 +-
include/linux/bio.h | 52 -----------------------
include/linux/blk_types.h | 22 +---------
include/linux/bvec.h | 96 +++++++++++++++++++++++++++++++++++++++++++
lib/iov_iter.c | 45 +++++++-------------
6 files changed, 115 insertions(+), 108 deletions(-)
create mode 100644 include/linux/bvec.h
--
1.9.1
next reply other threads:[~2016-04-17 21:30 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-04-17 21:29 Ming Lei [this message]
2016-04-17 21:29 ` [PATCH v5 1/8] block: move bvec iterator into include/linux/bvec.h Ming Lei
2016-05-02 14:56 ` Christoph Hellwig
2016-04-17 21:29 ` [PATCH v5 2/8] block: move two bvec structure into bvec.h Ming Lei
2016-05-02 14:57 ` Christoph Hellwig
2016-04-17 21:29 ` [PATCH v5 3/8] block: mark 1st parameter of bvec_iter_advance as const Ming Lei
2016-04-17 21:29 ` [PATCH v5 4/8] iov_iter: use bvec iterator to implement iterate_bvec() Ming Lei
2016-05-02 14:57 ` Christoph Hellwig
2016-04-17 21:29 ` [PATCH v5 5/8] fs: xfs: replace BIO_MAX_SECTORS with BIO_MAX_PAGES Ming Lei
2016-05-02 14:57 ` Christoph Hellwig
2016-04-17 21:29 ` [PATCH v5 6/8] block: bio: remove BIO_MAX_SECTORS Ming Lei
2016-04-17 21:29 ` [PATCH v5 7/8] block: drbd: avoid to use BIO_MAX_SIZE Ming Lei
2016-04-17 21:29 ` [PATCH v5 8/8] block: bio: remove BIO_MAX_SIZE Ming Lei
2016-05-03 1:03 ` [PATCH v5 0/8] block: prepare for multipage bvecs Ming Lei
2016-05-08 9:27 ` Christoph Hellwig
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1460928615-20894-1-git-send-email-ming.lei@canonical.com \
--to=ming.lei@canonical.com \
--cc=axboe@fb.com \
--cc=drbd-dev@lists.linbit.com \
--cc=hch@infradead.org \
--cc=jack@suse.cz \
--cc=keith.busch@intel.com \
--cc=kent.overstreet@gmail.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=linux-block@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=shli@fb.com \
--cc=snitzer@redhat.com \
--cc=tj@kernel.org \
--cc=viro@zeniv.linux.org.uk \
--cc=xfs@oss.sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®