mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] pinctrl: oxnas: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map
@ 2016-05-31  9:36 Neil Armstrong
  2016-05-31 10:59 ` Linus Walleij
  0 siblings, 1 reply; 2+ messages in thread
From: Neil Armstrong @ 2016-05-31  9:36 UTC (permalink / raw)
  To: linus.walleij, linux-gpio, linux-arm-kernel, linux-kernel; +Cc: Neil Armstrong

Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map, introduced in
d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map")
but not reported into oxnas driver.

Fixes: 611dac1e48a4 ("pinctrl: Add Oxford Semiconductor OXNAS pinctrl and gpio driver")
Signed-off-by: Neil Armstrong <narmstrong@baylibre.com>
---
 drivers/pinctrl/pinctrl-oxnas.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/pinctrl/pinctrl-oxnas.c b/drivers/pinctrl/pinctrl-oxnas.c
index 2c6abef..917a7d2 100644
--- a/drivers/pinctrl/pinctrl-oxnas.c
+++ b/drivers/pinctrl/pinctrl-oxnas.c
@@ -321,7 +321,7 @@ static const struct pinctrl_ops oxnas_pinctrl_ops = {
 	.get_group_name = oxnas_pinctrl_get_group_name,
 	.get_group_pins = oxnas_pinctrl_get_group_pins,
 	.dt_node_to_map = pinconf_generic_dt_node_to_map_pin,
-	.dt_free_map = pinctrl_utils_dt_free_map,
+	.dt_free_map = pinctrl_utils_free_map,
 };
 
 static int oxnas_pinmux_get_functions_count(struct pinctrl_dev *pctldev)
-- 
1.9.1

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] pinctrl: oxnas: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map
  2016-05-31  9:36 [PATCH] pinctrl: oxnas: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map Neil Armstrong
@ 2016-05-31 10:59 ` Linus Walleij
  0 siblings, 0 replies; 2+ messages in thread
From: Linus Walleij @ 2016-05-31 10:59 UTC (permalink / raw)
  To: Neil Armstrong; +Cc: linux-gpio, linux-arm-kernel, linux-kernel

On Tue, May 31, 2016 at 11:36 AM, Neil Armstrong
<narmstrong@baylibre.com> wrote:

> Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map, introduced in
> d32f7fd3bbc3 ("pinctrl: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map")
> but not reported into oxnas driver.
>
> Fixes: 611dac1e48a4 ("pinctrl: Add Oxford Semiconductor OXNAS pinctrl and gpio driver")
> Signed-off-by: Neil Armstrong <narmstrong@baylibre.com>

Patch applied.

Yours,
Linus Walleij

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2016-05-31 10:59 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-31  9:36 [PATCH] pinctrl: oxnas: Rename pinctrl_utils_dt_free_map to pinctrl_utils_free_map Neil Armstrong
2016-05-31 10:59 ` Linus Walleij

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®