From: Joe Perches <joe@perches.com>
To: Ingo Molnar <mingo@kernel.org>, Matt Fleming <matt@codeblueprint.co.uk>
Cc: Thomas Gleixner <tglx@linutronix.de>,
"H . Peter Anvin" <hpa@zytor.com>,
Peter Jones <pjones@redhat.com>,
Ard Biesheuvel <ard.biesheuvel@linaro.org>,
linux-kernel@vger.kernel.org, linux-efi@vger.kernel.org
Subject: Re: [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout
Date: Mon, 27 Jun 2016 04:14:18 -0700 [thread overview]
Message-ID: <1467026058.1847.95.camel@perches.com> (raw)
In-Reply-To: <20160627104920.GA9099@gmail.com>
On Mon, 2016-06-27 at 12:49 +0200, Ingo Molnar wrote:
> * Matt Fleming <matt@codeblueprint.co.uk> wrote:
[]
> > + * EFI Configuration Table and GUID definitions
> > + *
> > + * These should be formatted roughly like the ones in the UEFI SPEC has
> > + * them. It makes them easier to grep for, and they look the same when
> > + * you're staring at them.
[]
> Btw., another possible way to organize the GUIDs would be to ignore checkpatch (we
> should ignore checkpatch when it's wrong)
Completely agree. checkpatch is brainless.
> and go for a nice table format:
>
> #define NULL_GUID EFI_GUID(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00)
Much nicer.
There are a few more files that use EFI_GUID.
It'd be good to standardize.
$ git grep --name-only -w EFI_GUID
arch/ia64/include/asm/sal.h
arch/ia64/kernel/esi.c
arch/x86/platform/efi/quirks.c
block/partitions/efi.h
drivers/infiniband/hw/hfi1/efivar.c
drivers/scsi/isci/probe_roms.h
include/linux/efi.h
Maybe a checkpatch line-length exclusion:
---
scripts/checkpatch.pl | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl
index 4904ced..cc787e6 100755
--- a/scripts/checkpatch.pl
+++ b/scripts/checkpatch.pl
@@ -2764,6 +2764,10 @@ sub process {
$line =~ /^\+\s*#\s*define\s+\w+\s+$String$/) {
$msg_type = "";
+ # EFI_GUID is another special case
+ } elsif ($line =~ /^\+.*\bEFI_GUID\s*\(/) {
+ $msg_type = "";
+
# Otherwise set the alternate message types
# a comment starts before $max_line_length
next prev parent reply other threads:[~2016-06-27 11:14 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-06-25 7:20 [GIT PULL 0/7] EFI changes for v4.8 Matt Fleming
2016-06-25 7:20 ` [PATCH 1/7] efibc: Report more information in the error messages Matt Fleming
2016-06-27 13:00 ` [tip:efi/core] " tip-bot for Compostella, Jeremy
2016-06-25 7:20 ` [PATCH 2/7] efi: Document #define FOO_PROTOCOL_GUID layout Matt Fleming
2016-06-27 10:49 ` Ingo Molnar
2016-06-27 11:14 ` Joe Perches [this message]
2016-07-04 13:17 ` Matt Fleming
2016-07-08 13:27 ` [tip:efi/core] efi: Reorganize the GUID table to make it easier to read tip-bot for Ingo Molnar
2016-06-27 13:01 ` [tip:efi/core] efi: Document #define FOO_PROTOCOL_GUID layout tip-bot for Peter Jones
2016-06-25 7:20 ` [PATCH 3/7] x86/efi: Remove unused variable efi Matt Fleming
2016-06-27 13:01 ` [tip:efi/core] x86/efi: Remove unused variable 'efi' tip-bot for Colin Ian King
2016-06-25 7:20 ` [PATCH 4/7] efi: Convert efi_call_virt to efi_call_virt_pointer Matt Fleming
2016-06-27 11:00 ` Ingo Molnar
2016-06-27 11:22 ` Mark Rutland
2016-07-04 13:18 ` Matt Fleming
2016-06-27 13:02 ` [tip:efi/core] efi: Convert efi_call_virt() to efi_call_virt_pointer() tip-bot for Alex Thorlton
2016-06-25 7:20 ` [PATCH 5/7] x86/uv: Update uv_bios_call to use efi_call_virt_pointer Matt Fleming
2016-06-27 13:02 ` [tip:efi/core] x86/uv: Update uv_bios_call() to use efi_call_virt_pointer() tip-bot for Alex Thorlton
2016-06-25 7:20 ` [PATCH 6/7] x86/efi: Update efi_thunk to use the the arch_efi_call_virt* macros Matt Fleming
2016-06-27 13:02 ` [tip:efi/core] x86/efi: Update efi_thunk() to use the the arch_efi_call_virt*() macros tip-bot for Alex Thorlton
2016-06-25 7:20 ` [PATCH 7/7] x86/efi: Remove unused efi_get_time function Matt Fleming
2016-06-27 13:03 ` [tip:efi/core] x86/efi: Remove the unused efi_get_time() function tip-bot for Arnd Bergmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1467026058.1847.95.camel@perches.com \
--to=joe@perches.com \
--cc=ard.biesheuvel@linaro.org \
--cc=hpa@zytor.com \
--cc=linux-efi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=matt@codeblueprint.co.uk \
--cc=mingo@kernel.org \
--cc=pjones@redhat.com \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome