mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v6 0/6] firmware: encapsulate firmware loading status
@ 2016-10-20  9:52 Daniel Wagner
  2016-10-20  9:52 ` [PATCH v6 1/6] firmware: move umh locking code into fw_load_from_user_helper() Daniel Wagner
                   ` (5 more replies)
  0 siblings, 6 replies; 8+ messages in thread
From: Daniel Wagner @ 2016-10-20  9:52 UTC (permalink / raw)
  To: linux-kernel
  Cc: Ming Lei, Luis R . Rodriguez, Greg Kroah-Hartman,
	Srivatsa S . Bhat, Rafael J . Wysocki, Daniel Vetter,
	Takashi Iwai, Bjorn Andersson, Arend van Spriel, Daniel Wagner

From: Daniel Wagner <daniel.wagner@bmw-carit.de>

Hi,

Here is a updated version with the input from Luis.

The firmware user helper code tracks the current state of the loading
process via an member of struct firmware_buf and a completion. Let's
encapsulate this simple state machine into struct fw_status. The aim is
to increase readability and reduce the usage of the fw_lock.

I tested this series with fw_userhelper.sh and fw_filesystem.sh under
kvm and also let it run on real hardware. You can get the series as git tree:

https://git.kernel.org/cgit/linux/kernel/git/wagi/linux.git/log/?h=firmware_async-9

cheers,
daniel


This series depends on Luis' "firmware: add SmPL grammar to avoid issues"
series:

http://marc.info/?l=linux-kernel&m=147320896231418&w=2

changes since v5:
  - add enum name (enum fw_status)
  - renamed function prefix and structure fw_umh to fw_state (avoid to
    clash with enum fw_status)
  - add back patch 1 from v3
  - move unused functions for direct firmeware loading into UMH section

changes since v4:
  - replaced "firmware: Move umh locking code into fw_load_from_user_helper()"
    with "firmware: document user mode helper lock usage"
  - changed prefix fw_status_ to fw_umh_
  - fixed a couple of bux pointed out by Ming
  - changed type of fw_umh::status to u8 and updated commit message to
    point out that all states are exclusive

changes since v3:
  - added 'firmware: Move umh locking code into
    fw_load_from_user_helper()'
  - dropped loading_tiemout and firmware_loading_time() for
    !CONFG_FW_LOADER_USER_HELPER
  - rebased on Luis patches

changes since v2:
  - more splitting out
    - first patch factors out all the bit ops into fw_status
    - second patch gets rid of the bit ops
    - third get rid of fw_lock by using swait

changes since v1:
  - moved swait change into its own patch
  - added ifdef section for FW_LOADER_USER_HELPER_FALLBACK
  - updated commit message highlighting the mutex usage drop a bit

Daniel Wagner (6):
  firmware: move umh locking code into fw_load_from_user_helper()
  firmware: encapsulate firmware loading status
  firmware: rename fw_load_from_user_helper() and
    _request_firmware_load()
  firmware: drop bit ops in favor of simple state machine
  firmware: do not use fw_lock for fw_state protection
  firmware: move fw_state_is_{aborted|done}() into UHM section

 drivers/base/firmware_class.c | 226 ++++++++++++++++++++++++------------------
 1 file changed, 131 insertions(+), 95 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2016-11-09 21:17 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-10-20  9:52 [PATCH v6 0/6] firmware: encapsulate firmware loading status Daniel Wagner
2016-10-20  9:52 ` [PATCH v6 1/6] firmware: move umh locking code into fw_load_from_user_helper() Daniel Wagner
2016-11-09 21:17   ` Luis R. Rodriguez
2016-10-20  9:52 ` [PATCH v6 2/6] firmware: encapsulate firmware loading status Daniel Wagner
2016-10-20  9:52 ` [PATCH v6 3/6] firmware: rename fw_load_from_user_helper() and _request_firmware_load() Daniel Wagner
2016-10-20  9:52 ` [PATCH v6 4/6] firmware: drop bit ops in favor of simple state machine Daniel Wagner
2016-10-20  9:52 ` [PATCH v6 5/6] firmware: do not use fw_lock for fw_state protection Daniel Wagner
2016-10-20  9:52 ` [PATCH v6 6/6] firmware: move fw_state_is_{aborted|done}() into UHM section Daniel Wagner

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®