From: Joe Perches <joe@perches.com>
To: Greg KH <greg@kroah.com>, Chewie Lin <linsh@oregonstate.edu>
Cc: forest@alittletooquiet.net, devel@driverdev.osuosl.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
Date: Tue, 18 Apr 2017 03:32:41 -0700 [thread overview]
Message-ID: <1492511561.8661.34.camel@perches.com> (raw)
In-Reply-To: <20170418083348.GA4366@kroah.com>
On Tue, 2017-04-18 at 10:33 +0200, Greg KH wrote:
> On Tue, Apr 18, 2017 at 01:24:37AM -0700, Chewie Lin wrote:
> > Removed the usb_device_reset(), replace with call to usb_reset_device()
> > directly. Plus it removes the confusing function name and addressed
> > the checkpatch warning as well by swap string in the dev_warn() call with
> > __func__ argument, instead of explicitly calling the function name in
> > the string:
> >
> > WARNING: Prefer using "%s", __func__ to embedded function names
> > #417: FILE: main_usb.c:417:
> > + "usb_device_reset fail status=%d\n", status);
> >
> > total: 0 errors, 1 warnings, 1058 lines checked
> >
> > And after fix:
> >
> > main_usb.c has no obvious style problems and is ready for submission.
> >
> >
> > Signed-off-by: Chewie Lin <linsh@oregonstate.edu>
>
> Your subject line is odd, don't you think? Compare it to other patches
> for this driver and please fix it up and resend.
>
> And there's never a need for a 0/X email for a single patch submission,
> no need to do that again.
And __func__ here is vt6656_probe not usb_reset_device.
usb_reset_device is the function that failed.
prev parent reply other threads:[~2017-04-18 10:32 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-18 8:24 [PATCH 0/1] " Chewie Lin
2017-04-18 8:24 ` [PATCH 1/1] " Chewie Lin
2017-04-18 8:33 ` Greg KH
2017-04-18 10:32 ` Joe Perches [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1492511561.8661.34.camel@perches.com \
--to=joe@perches.com \
--cc=devel@driverdev.osuosl.org \
--cc=forest@alittletooquiet.net \
--cc=greg@kroah.com \
--cc=linsh@oregonstate.edu \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome