From: Chewie Lin <linsh@oregonstate.edu>
To: greg@kroah.com, forest@alittletooquiet.net,
devel@driverdev.osuosl.org, linux-kernel@vger.kernel.org
Subject: [PATCH 1/1] drivers/staging/vt6656/main_usb.c: usb_device_reset
Date: Tue, 18 Apr 2017 01:24:37 -0700 [thread overview]
Message-ID: <20170418082437.25451-2-linsh@oregonstate.edu> (raw)
In-Reply-To: <20170418082437.25451-1-linsh@oregonstate.edu>
Removed the usb_device_reset(), replace with call to usb_reset_device()
directly. Plus it removes the confusing function name and addressed
the checkpatch warning as well by swap string in the dev_warn() call with
__func__ argument, instead of explicitly calling the function name in
the string:
WARNING: Prefer using "%s", __func__ to embedded function names
#417: FILE: main_usb.c:417:
+ "usb_device_reset fail status=%d\n", status);
total: 0 errors, 1 warnings, 1058 lines checked
And after fix:
main_usb.c has no obvious style problems and is ready for submission.
Signed-off-by: Chewie Lin <linsh@oregonstate.edu>
---
drivers/staging/vt6656/main_usb.c | 15 ++++-----------
1 file changed, 4 insertions(+), 11 deletions(-)
diff --git a/drivers/staging/vt6656/main_usb.c b/drivers/staging/vt6656/main_usb.c
index 9e074e9daf4e..028f54b453d0 100644
--- a/drivers/staging/vt6656/main_usb.c
+++ b/drivers/staging/vt6656/main_usb.c
@@ -407,16 +407,6 @@ static void vnt_free_rx_bufs(struct vnt_private *priv)
}
}
-static void usb_device_reset(struct vnt_private *priv)
-{
- int status;
-
- status = usb_reset_device(priv->usb);
- if (status)
- dev_warn(&priv->usb->dev,
- "usb_device_reset fail status=%d\n", status);
-}
-
static void vnt_free_int_bufs(struct vnt_private *priv)
{
kfree(priv->int_buf.data_buf);
@@ -995,7 +985,10 @@ vt6656_probe(struct usb_interface *intf, const struct usb_device_id *id)
SET_IEEE80211_DEV(priv->hw, &intf->dev);
- usb_device_reset(priv);
+ rc = usb_reset_device(priv->usb);
+ if (rc)
+ dev_warn(&priv->usb->dev,
+ "%s reset fail status=%d\n", __func__, rc);
clear_bit(DEVICE_FLAGS_DISCONNECTED, &priv->flags);
vnt_reset_command_timer(priv);
--
2.12.2
next prev parent reply other threads:[~2017-04-18 8:24 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-04-18 8:24 [PATCH 0/1] " Chewie Lin
2017-04-18 8:24 ` Chewie Lin [this message]
2017-04-18 8:33 ` [PATCH 1/1] " Greg KH
2017-04-18 10:32 ` Joe Perches
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170418082437.25451-2-linsh@oregonstate.edu \
--to=linsh@oregonstate.edu \
--cc=devel@driverdev.osuosl.org \
--cc=forest@alittletooquiet.net \
--cc=greg@kroah.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome