mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/3] staging: rtl8192u: Refactor u4bAcParam construction
@ 2017-05-01 22:46 Tuomo Rinne
  2017-05-01 22:46 ` [PATCH 1/3] staging: rtl8192u: Remove unnecessary scope Tuomo Rinne
                   ` (2 more replies)
  0 siblings, 3 replies; 5+ messages in thread
From: Tuomo Rinne @ 2017-05-01 22:46 UTC (permalink / raw)
  To: gregkh; +Cc: devel, linux-kernel

This is a resubmission of patch series. 

This submission fixes the warnings reported by kbuild robot by passing
in u4bAcParam to cpu_to_le32s using pointer rather than value.

This submission also fixes erroneous line deletion reported by reviewer.

I've also amended the commit message of the last patch of the series for 
better explanation.


Tuomo Rinne (3):
  staging: rtl8192u: Remove unnecessary scope
  staging: rtl8192u: Improve code readability
  staging: rtl8192u: Convert u4bAcParam to little-endian

 drivers/staging/rtl8192u/r8192U_dm.c | 77 ++++++++++++++++++++----------------
 1 file changed, 43 insertions(+), 34 deletions(-)

-- 
2.1.4

^ permalink raw reply	[flat|nested] 5+ messages in thread
* Re: [PATCH] staging: rtl8192u: Improve readability and fix sparse warnings: cast from restricted __le16
@ 2017-04-28 10:27 Greg KH
  2017-04-29 11:35 ` [PATCH 1/3] staging: rtl8192u: Remove unnecessary scope Tuomo Rinne
  0 siblings, 1 reply; 5+ messages in thread
From: Greg KH @ 2017-04-28 10:27 UTC (permalink / raw)
  To: Tuomo Rinne; +Cc: devel, linux-kernel

On Sat, Apr 22, 2017 at 11:55:23PM +0100, Tuomo Rinne wrote:
> This patch fixes following sparse warnings:
> 
> drivers/staging/rtl8192u//r8192U_dm.c:2307:49: warning: cast from restricted __le16
> drivers/staging/rtl8192u//r8192U_dm.c:2308:44: warning: cast from restricted __le16
> drivers/staging/rtl8192u//r8192U_dm.c:2309:44: warning: cast from restricted __le16
> 
> In order to avoid the warnings the u4bAcParam variable is constructed
> using the cpu's endianness and in case of big endian architectures the
> variable is converted back to little endian before passed to write_nic_dword
> function.
> 
> Also the patch improves readability by getting rid of unnecessary scope
> and splitting complex variable construction to multiple lines.

Don't do multiple things in the same patch, please break this up into
different patches, each one doing only one thing.

thanks,

greg k-h

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2017-05-01 22:47 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-01 22:46 [PATCH 0/3] staging: rtl8192u: Refactor u4bAcParam construction Tuomo Rinne
2017-05-01 22:46 ` [PATCH 1/3] staging: rtl8192u: Remove unnecessary scope Tuomo Rinne
2017-05-01 22:46 ` [PATCH 2/3] staging: rtl8192u: Improve code readability Tuomo Rinne
2017-05-01 22:46 ` [PATCH 3/3] staging: rtl8192u: Convert u4bAcParam to little-endian Tuomo Rinne
  -- strict thread matches above, loose matches on Subject: below --
2017-04-28 10:27 [PATCH] staging: rtl8192u: Improve readability and fix sparse warnings: cast from restricted __le16 Greg KH
2017-04-29 11:35 ` [PATCH 1/3] staging: rtl8192u: Remove unnecessary scope Tuomo Rinne
2017-04-29 11:35   ` [PATCH 2/3] staging: rtl8192u: Improve code readability Tuomo Rinne

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®