* [RESENT PATCH] ASoC: hdmi-codec: Use different name for playback streams
@ 2017-08-12 0:40 Jeffy Chen
2017-08-30 21:19 ` Applied "ASoC: hdmi-codec: Use different name for playback streams" to the asoc tree Mark Brown
0 siblings, 1 reply; 2+ messages in thread
From: Jeffy Chen @ 2017-08-12 0:40 UTC (permalink / raw)
To: linux-kernel
Cc: briannorris, dianders, Jeffy Chen, Jaroslav Kysela, alsa-devel,
Vincent Abriou, Arnaud Pouliquen, Mark Brown, Kuninori Morimoto,
Takashi Iwai, Jon Medhurst (Tixy),
Liam Girdwood, Colin Ian King
Currently the hdmi i2s playback stream and hdmi spdif playback stream
are using the same name. So when they are enabled at the same time,
kernel will print this warning:
[ 2.201835] hdmi-audio-codec hdmi-audio-codec.1.auto: ASoC: Failed to
create Playback debugfs file
Assign different names to them to avoid that.
Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
---
sound/soc/codecs/hdmi-codec.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sound/soc/codecs/hdmi-codec.c b/sound/soc/codecs/hdmi-codec.c
index 509ab51..a2af440 100644
--- a/sound/soc/codecs/hdmi-codec.c
+++ b/sound/soc/codecs/hdmi-codec.c
@@ -696,7 +696,7 @@ static struct snd_soc_dai_driver hdmi_i2s_dai = {
.name = "i2s-hifi",
.id = DAI_ID_I2S,
.playback = {
- .stream_name = "Playback",
+ .stream_name = "I2S Playback",
.channels_min = 2,
.channels_max = 8,
.rates = HDMI_RATES,
@@ -711,7 +711,7 @@ static const struct snd_soc_dai_driver hdmi_spdif_dai = {
.name = "spdif-hifi",
.id = DAI_ID_SPDIF,
.playback = {
- .stream_name = "Playback",
+ .stream_name = "SPDIF Playback",
.channels_min = 2,
.channels_max = 2,
.rates = HDMI_RATES,
--
2.1.4
^ permalink raw reply [flat|nested] 2+ messages in thread* Applied "ASoC: hdmi-codec: Use different name for playback streams" to the asoc tree
2017-08-12 0:40 [RESENT PATCH] ASoC: hdmi-codec: Use different name for playback streams Jeffy Chen
@ 2017-08-30 21:19 ` Mark Brown
0 siblings, 0 replies; 2+ messages in thread
From: Mark Brown @ 2017-08-30 21:19 UTC (permalink / raw)
To: Jeffy Chen
Cc: Mark Brown, linux-kernel, Jon Medhurst (Tixy),
alsa-devel, briannorris, Kuninori Morimoto, Liam Girdwood,
Arnaud Pouliquen, dianders, Mark Brown, Colin Ian King,
Takashi Iwai, Vincent Abriou, alsa-devel
The patch
ASoC: hdmi-codec: Use different name for playback streams
has been applied to the asoc tree at
git://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git
All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.
You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.
If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.
Please add any relevant lists and maintainers to the CCs when replying
to this mail.
Thanks,
Mark
>From 943fa0228252320de503b923dfe46334f755aaae Mon Sep 17 00:00:00 2001
From: Jeffy Chen <jeffy.chen@rock-chips.com>
Date: Sat, 12 Aug 2017 08:40:38 +0800
Subject: [PATCH] ASoC: hdmi-codec: Use different name for playback streams
Currently the hdmi i2s playback stream and hdmi spdif playback stream
are using the same name. So when they are enabled at the same time,
kernel will print this warning:
[ 2.201835] hdmi-audio-codec hdmi-audio-codec.1.auto: ASoC: Failed to
create Playback debugfs file
Assign different names to them to avoid that.
Signed-off-by: Jeffy Chen <jeffy.chen@rock-chips.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
sound/soc/codecs/hdmi-codec.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sound/soc/codecs/hdmi-codec.c b/sound/soc/codecs/hdmi-codec.c
index f7520413c671..189af068f28d 100644
--- a/sound/soc/codecs/hdmi-codec.c
+++ b/sound/soc/codecs/hdmi-codec.c
@@ -696,7 +696,7 @@ static struct snd_soc_dai_driver hdmi_i2s_dai = {
.name = "i2s-hifi",
.id = DAI_ID_I2S,
.playback = {
- .stream_name = "Playback",
+ .stream_name = "I2S Playback",
.channels_min = 2,
.channels_max = 8,
.rates = HDMI_RATES,
@@ -711,7 +711,7 @@ static const struct snd_soc_dai_driver hdmi_spdif_dai = {
.name = "spdif-hifi",
.id = DAI_ID_SPDIF,
.playback = {
- .stream_name = "Playback",
+ .stream_name = "SPDIF Playback",
.channels_min = 2,
.channels_max = 2,
.rates = HDMI_RATES,
--
2.14.1
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2017-08-30 21:19 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-08-12 0:40 [RESENT PATCH] ASoC: hdmi-codec: Use different name for playback streams Jeffy Chen
2017-08-30 21:19 ` Applied "ASoC: hdmi-codec: Use different name for playback streams" to the asoc tree Mark Brown
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®