mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/17] DRBD updates
@ 2017-08-24 21:22 Philipp Reisner
  2017-08-24 21:22 ` [PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Philipp Reisner
                   ` (16 more replies)
  0 siblings, 17 replies; 21+ messages in thread
From: Philipp Reisner @ 2017-08-24 21:22 UTC (permalink / raw)
  To: Jens Axboe, linux-kernel; +Cc: drbd-dev

Hi Jens,

Please consider these patches for your for-4.14 branch.

The first and third patch help with request merging on DRBD's secondary side.
That can improves performance for some workloads.

The other patches are fixes and random mentenance.


Baoyou Xie (1):
  drbd: mark symbols static where possible

Geliang Tang (1):
  drbd: Use setup_timer() instead of init_timer() to simplify the code.

Greg Kroah-Hartman (1):
  drbd: rename "usermode_helper" to "drbd_usermode_helper"

Lars Ellenberg (9):
  drbd: introduce drbd_recv_header_maybe_unplug
  drbd: change list_for_each_safe to while(list_first_entry_or_null)
  drbd: add explicit plugging when submitting batches
  drbd: Send P_NEG_ACK upon write error in protocol != C
  drbd: new disk-option disable-write-same
  drbd: fix potential get_ldev/put_ldev refcount imbalance during attach
  drbd: fix rmmod cleanup, remove _all_ debugfs entries
  drbd: fix potential deadlock when trying to detach during handshake
  drbd: fix race between handshake and admin disconnect/down

Markus Elfring (1):
  drbd: A single dot should be put into a sequence.

Philipp Reisner (1):
  drbd: Fix resource role for newly created resources in events2

Roland Kammerer (3):
  drbd: move global variables to drbd namespace and make some static
  drbd: abort drbd_start_resync if there is no connection
  drbd: switch from kmalloc() to kmalloc_array()

 drivers/block/drbd/drbd_int.h      |  27 +++++-----
 drivers/block/drbd/drbd_main.c     | 106 +++++++++++++++++++++----------------
 drivers/block/drbd/drbd_nl.c       |  60 +++++++++------------
 drivers/block/drbd/drbd_proc.c     |  10 ++--
 drivers/block/drbd/drbd_receiver.c |  56 +++++++++++++++++---
 drivers/block/drbd/drbd_req.c      |  80 ++++++++++++++++++++++++++--
 drivers/block/drbd/drbd_req.h      |   6 +++
 drivers/block/drbd/drbd_state.c    |  48 ++++++++++++++++-
 drivers/block/drbd/drbd_state.h    |   8 +++
 drivers/block/drbd/drbd_worker.c   |  46 ++++++++++++----
 include/linux/drbd.h               |   2 +-
 include/linux/drbd_genl.h          |   3 +-
 include/linux/drbd_limits.h        |   8 ++-
 13 files changed, 333 insertions(+), 127 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 21+ messages in thread

end of thread, other threads:[~2017-08-28 13:51 UTC | newest]

Thread overview: 21+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-08-24 21:22 [PATCH 00/17] DRBD updates Philipp Reisner
2017-08-24 21:22 ` [PATCH 01/17] drbd: introduce drbd_recv_header_maybe_unplug Philipp Reisner
2017-08-25 17:26   ` Jens Axboe
2017-08-28 13:35     ` Philipp Reisner
2017-08-28 13:43       ` Philipp Reisner
2017-08-24 21:22 ` [PATCH 02/17] drbd: change list_for_each_safe to while(list_first_entry_or_null) Philipp Reisner
2017-08-24 21:23 ` [PATCH 03/17] drbd: add explicit plugging when submitting batches Philipp Reisner
2017-08-24 21:23 ` [PATCH 04/17] drbd: Send P_NEG_ACK upon write error in protocol != C Philipp Reisner
2017-08-24 21:23 ` [PATCH 05/17] drbd: mark symbols static where possible Philipp Reisner
2017-08-24 21:23 ` [PATCH 06/17] drbd: Fix resource role for newly created resources in events2 Philipp Reisner
2017-08-24 21:23 ` [PATCH 07/17] drbd: new disk-option disable-write-same Philipp Reisner
2017-08-24 21:23 ` [PATCH 08/17] drbd: fix potential get_ldev/put_ldev refcount imbalance during attach Philipp Reisner
2017-08-24 21:23 ` [PATCH 09/17] drbd: Use setup_timer() instead of init_timer() to simplify the code Philipp Reisner
2017-08-24 21:23 ` [PATCH 10/17] drbd: fix rmmod cleanup, remove _all_ debugfs entries Philipp Reisner
2017-08-24 21:23 ` [PATCH 11/17] drbd: A single dot should be put into a sequence Philipp Reisner
2017-08-24 21:23 ` [PATCH 12/17] drbd: fix potential deadlock when trying to detach during handshake Philipp Reisner
2017-08-24 21:23 ` [PATCH 13/17] drbd: fix race between handshake and admin disconnect/down Philipp Reisner
2017-08-24 21:23 ` [PATCH 14/17] drbd: rename "usermode_helper" to "drbd_usermode_helper" Philipp Reisner
2017-08-24 21:23 ` [PATCH 15/17] drbd: move global variables to drbd namespace and make some static Philipp Reisner
2017-08-24 21:23 ` [PATCH 16/17] drbd: abort drbd_start_resync if there is no connection Philipp Reisner
2017-08-24 21:23 ` [PATCH 17/17] drbd: switch from kmalloc() to kmalloc_array() Philipp Reisner

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome