mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ricardo Neri <ricardo.neri-calderon@linux.intel.com>
To: Borislav Petkov <bp@suse.de>
Cc: Ingo Molnar <mingo@redhat.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	"H. Peter Anvin" <hpa@zytor.com>,
	Andy Lutomirski <luto@kernel.org>,
	Peter Zijlstra <peterz@infradead.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Brian Gerst <brgerst@gmail.com>,
	Chris Metcalf <cmetcalf@mellanox.com>,
	Dave Hansen <dave.hansen@linux.intel.com>,
	Paolo Bonzini <pbonzini@redhat.com>,
	Masami Hiramatsu <mhiramat@kernel.org>,
	Huang Rui <ray.huang@amd.com>, Jiri Slaby <jslaby@suse.cz>,
	Jonathan Corbet <corbet@lwn.net>,
	"Michael S. Tsirkin" <mst@redhat.com>,
	Paul Gortmaker <paul.gortmaker@windriver.com>,
	Vlastimil Babka <vbabka@suse.cz>, Chen Yucong <slaoub@gmail.com>,
	"Ravi V. Shankar" <ravi.v.shankar@intel.com>,
	Shuah Khan <shuah@kernel.org>,
	linux-kernel@vger.kernel.org, x86@kernel.org,
	Adam Buchbinder <adam.buchbinder@gmail.com>,
	Colin Ian King <colin.king@canonical.com>,
	Lorenzo Stoakes <lstoakes@gmail.com>,
	Qiaowei Ren <qiaowei.ren@intel.com>,
	Arnaldo Carvalho de Melo <acme@redhat.com>,
	Adrian Hunter <adrian.hunter@intel.com>,
	Kees Cook <keescook@chromium.org>,
	Thomas Garnier <thgarnie@google.com>,
	Dmitry Vyukov <dvyukov@google.com>
Subject: Re: [PATCH v8 12/28] x86/insn-eval: Add utility functions to get segment selector
Date: Wed, 27 Sep 2017 15:32:26 -0700	[thread overview]
Message-ID: <1506551546.2532.36.camel@linux.intel.com> (raw)
In-Reply-To: <20170927114713.wbee7ze2ud2ekvbw@pd.tnic>

On Wed, 2017-09-27 at 13:47 +0200, Borislav Petkov wrote:
> On Tue, Sep 26, 2017 at 09:21:44PM -0700, Ricardo Neri wrote:
> > 
> > This is true except when we don't have an insn at all (well, it may
> > be
> > non-NULL but it will only contain garbage). The case to which I am
> > referring is when we begin decoding our instruction. The first step
> > is
> > to copy_from_user the instruction and populate insn. For this we
> > must
> > calculate the linear address from where we copy using CS and rIP.
> Where do we do that?

UMIP emulation does it when evaluating if emulation is needed after a
#GP(0). It copy_from_user into insn the code at rIP that caused the
exception [1].
> 
> > 
> > Furthermore, in this only case we don't need to look at insn at all
> > as
> > the only register involved is rIP no segment override prefixes are
> > allowed.
> In any case, as it is now it sounds convoluted: you may or may not
> have an insn, and yet you call get_overridden_seg_reg() on it but you
> don't really need segment overrides because you only need CS and rIP
> initially.

The idea is that get_overridden_seg_reg() would implement the logic you
just described. It would return return INAT_SEG_REG_DEFAULT/IGNORE when
segment override prefixes are not allowed (i.e., valid insn with
operand rDI and string instruction; and rIP) or needed (i.e., long
mode, except if there are override prefixes for FS or GS); or
INAT_SEG_REG_[CSDEFG]S otherwise. 

Then resolve_seg_register() resolves the default segment if needed as
per the value returned by get_overridden_seg_reg().

Summarizing, a more accurate function name for the intended behavior is
get_overridden_seg_reg_if_any_or_needed().

> Sounds to me like this initial parsing should be done separately from
> this function...

I decided to put all the handling of segment override prefixes in a
single function.

Perhaps it could be split into two functions as follows(diff on top of
my original patches):

* Rename get_overridden_seg_reg top get_overridden_seg_reg_idx
* Remove from get_overridden_seg_reg_idx checks for rIP and rDI...
* Checks for rIP and rDI are done in a new function
* Now resolve_seg_reg calls the two functions above to determine if it
needs to resolve the default segment register index.

@@ -77,24 +77,12 @@ static bool is_string_insn(struct insn *insn)
  * INAT_SEG_REG_DEFAULT is returned if no segment override prefixes
were found
  * and the default segment register shall be used. -EINVAL in case of
error.
  */
-static int get_overridden_seg_reg(struct insn *insn, struct pt_regs
*regs,
-				  int regoff)
+static int get_overridden_seg_reg_idx(struct insn *insn, struct
pt_regs *regs,
+				      int regoff)
 {
 	int idx = INAT_SEG_REG_DEFAULT;
 	int sel_overrides = 0, i;
 
-	/*
-	 * Segment override prefixes should not be used for (E)IP. 
-	 * Check this case first as we might not have (and not needed 
-	 * at all) a valid insn structure to evaluate segment
override 
-	 * prefixes.
-	 */
-	if (regoff == offsetof(struct pt_regs, ip)) {
-		if (user_64bit_mode(regs))
-			return INAT_SEG_REG_IGNORE;
-		else
-			return INAT_SEG_REG_DEFAULT;
-	}
-
 	if (!insn)
 		return -EINVAL;
 
@@ -145,18 +133,32 @@ static int get_overridden_seg_reg(struct insn
*insn, struct pt_regs *regs,
 	/*
	 * More than one segment override prefix leads to undefined 
	 * behavior.
	 */
 	} else if (sel_overrides > 1) {
 		return -EINVAL;
-	/*
-	 * Segment override prefixes are always ignored for string 
-	 * instructions
-	 * that involve the use the (E)DI register.
-	 */
-	} else if ((regoff == offsetof(struct pt_regs, di)) &&
-		   is_string_insn(insn)) {
-		return INAT_SEG_REG_DEFAULT;
 	}
 
 	return idx;
 }
 
+static int use_seg_reg_overrides(struct insn *insn, int regoff)
+{
+	/*
+	 * Segment override prefixes should not be used for rIP.
Check 
+	 * this case first as we might not have (and not needed at
all) +	 * a valid insn structure to evaluate segment override 
+	 * prefixes.
+	 */
+	if (regoff == offsetof(struct pt_regs, ip))
+		return 0;
+
+	/* Subsequent checks require a valid insn. */
+	if (!insn)
+		return -EINVAL;
+
+	if ((regoff == offsetof(struct pt_regs, di)) &&
+		   is_string_insn(insn))
+		return 0;
+
+	return 1;
+}
+
 /**
  * resolve_seg_register() - obtain segment register
  * @insn:	Instruction structure with segment override prefixes
@@ -179,22 +181,20 @@ static int get_overridden_seg_reg(struct insn
*insn, struct pt_regs *regs,
  */
 static int resolve_seg_reg(struct insn *insn, struct pt_regs *regs,
int regoff)
 {
-	int idx;
-
-	idx = get_overridden_seg_reg(insn, regs, regoff);
+	int use_pfx_overrides;
 
-	if (idx < 0)
-		return idx;
-
-	if (idx == INAT_SEG_REG_IGNORE)
-		return idx;
+	use_pfx_overrides = use_seg_reg_overrides(insn, regoff);
+	if (use_pfx_overrides < 0)
+		return -EINVAL;
 
-	if (idx != INAT_SEG_REG_DEFAULT)
-		return idx;
+	if (use_pfx_overrides == 0)
+		goto resolve_default_idx;
 
-	if (!insn)
-		return -EINVAL;
+	return get_overridden_seg_reg_idx(insn, regs, regoff);
 
+resolve_default_idx:
+	if (user_64bit_mode(regs))
+		return INAT_SEG_REG_IGNORE;
 	/*
 	 * If we are here, we use the default segment register as 
	 * described in the Intel documentation:
@@ -209,6 +209,9 @@ static int resolve_seg_reg(struct insn *insn,
struct pt_regs *regs, int regoff)
 	 *  + CS for (E)IP.
 	 */
 
+	if (!insn)
+		return -EINVAL;
+
 	switch (regoff) {
 	case offsetof(struct pt_regs, ax):
 	case offsetof(struct pt_regs, cx):

Does this make sense?

> 
> > 
> > I only used "(E)" (i.e., not the "(R|)" part) as these utility
> > functions will deal mostly with protected mode, unless FS or GS are
> > used in long mode.
> eIP or rIP is simply much easier to type and parse. Those brackets,
> not
> really.

Agreed. Then I will use rIP.
> 
> > 
> > I only check for a NULL insn when needed (i.e., the contents of the
> > instruction could change the used segment register).
> ... and those if (!insn) tests sprinkled around simply make the code
> unreadable and if we can get rid of them, we should.

Sure, you are correct this will make code more readable.

Thanks and BR,
Ricardo

[1]. https://github.com/ricardon/tip/blob/rneri/umip_v9/arch/x86/kernel
/umip.c#L276

  reply	other threads:[~2017-09-27 22:32 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-19  0:27 [PATCH v8 00/28] x86: Enable User-Mode Instruction Prevention Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 01/28] x86/mm: Relocate page fault error codes to traps.h Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 02/28] x86/boot: Relocate definition of the initial state of CR0 Ricardo Neri
2017-08-25 17:41   ` Borislav Petkov
2017-08-31  4:04     ` Ricardo Neri
2017-08-31  9:51       ` Borislav Petkov
2017-09-02 17:35         ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 03/28] ptrace,x86: Make user_64bit_mode() available to 32-bit builds Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 04/28] uprobes/x86: Use existing definitions for segment override prefixes Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 05/28] x86/mpx: Use signed variables to compute effective addresses Ricardo Neri
2017-08-29 16:09   ` Borislav Petkov
2017-08-31  4:19     ` Ricardo Neri
2017-08-31  9:52       ` Borislav Petkov
2017-08-19  0:27 ` [PATCH v8 06/28] x86/mpx: Do not use SIB.index if its value is 100b and ModRM.mod is not 11b Ricardo Neri
2017-08-31 19:38   ` Borislav Petkov
2017-09-02 17:19     ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 07/28] x86/mpx: Do not use SIB.base if its value is 101b and ModRM.mod = 0 Ricardo Neri
2017-09-06 15:44   ` Borislav Petkov
2017-08-19  0:27 ` [PATCH v8 08/28] x86/mpx, x86/insn: Relocate insn util functions to a new insn-eval file Ricardo Neri
2017-09-06 15:54   ` Borislav Petkov
2017-09-06 19:27     ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 09/28] x86/insn-eval: Do not BUG on invalid register type Ricardo Neri
2017-09-07 17:54   ` Borislav Petkov
2017-09-07 20:27     ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 10/28] x86/insn-eval: Add a utility function to get register offsets Ricardo Neri
2017-09-08 13:35   ` Borislav Petkov
2017-09-14 18:30     ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 11/28] x86/insn-eval: Add utility function to identify string instructions Ricardo Neri
2017-09-08 13:57   ` Borislav Petkov
2017-09-14 18:30     ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 12/28] x86/insn-eval: Add utility functions to get segment selector Ricardo Neri
2017-09-26 10:43   ` Borislav Petkov
2017-09-27  4:21     ` Ricardo Neri
2017-09-27 11:47       ` Borislav Petkov
2017-09-27 22:32         ` Ricardo Neri [this message]
2017-09-28  9:36           ` Borislav Petkov
2017-09-29  6:06             ` Ricardo Neri
2017-09-29 11:56               ` Borislav Petkov
2017-10-04 16:47                 ` Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 13/28] x86/insn-eval: Add utility function to get segment descriptor Ricardo Neri
2017-09-26 18:05   ` Borislav Petkov
2017-09-27 17:39     ` Neri, Ricardo
2017-08-19  0:27 ` [PATCH v8 14/28] x86/insn-eval: Add utility functions to get segment descriptor base address and limit Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 15/28] x86/insn-eval: Add function to get default params of code segment Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 16/28] x86/insn-eval: Indicate a 32-bit displacement if ModRM.mod is 0 and ModRM.rm is 101b Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 17/28] x86/insn-eval: Incorporate segment base in linear address computation Ricardo Neri
2017-08-19  0:27 ` [PATCH v8 18/28] x86/insn-eval: Add support to resolve 32-bit address encodings Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 19/28] x86/insn-eval: Add wrapper function for 32 and 64-bit addresses Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 20/28] x86/insn-eval: Handle 32-bit address encodings in virtual-8086 mode Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 21/28] x86/insn-eval: Add support to resolve 16-bit addressing encodings Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 22/28] x86/cpufeature: Add User-Mode Instruction Prevention definitions Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 23/28] x86: Add emulation code for UMIP instructions Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 24/28] x86/umip: Force a page fault when unable to copy emulated result to user Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 25/28] x86: Enable User-Mode Instruction Prevention Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 26/28] x86/traps: Fixup general protection faults caused by UMIP Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 27/28] selftests/x86: Add tests for User-Mode Instruction Prevention Ricardo Neri
2017-08-19  0:28 ` [PATCH v8 28/28] selftests/x86: Add tests for instruction str and sldt Ricardo Neri

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1506551546.2532.36.camel@linux.intel.com \
    --to=ricardo.neri-calderon@linux.intel.com \
    --cc=acme@redhat.com \
    --cc=adam.buchbinder@gmail.com \
    --cc=adrian.hunter@intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=bp@suse.de \
    --cc=brgerst@gmail.com \
    --cc=cmetcalf@mellanox.com \
    --cc=colin.king@canonical.com \
    --cc=corbet@lwn.net \
    --cc=dave.hansen@linux.intel.com \
    --cc=dvyukov@google.com \
    --cc=hpa@zytor.com \
    --cc=jslaby@suse.cz \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lstoakes@gmail.com \
    --cc=luto@kernel.org \
    --cc=mhiramat@kernel.org \
    --cc=mingo@redhat.com \
    --cc=mst@redhat.com \
    --cc=paul.gortmaker@windriver.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=qiaowei.ren@intel.com \
    --cc=ravi.v.shankar@intel.com \
    --cc=ray.huang@amd.com \
    --cc=shuah@kernel.org \
    --cc=slaoub@gmail.com \
    --cc=tglx@linutronix.de \
    --cc=thgarnie@google.com \
    --cc=vbabka@suse.cz \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome