* [PATCH] Revert "ASoC: core: use component driver name as component name"
@ 2019-05-31 10:31 Krzysztof Kozlowski
0 siblings, 0 replies; only message in thread
From: Krzysztof Kozlowski @ 2019-05-31 10:31 UTC (permalink / raw)
To: Liam Girdwood, Mark Brown, Jaroslav Kysela, Takashi Iwai,
alsa-devel, linux-kernel
Cc: Tzung-Bi Shih, Sylwester Nawrocki, Krzysztof Kozlowski
Using component driver as a name is not unique and it breaks audio in
certain configurations, e.g. Hardkernel Odroid XU3 board where following
components are registered:
- 3830000.i2s with driver snd_dmaengine_pcm
- 3830000.i2s-sec with driver snd_dmaengine_pcm
- 3830000.i2s with driver 3830000.i2s-sec
This reverts commit b19671d6caf1ac393681864d5d85dda9fa99a448.
Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org>
---
sound/soc/soc-core.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/sound/soc/soc-core.c b/sound/soc/soc-core.c
index 2d3520fca613..7abb017a83f3 100644
--- a/sound/soc/soc-core.c
+++ b/sound/soc/soc-core.c
@@ -3113,10 +3113,7 @@ static int snd_soc_component_initialize(struct snd_soc_component *component,
{
struct snd_soc_dapm_context *dapm;
- if (driver->name)
- component->name = kstrdup(driver->name, GFP_KERNEL);
- else
- component->name = fmt_single_name(dev, &component->id);
+ component->name = fmt_single_name(dev, &component->id);
if (!component->name) {
dev_err(dev, "ASoC: Failed to allocate name\n");
return -ENOMEM;
--
2.7.4
^ permalink raw reply [flat|nested] only message in thread
only message in thread, other threads:[~2019-05-31 10:31 UTC | newest]
Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-05-31 10:31 [PATCH] Revert "ASoC: core: use component driver name as component name" Krzysztof Kozlowski
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®