* verify_pefile_signature() and a message field of MZ header in pe.h
@ 2017-05-30 7:10 AKASHI Takahiro
2017-05-30 9:41 ` Ard Biesheuvel
2017-05-30 15:47 ` David Howells
0 siblings, 2 replies; 3+ messages in thread
From: AKASHI Takahiro @ 2017-05-30 7:10 UTC (permalink / raw)
To: dhowells; +Cc: ard.biesheuvel, keyrings, linux-kernel
Hi David,
Struct mz_hdr in include/linux/pe.h contains a message[] field.
Should it be part of this structure?
(I googled "MZ format," but didn't find out the exact definition.)
I'm now working on kexec_file_load support on arm64. As arm64's
Image binary can be seen as in PE format, verify_pefile_signature()
is used to assure integrity as on x86.
But this attempt fails (ELIBBAD) at pefile_parse_binary():
---8<---
#define chkaddr(base, x, s) \
do { \
if ((x) < base || (s) >= datalen || (x) > datalen - (s)) \
return -ELIBBAD; \
} while (0)
...
cursor = sizeof(*mz);
chkaddr(cursor, mz->peaddr, sizeof(*pe)); <-- Here
pe = pebuf + mz->peaddr;
if (pe->magic != PE_MAGIC)
return -ELIBBAD;
--->8---
because our Image doesn't have message[] in a pseudo header and so
mz->peaddr is not beyond sizeof(*mz).
I think we can fix this issue, either
(a) remove message[] from struct mz_hdr
(b) modify a check by chkaddr() macro
(c) add a dummy pad into arm64's binary
Which one should we follow here?
Thanks,
-Takahiro AKASHI
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: verify_pefile_signature() and a message field of MZ header in pe.h
2017-05-30 7:10 verify_pefile_signature() and a message field of MZ header in pe.h AKASHI Takahiro
@ 2017-05-30 9:41 ` Ard Biesheuvel
2017-05-30 15:47 ` David Howells
1 sibling, 0 replies; 3+ messages in thread
From: Ard Biesheuvel @ 2017-05-30 9:41 UTC (permalink / raw)
To: AKASHI Takahiro, David Howells, Ard Biesheuvel, keyrings, linux-kernel
On 30 May 2017 at 07:10, AKASHI Takahiro <takahiro.akashi@linaro.org> wrote:
> Hi David,
>
> Struct mz_hdr in include/linux/pe.h contains a message[] field.
> Should it be part of this structure?
> (I googled "MZ format," but didn't find out the exact definition.)
>
MZ format does not exist. It is the magic number of the DOS header,
and MZ are the initials of one of the MS-DOS developers.
> I'm now working on kexec_file_load support on arm64. As arm64's
> Image binary can be seen as in PE format, verify_pefile_signature()
> is used to assure integrity as on x86.
> But this attempt fails (ELIBBAD) at pefile_parse_binary():
>
> ---8<---
> #define chkaddr(base, x, s) \
> do { \
> if ((x) < base || (s) >= datalen || (x) > datalen - (s)) \
> return -ELIBBAD; \
> } while (0)
>
> ...
>
> cursor = sizeof(*mz);
>
> chkaddr(cursor, mz->peaddr, sizeof(*pe)); <-- Here
> pe = pebuf + mz->peaddr;
> if (pe->magic != PE_MAGIC)
> return -ELIBBAD;
> --->8---
>
> because our Image doesn't have message[] in a pseudo header and so
> mz->peaddr is not beyond sizeof(*mz).
>
> I think we can fix this issue, either
> (a) remove message[] from struct mz_hdr
> (b) modify a check by chkaddr() macro
> (c) add a dummy pad into arm64's binary
>
> Which one should we follow here?
>
I think the simplest yet correct approach is to omit the size from
'message', i.e.,
diff --git a/include/linux/pe.h b/include/linux/pe.h
index e170b95e763b..dbcd36ce9e49 100644
--- a/include/linux/pe.h
+++ b/include/linux/pe.h
@@ -43,7 +43,7 @@ struct mz_hdr {
uint16_t oem_info; /* oem specific */
uint16_t reserved1[10]; /* reserved */
uint32_t peaddr; /* address of pe header */
- char message[64]; /* message to print */
+ char message[]; /* message to print */
};
struct mz_reloc {
This is appropriate since we are not parsing random MS-DOS files here
but PE/COFF binaries, and the PE/COFF spec does not specify a minimum
size for the so-called MS-DOS stub, which populates the region between
the DOS and PE headers. It does specify that its purpose is MS-DOS 2.0
compatibility, which seems a bit pointless for PE/COFF on ARM/arm64
systems.
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: verify_pefile_signature() and a message field of MZ header in pe.h
2017-05-30 7:10 verify_pefile_signature() and a message field of MZ header in pe.h AKASHI Takahiro
2017-05-30 9:41 ` Ard Biesheuvel
@ 2017-05-30 15:47 ` David Howells
1 sibling, 0 replies; 3+ messages in thread
From: David Howells @ 2017-05-30 15:47 UTC (permalink / raw)
To: AKASHI Takahiro; +Cc: dhowells, ard.biesheuvel, keyrings, linux-kernel, pjones
AKASHI Takahiro <takahiro.akashi@linaro.org> wrote:
> Struct mz_hdr in include/linux/pe.h contains a message[] field.
> Should it be part of this structure?
You'd probably be better off asking Peter Jones - he wrote the original code
that I copied into the kernel.
David
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2017-05-30 15:47 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2017-05-30 7:10 verify_pefile_signature() and a message field of MZ header in pe.h AKASHI Takahiro
2017-05-30 9:41 ` Ard Biesheuvel
2017-05-30 15:47 ` David Howells
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®