* [PATCH] drm/panfrost: Add support for non-existent reset node
@ 2020-11-02 8:54 Yejune Deng
2020-11-02 9:11 ` Steven Price
0 siblings, 1 reply; 2+ messages in thread
From: Yejune Deng @ 2020-11-02 8:54 UTC (permalink / raw)
To: robh, tomeu.vizoso, steven.price, alyssa.rosenzweig, airlied,
daniel, p.zabel
Cc: dri-devel, linux-kernel, yejune.deng
Some dts hasn't no reset node, is should ok.
Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
---
drivers/gpu/drm/panfrost/panfrost_device.c | 10 ++++++++--
1 file changed, 8 insertions(+), 2 deletions(-)
diff --git a/drivers/gpu/drm/panfrost/panfrost_device.c b/drivers/gpu/drm/panfrost/panfrost_device.c
index ea8d318..a982878 100644
--- a/drivers/gpu/drm/panfrost/panfrost_device.c
+++ b/drivers/gpu/drm/panfrost/panfrost_device.c
@@ -18,7 +18,12 @@
static int panfrost_reset_init(struct panfrost_device *pfdev)
{
- pfdev->rstc = devm_reset_control_array_get(pfdev->dev, false, true);
+ pfdev->rstc = devm_reset_control_array_get_optional_exclusive(pfdev->dev);
+ if (!pfdev->rstc) {
+ dev_info(pfdev->dev, "reset does not exist\n");
+ return 0;
+ }
+
if (IS_ERR(pfdev->rstc)) {
dev_err(pfdev->dev, "get reset failed %ld\n", PTR_ERR(pfdev->rstc));
return PTR_ERR(pfdev->rstc);
@@ -29,7 +34,8 @@ static int panfrost_reset_init(struct panfrost_device *pfdev)
static void panfrost_reset_fini(struct panfrost_device *pfdev)
{
- reset_control_assert(pfdev->rstc);
+ if (pfdev->rstc)
+ reset_control_assert(pfdev->rstc);
}
static int panfrost_clk_init(struct panfrost_device *pfdev)
--
1.9.1
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] drm/panfrost: Add support for non-existent reset node
2020-11-02 8:54 [PATCH] drm/panfrost: Add support for non-existent reset node Yejune Deng
@ 2020-11-02 9:11 ` Steven Price
0 siblings, 0 replies; 2+ messages in thread
From: Steven Price @ 2020-11-02 9:11 UTC (permalink / raw)
To: Yejune Deng, robh, tomeu.vizoso, alyssa.rosenzweig, airlied,
daniel, p.zabel
Cc: dri-devel, linux-kernel
On 02/11/2020 08:54, Yejune Deng wrote:
> Some dts hasn't no reset node, is should ok.
>
> Signed-off-by: Yejune Deng <yejune.deng@gmail.com>
> ---
> drivers/gpu/drm/panfrost/panfrost_device.c | 10 ++++++++--
> 1 file changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/gpu/drm/panfrost/panfrost_device.c b/drivers/gpu/drm/panfrost/panfrost_device.c
> index ea8d318..a982878 100644
> --- a/drivers/gpu/drm/panfrost/panfrost_device.c
> +++ b/drivers/gpu/drm/panfrost/panfrost_device.c
> @@ -18,7 +18,12 @@
>
> static int panfrost_reset_init(struct panfrost_device *pfdev)
> {
> - pfdev->rstc = devm_reset_control_array_get(pfdev->dev, false, true);
> + pfdev->rstc = devm_reset_control_array_get_optional_exclusive(pfdev->dev);
This change is fine - it should have no functional change and makes the
code more readable.
> + if (!pfdev->rstc) {
> + dev_info(pfdev->dev, "reset does not exist\n");
I don't think this output is particularly useful.
> + return 0;
The early return isn't necessary. IS_ERR(NULL) is false, and
reset_control_deassert() deals fine with NULL, so the path below would
be fine.
> + }
> +
> if (IS_ERR(pfdev->rstc)) {
> dev_err(pfdev->dev, "get reset failed %ld\n", PTR_ERR(pfdev->rstc));
> return PTR_ERR(pfdev->rstc);
> @@ -29,7 +34,8 @@ static int panfrost_reset_init(struct panfrost_device *pfdev)
>
> static void panfrost_reset_fini(struct panfrost_device *pfdev)
> {
> - reset_control_assert(pfdev->rstc);
> + if (pfdev->rstc)
> + reset_control_assert(pfdev->rstc);
reset_control_assert() deals fine with a NULL input, so this is unneeded.
> }
>
> static int panfrost_clk_init(struct panfrost_device *pfdev)
>
Have you actually seen a problem on a platform without a reset node - it
works fine for me and I can't see any functional change with this patch.
Steve
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2020-11-02 9:11 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-11-02 8:54 [PATCH] drm/panfrost: Add support for non-existent reset node Yejune Deng
2020-11-02 9:11 ` Steven Price
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®