mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 net-next 0/5] lynx pcs interface cleanup
@ 2021-12-29  5:03 Colin Foster
  2021-12-29  5:03 ` [PATCH v2 net-next 1/5] net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs Colin Foster
                   ` (5 more replies)
  0 siblings, 6 replies; 7+ messages in thread
From: Colin Foster @ 2021-12-29  5:03 UTC (permalink / raw)
  To: linux-kernel, netdev
  Cc: Russell King, Heiner Kallweit, Ioana Ciornei, Jakub Kicinski,
	David S. Miller, Florian Fainelli, Vivien Didelot, Andrew Lunn,
	UNGLinuxDriver, Alexandre Belloni, Claudiu Manoil,
	Vladimir Oltean

The current Felix driver (and Seville) rely directly on the lynx_pcs
device. There are other possible PCS interfaces that can be used with
this hardware, so this should be abstracted from felix. The generic
phylink_pcs is used instead.

While going through the code, there were some opportunities to change
some misleading variable names. Those are included in this patch set.

v1->v2
    * compile-time fixes for freescale parts


Colin Foster (5):
  net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs
  net: dsa: felix: name change for clarity from pcs to mdio_device
  net: dsa: seville: name change for clarity from pcs to mdio_device
  net: ethernet: enetc: name change for clarity from pcs to mdio_device
  net: pcs: lynx: use a common naming scheme for all lynx_pcs variables

 drivers/net/dsa/ocelot/felix.c                |  3 +-
 drivers/net/dsa/ocelot/felix.h                |  2 +-
 drivers/net/dsa/ocelot/felix_vsc9959.c        | 28 ++++++++-------
 drivers/net/dsa/ocelot/seville_vsc9953.c      | 28 ++++++++-------
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.c  | 13 ++++---
 .../net/ethernet/freescale/dpaa2/dpaa2-mac.h  |  3 +-
 .../net/ethernet/freescale/enetc/enetc_pf.c   | 28 ++++++++-------
 .../net/ethernet/freescale/enetc/enetc_pf.h   |  4 +--
 drivers/net/pcs/pcs-lynx.c                    | 36 +++++++++++++------
 include/linux/pcs-lynx.h                      |  9 ++---
 10 files changed, 88 insertions(+), 66 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2022-01-02 19:00 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-29  5:03 [PATCH v2 net-next 0/5] lynx pcs interface cleanup Colin Foster
2021-12-29  5:03 ` [PATCH v2 net-next 1/5] net: phy: lynx: refactor Lynx PCS module to use generic phylink_pcs Colin Foster
2021-12-29  5:03 ` [PATCH v2 net-next 2/5] net: dsa: felix: name change for clarity from pcs to mdio_device Colin Foster
2021-12-29  5:03 ` [PATCH v2 net-next 3/5] net: dsa: seville: " Colin Foster
2021-12-29  5:03 ` [PATCH v2 net-next 4/5] net: ethernet: enetc: " Colin Foster
2021-12-29  5:03 ` [PATCH v2 net-next 5/5] net: pcs: lynx: use a common naming scheme for all lynx_pcs variables Colin Foster
2022-01-02 19:00 ` [PATCH v2 net-next 0/5] lynx pcs interface cleanup patchwork-bot+netdevbpf

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome