mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Indan Zupancic" <indan@nul.nu>
To: "Will Drewry" <wad@chromium.org>
Cc: linux-kernel@vger.kernel.org, linux-arch@vger.kernel.org,
	linux-doc@vger.kernel.org, kernel-hardening@lists.openwall.org,
	netdev@vger.kernel.org, x86@kernel.org, arnd@arndb.de,
	davem@davemloft.net, hpa@zytor.com, mingo@redhat.com,
	oleg@redhat.com, peterz@infradead.org, rdunlap@xenotime.net,
	mcgrathr@chromium.org, tglx@linutronix.de, luto@mit.edu,
	eparis@redhat.com, serge.hallyn@canonical.com, djm@mindrot.org,
	scarybeasts@gmail.com, pmoore@redhat.com,
	akpm@linux-foundation.org, corbet@lwn.net,
	eric.dumazet@gmail.com, markus@chromium.org,
	keescook@chromium.org
Subject: Re: [PATCH v8 1/8] sk_run_filter: add support for custom load_pointer
Date: Fri, 17 Feb 2012 06:05:03 +0100	[thread overview]
Message-ID: <16a5b39e58f3e0bf112918ca032dc4c0.squirrel@webmail.greenhost.nl> (raw)
In-Reply-To: <CABqD9hYBs6fnmnDKwkkJCnbfji8NU06_Z6m+am=aJQDbYEJr_Q@mail.gmail.com>

On Fri, February 17, 2012 05:13, Will Drewry wrote:
> On Thu, Feb 16, 2012 at 9:04 PM, Indan Zupancic <indan@nul.nu> wrote:
>>> Hello,
>>>
>>> On Thu, February 16, 2012 21:02, Will Drewry wrote:
>>>> This change allows CONFIG_SECCOMP to make use of BPF programs for
>>>> user-controlled system call filtering (as shown in this patch series).
>>>>
>>>> To minimize the impact on existing BPF evaluation, function pointer
>>>> use must be declared at sk_chk_filter-time.  This allows ancillary
>>>> load instructions to be generated that use the function pointer rather
>>>> than adding _any_ code to the existing LD_* instruction paths.
>>>>
>>>> Crude performance numbers using udpflood -l 10000000 against dummy0.
>>>> 3 trials for baseline, 3 for with tcpdump. Averaged then differenced.
>>>> Hard to believe trials were repeated at least a couple more times.
>>>>
>>>> * x86 32-bit (Atom N570 @ 1.66 GHz 2 core HT) [stackprot]:
>>>> - Without:  94.05s - 76.36s = 17.68s
>>>> - With:     86.22s - 73.30s = 12.92s
>>>> - Slowdown per call: -476 nanoseconds
>>>>
>>>> * x86 32-bit (Atom N570 @ 1.66 GHz 2 core HT) [no stackprot]:
>>>> - Without:  92.06s - 77.81s = 14.25s
>>>> - With:     91.77s - 76.91s = 14.86s
>>>> - Slowdown per call: +61 nanoseconds
>>>>
>>>> * x86 64-bit (Atom N570 @ 1.66 GHz 2 core HT) [stackprot]:
>>>> - Without: 122.58s - 99.54s = 23.04s
>>>> - With:    115.52s - 98.99s = 16.53s
>>>> - Slowdown per call:  -651 nanoseconds
>>>>
>>>> * x86 64-bit (Atom N570 @ 1.66 GHz 2 core HT) [no stackprot]:
>>>> - Without: 114.95s - 91.92s = 23.03s
>>>> - With:    110.47s - 90.79s = 19.68s
>>>> - Slowdown per call: -335 nanoseconds
>>>>
>>>> This makes the x86-32-nossp make sense.  Added register pressure always
>>>> makes x86-32 sad.
>>>
>>> Your 32-bit numbers are better than your 64-bit numbers, so I don't get
>>> this comment.
>
> They are in the absolute.  Relatively, all performance improved with
> my patch except for x86-nossp.

Why is 32-bit sad if it's faster than the 64-bit version?

I'd say the 64-bit numbers are sad considering the extra registers.

>>> Yeah, testing on Atom is a bit silly.
>
> Making things run well on Atom is important for my daily work.  And it
> usually means (barring Atom-specific weirdness) that it then runs even
> better on bigger processors :)

Fair enough!

>>>> +#define SKB(_data) ((const struct sk_buff *)(_data))
>>>
>>> Urgh!
>>>
>>> If you had done:
>>>                const struct sk_buff *skb = data;
>>>
>>> at the top, all those changed wouldn't be needed and it would look better too.
>
> That just means I need to disassemble after to make sure the compiler
> does the right thing.  I'll do that and change it if gcc is doing the
> right thing.

You're telling the compiler the same thing, so it better do the right thing!
It just looks better.

>>> These two should either return 0, be networking-only, just return 0/-1 or
>>> use a constant length.
>
> I'm changing it to constant length, but I can get rid of it
> altogether. I don't care either way, it just depends on if there is
> anyone else who will want this support.

Right now there is no one else.

>>>> +#define MAYBE_USE_LOAD_FN(CODE) \
>>>> +                     if (flags & BPF_CHK_FLAGS_NO_SKB) { \
>>>> +                             code = BPF_S_ANC_##CODE; \
>>>> +                             break; \
>>>> +                     }
>>>
>>> You can as well hide everything in the macro then, including the case,
>>> like the ANCILLARY() macro does.
>
> I'm not sure that would make it any more readable though, especially
> since I don't always break; after.

Ah, true. Because there was a break; in the macro, I assumed it would
always break, for some reason. I wish there was a way to make it look
nice though, it's so ugly.

>
>>>> +             case BPF_S_LD_W_LEN:
>>>> +                     MAYBE_USE_LOAD_FN(LD_W_LEN);
>>>> +                     break;
>>>> +             case BPF_S_LDX_W_LEN:
>>>> +                     MAYBE_USE_LOAD_FN(LDX_W_LEN);
>>>> +                     break;
>>>> +             case BPF_S_LD_W_IND:
>>>> +                     MAYBE_USE_LOAD_FN(LD_W_IND);
>>>> +                     break;
>>>> +             case BPF_S_LD_H_IND:
>>>> +                     MAYBE_USE_LOAD_FN(LD_H_IND);
>>>> +                     break;
>>>> +             case BPF_S_LD_B_IND:
>>>> +                     MAYBE_USE_LOAD_FN(LD_B_IND);
>>>> +                     break;
>>>> +             case BPF_S_LDX_B_MSH:
>>>> +                     MAYBE_USE_LOAD_FN(LDX_B_MSH);
>>>> +                     break;
>>>>               case BPF_S_LD_W_ABS:
>>>> +                     MAYBE_USE_LOAD_FN(LD_W_ABS);
>>>>               case BPF_S_LD_H_ABS:
>>>> +                     MAYBE_USE_LOAD_FN(LD_H_ABS);
>>>>               case BPF_S_LD_B_ABS:
>>>> +                     MAYBE_USE_LOAD_FN(LD_B_ABS);
>>>>  #define ANCILLARY(CODE) case SKF_AD_OFF + SKF_AD_##CODE:     \
>>>>                               code = BPF_S_ANC_##CODE;        \
>>>>                               break
>>>> @@ -572,7 +658,7 @@ int sk_chk_filter(struct sock_filter *filter, unsigned int flen)
>>>>       }
>>>>       return -EINVAL;
>>>>  }
>>>> -EXPORT_SYMBOL(sk_chk_filter);
>>>> +EXPORT_SYMBOL(bpf_chk_filter);
>>>>
>>>>  /**
>>>>   *   sk_filter_release_rcu - Release a socket filter by rcu_head
>>>> --
>>>> 1.7.5.4
>>>>
>>>
>>> Greetings,
>
> Thanks!

You're welcome!

Indan



      reply	other threads:[~2012-02-17  5:05 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-02-16 20:02 Will Drewry
2012-02-16 20:02 ` [PATCH v8 2/8] seccomp: kill the seccomp_t typedef Will Drewry
2012-02-20  2:55   ` James Morris
2012-02-16 20:02 ` [PATCH v8 3/8] seccomp: add system call filtering using BPF Will Drewry
2012-02-16 20:06   ` H. Peter Anvin
2012-02-16 20:25     ` Will Drewry
2012-02-16 21:17       ` H. Peter Anvin
2012-02-16 21:28         ` Markus Gutschke
2012-02-16 21:34           ` H. Peter Anvin
2012-02-16 21:51             ` Will Drewry
2012-02-16 22:06               ` H. Peter Anvin
2012-02-16 23:00                 ` Will Drewry
2012-02-17  0:23                   ` Andrew Lutomirski
2012-02-17  0:43                   ` H. Peter Anvin
2012-02-17  0:50                   ` Eric Paris
2012-02-17  2:24                     ` H. Peter Anvin
2012-02-17  3:53                     ` Will Drewry
2012-02-17  4:12                       ` H. Peter Anvin
2012-02-17  4:26                         ` Will Drewry
2012-02-17  4:32                           ` H. Peter Anvin
2012-02-17  4:40                             ` Will Drewry
2012-02-16 21:31         ` Will Drewry
2012-02-17  0:48         ` Indan Zupancic
2012-02-17  0:51           ` Andrew Lutomirski
2012-02-17  1:10             ` H. Peter Anvin
2012-02-17  1:25             ` Indan Zupancic
2012-02-17  1:33           ` H. Peter Anvin
2012-02-17  2:00             ` Indan Zupancic
2012-02-17  2:16               ` Andrew Lutomirski
2012-02-17  2:22                 ` H. Peter Anvin
2012-02-17  3:27                   ` Indan Zupancic
2012-02-17  4:09                     ` H. Peter Anvin
2012-02-17  4:51                       ` Indan Zupancic
2012-02-17  2:44   ` Indan Zupancic
2012-02-17  3:38     ` [kernel-hardening] " Will Drewry
2012-02-16 20:02 ` [PATCH v8 4/8] seccomp: add SECCOMP_RET_ERRNO Will Drewry
2012-02-16 20:02 ` [PATCH v8 5/8] seccomp: Add SECCOMP_RET_TRAP Will Drewry
     [not found]   ` <CAE6n16mCrJC=Sre+PT1H_VfSjW0MGyi0xtEcdcRvGMvvwXWzmA@mail.gmail.com>
2012-02-16 20:28     ` Markus Gutschke
2012-02-16 21:23       ` H. Peter Anvin
2012-02-16 20:42     ` Will Drewry
2012-02-16 21:11       ` [PATCH v9 " Will Drewry
2012-02-16 21:11         ` [PATCH v9 8/8] Documentation: prctl/seccomp_filter Will Drewry
2012-02-16 21:28       ` [PATCH v8 5/8] seccomp: Add SECCOMP_RET_TRAP H. Peter Anvin
2012-02-16 21:33         ` Will Drewry
2012-02-16 20:02 ` [PATCH v8 6/8] ptrace,seccomp: Add PTRACE_SECCOMP support Will Drewry
2012-02-17  5:08   ` Indan Zupancic
2012-02-17 16:23     ` Will Drewry
2012-02-17 22:55       ` Indan Zupancic
2012-02-21 17:31         ` Will Drewry
2012-02-16 20:02 ` [PATCH v8 7/8] x86: Enable HAVE_ARCH_SECCOMP_FILTER Will Drewry
2012-02-16 20:02 ` [PATCH v8 8/8] Documentation: prctl/seccomp_filter Will Drewry
2012-02-16 20:08 ` [PATCH v8 1/8] sk_run_filter: add support for custom load_pointer Will Drewry
2012-02-17  1:54 ` Joe Perches
2012-02-17  2:22   ` Will Drewry
2012-02-17  3:04 ` Indan Zupancic
2012-02-17  4:13   ` Will Drewry
2012-02-17  5:05     ` Indan Zupancic [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=16a5b39e58f3e0bf112918ca032dc4c0.squirrel@webmail.greenhost.nl \
    --to=indan@nul.nu \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=corbet@lwn.net \
    --cc=davem@davemloft.net \
    --cc=djm@mindrot.org \
    --cc=eparis@redhat.com \
    --cc=eric.dumazet@gmail.com \
    --cc=hpa@zytor.com \
    --cc=keescook@chromium.org \
    --cc=kernel-hardening@lists.openwall.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@mit.edu \
    --cc=markus@chromium.org \
    --cc=mcgrathr@chromium.org \
    --cc=mingo@redhat.com \
    --cc=netdev@vger.kernel.org \
    --cc=oleg@redhat.com \
    --cc=peterz@infradead.org \
    --cc=pmoore@redhat.com \
    --cc=rdunlap@xenotime.net \
    --cc=scarybeasts@gmail.com \
    --cc=serge.hallyn@canonical.com \
    --cc=tglx@linutronix.de \
    --cc=wad@chromium.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®